summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-28 13:38:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:04:00 -0500
commit5696764da95a1ea14202333b71ae78573c910c7e (patch)
tree2e1d6ee6ae52f8d7b3afc0914213711d8323ef24
parent1e01fcc1e7d6df3ca7c4292058b875f5c757bb00 (diff)
downloadpackages-5696764da95a1ea14202333b71ae78573c910c7e.tar.gz
packages-5696764da95a1ea14202333b71ae78573c910c7e.tar.bz2
packages-5696764da95a1ea14202333b71ae78573c910c7e.tar.xz
packages-5696764da95a1ea14202333b71ae78573c910c7e.zip
user/libnih: Fix for GCC -fno-common
-rw-r--r--user/libnih/APKBUILD6
-rw-r--r--user/libnih/gcc10.patch15
2 files changed, 19 insertions, 2 deletions
diff --git a/user/libnih/APKBUILD b/user/libnih/APKBUILD
index a1bd5883e..523b8a1a9 100644
--- a/user/libnih/APKBUILD
+++ b/user/libnih/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libnih
pkgver=1.0.3
-pkgrel=6
+pkgrel=7
pkgdesc="GLib-like library for embedded use"
url="https://launchpad.net/libnih"
arch="all"
@@ -18,6 +18,7 @@ source="https://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}
disable-broken-test.patch
musl-enomem-message.patch
parse-test-fix.patch
+ gcc10.patch
"
prepare() {
@@ -48,4 +49,5 @@ sha512sums="fce40d2445b28c27b8838631681ca3206a4f053b2dd4fc488fc9ef98bbd3d933e3d6
77a979b3076c4e4229359f28c2e9d4fb66d799a66d60391ab6fd7e0dfe2a615b88330a979877b105293a95ed147546596eca174f52b75beca0457c49a017d040 musl-fix-signals.patch
b5b77b1f18d7aa5d603a0d312b785c28200c38b7bbe5c384ee576c762bd9e3163682c29dd5410baf18c5c3734f0b719602caa1de096f1758d624d94b7753066a disable-broken-test.patch
b800c99153ad66c9d7399bc7544a0237de0c7a4ddac129509f13eb1c31805fcac31c93bbf2945da557dfc900c9ec837ec0fded1c3f9887095dae52ff6fc046ec musl-enomem-message.patch
-3f24f648c27e9b5a6872859fe97b34055b0f43b11f0321508852b20b6dd94de5c8d24a6dbaab9d49e7004bf0c571c11ebf520d49630d8a89bceeb7783de7dcd2 parse-test-fix.patch"
+3f24f648c27e9b5a6872859fe97b34055b0f43b11f0321508852b20b6dd94de5c8d24a6dbaab9d49e7004bf0c571c11ebf520d49630d8a89bceeb7783de7dcd2 parse-test-fix.patch
+e2fc351e68ab194723b95a37b4b78c726ef9d7bda173ae51816f979f2f1385f1e776052b75b949cdd794da0cdb53e270fb7a950dc68f2d818ccb1f0013664e0c gcc10.patch"
diff --git a/user/libnih/gcc10.patch b/user/libnih/gcc10.patch
new file mode 100644
index 000000000..a118b1f53
--- /dev/null
+++ b/user/libnih/gcc10.patch
@@ -0,0 +1,15 @@
+GCC 10+ use -fno-common by default, which means we need to declare this 'extern'.
+
+There is no upstream to send this to.
+
+--- libnih-1.0.3/nih-dbus-tool/output.h.old 2010-09-20 18:17:01.000000000 -0500
++++ libnih-1.0.3/nih-dbus-tool/output.h 2024-05-28 13:22:58.501847205 -0500
+@@ -27,7 +27,7 @@
+
+ NIH_BEGIN_EXTERN
+
+-char *output_package;
++extern char *output_package;
+
+ int output (const char *source_path, int source_fd,
+ const char *header_path, int header_fd,