summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-30 17:47:53 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:04:12 -0500
commit84b0afb245fd31cb3ca7feaada445be58f3e7acb (patch)
tree66a62a7feb68f9230b3e22cc893469077fbeb79c
parent94b622747dc95fd957e487e38d6842284526bdbd (diff)
downloadpackages-84b0afb245fd31cb3ca7feaada445be58f3e7acb.tar.gz
packages-84b0afb245fd31cb3ca7feaada445be58f3e7acb.tar.bz2
packages-84b0afb245fd31cb3ca7feaada445be58f3e7acb.tar.xz
packages-84b0afb245fd31cb3ca7feaada445be58f3e7acb.zip
user/mosh: Update to 1.4.0
-rw-r--r--user/mosh/APKBUILD10
-rw-r--r--user/mosh/fix-ppc64le-build-with-musl.patch53
2 files changed, 4 insertions, 59 deletions
diff --git a/user/mosh/APKBUILD b/user/mosh/APKBUILD
index d138bd4f3..728719767 100644
--- a/user/mosh/APKBUILD
+++ b/user/mosh/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=mosh
-pkgver=1.3.2
-pkgrel=2
+pkgver=1.4.0
+pkgrel=0
pkgdesc="Mobile shell surviving disconnects with local echo and line editing"
url="https://mosh.org"
arch="all"
@@ -13,8 +13,7 @@ makedepends="ncurses-dev zlib-dev openssl-dev perl-dev perl-io-tty
protobuf-dev automake autoconf libtool gzip"
subpackages="$pkgname-doc $pkgname-client $pkgname-server
$pkgname-bash-completion:bashcomp:noarch"
-source="https://mosh.org/$pkgname-$pkgver.tar.gz
- fix-ppc64le-build-with-musl.patch"
+source="https://github.com/mobile-shell/mosh/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -70,5 +69,4 @@ client() {
"$subpkgdir"/usr/bin/
}
-sha512sums="f400e8fe7ba2ab7362311fc12a00ec69587505f901988aeee500fc68d38a388218500a3f602111c883ff23a9d43572114fcf0a8bf505df203691e5b597615769 mosh-1.3.2.tar.gz
-a276dde98a2dab63ad9c9c05468c55983a95f482878c5694713810b561eae1ea5618efc72431a17ee5b5014b12ee9709c6a8cbf582620294e7888cc837cd073c fix-ppc64le-build-with-musl.patch"
+sha512sums="38c11f52ff1e42965b50a22bf6de80b0fa8ebbff841d825e760abf69c788a2bf5f34e6f7fc047574d595118334eef9edf8da5520b52cdde3ac1a79d7ad70312e mosh-1.4.0.tar.gz"
diff --git a/user/mosh/fix-ppc64le-build-with-musl.patch b/user/mosh/fix-ppc64le-build-with-musl.patch
deleted file mode 100644
index 8d918a963..000000000
--- a/user/mosh/fix-ppc64le-build-with-musl.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Roberto Oliveira <robertoguimaraes8@gmail.com>
-Date: Tue, 4 Apr 2017 16:46:50 +0000
-Subject: [PATCH] Fix build with musl on ppc64le
-
-mosh was breaking when building in ppc64le using musl, because ioctl() is defined
-as ioctl(int, int) in musl and mosh is using TIOCSWINSZ macro as parameter. This was
-triggering a gcc warning and make the build fail.
-
-This patch does an explicit integer conversion in TIOCSWINSZ, as no bits get
-lost.
-
---- a/src/frontend/mosh-server.cc
-+++ b/src/frontend/mosh-server.cc
-@@ -714,7 +714,12 @@
- }
- window_size.ws_col = res->width;
- window_size.ws_row = res->height;
-- if ( ioctl( host_fd, TIOCSWINSZ, &window_size ) < 0 ) {
-+
-+ #if defined(__powerpc64__) && (!defined(__GLIBC__) && !defined(__UCLIBC__))
-+ if ( ioctl( host_fd, (int) TIOCSWINSZ, &window_size ) < 0 ) {
-+ #else
-+ if ( ioctl( host_fd, TIOCSWINSZ, &window_size ) < 0 ) {
-+ #endif
- perror( "ioctl TIOCSWINSZ" );
- network.start_shutdown();
- }
---- a/src/examples/termemu.cc
-+++ a/src/examples/termemu.cc
-@@ -226,7 +226,11 @@
- }
-
- /* tell child process */
-+ #if defined(__powerpc64__) && (!defined(__GLIBC__) && !defined(__UCLIBC__))
-+ if ( ioctl( fd, (int) TIOCSWINSZ, &window_size ) < 0 ) {
-+ #else
- if ( ioctl( fd, TIOCSWINSZ, &window_size ) < 0 ) {
-+ #endif
- perror( "ioctl TIOCSWINSZ" );
- return;
- }
-@@ -306,7 +310,11 @@
- complete.act( &r );
-
- /* tell child process */
-+ #if defined(__powerpc64__) && (!defined(__GLIBC__) && !defined(__UCLIBC__))
-+ if ( ioctl( fd, (int) TIOCSWINSZ, &window_size ) < 0 ) {
-+ #else
- if ( ioctl( fd, TIOCSWINSZ, &window_size ) < 0 ) {
-+ #endif
- perror( "ioctl TIOCSWINSZ" );
- return;
- }