summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-12-04 19:33:51 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-12-04 19:33:51 -0600
commit2a6a510a69b9cc71fcce9872f7bd4c4fa3e229b5 (patch)
treefd272d3386506c55544aeb1329949f29e4547730
parent7061ac5d9c1f86f1506bad6d3be44b74dd3cd80e (diff)
downloadpackages-2a6a510a69b9cc71fcce9872f7bd4c4fa3e229b5.tar.gz
packages-2a6a510a69b9cc71fcce9872f7bd4c4fa3e229b5.tar.bz2
packages-2a6a510a69b9cc71fcce9872f7bd4c4fa3e229b5.tar.xz
packages-2a6a510a69b9cc71fcce9872f7bd4c4fa3e229b5.zip
meta-desktop/kde-{games,utilities}: new packages
-rw-r--r--meta-desktop/kde-games/Manifest1
-rw-r--r--meta-desktop/kde-games/kde-games-16.04.3.ebuild41
-rw-r--r--meta-desktop/kde-utilities/Manifest1
-rw-r--r--meta-desktop/kde-utilities/kde-utilities-15.12.3.ebuild55
4 files changed, 98 insertions, 0 deletions
diff --git a/meta-desktop/kde-games/Manifest b/meta-desktop/kde-games/Manifest
new file mode 100644
index 000000000..7bed549d8
--- /dev/null
+++ b/meta-desktop/kde-games/Manifest
@@ -0,0 +1 @@
+DIST kde-games-16.04.3.tar.xz 408 SHA256 4714734879d641dc679092bd339a299b03b1569ef71353081dabdee1da479259 SHA512 c5ffd2f8eebab1a44045ede0122f376a82e3953b100389468b47cb2a0dd118cda8af2f072677415016c37b6dc56fb416ccc4ba662b891e95e85d9fb72ab409f8 WHIRLPOOL e8777c77311005a6ce71732d96190d5ab12ea061bbffde83ad6b8f50beb1c47fccc52277c5ec1641037aa91875c0bb86022a8e2200bdeb68c4092010a7784b26
diff --git a/meta-desktop/kde-games/kde-games-16.04.3.ebuild b/meta-desktop/kde-games/kde-games-16.04.3.ebuild
new file mode 100644
index 000000000..a0f426681
--- /dev/null
+++ b/meta-desktop/kde-games/kde-games-16.04.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=6
+
+DESCRIPTION="Games and toys from the KDE Software Collection"
+HOMEPAGE="https://www.kde.org/applications/games/"
+SRC_URI="mirror://foxkit/meta/${P}.tar.xz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="arm ppc ppc64 x86 x86_64"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/bovo-${PV}
+ >=kde-apps/granatier-${PV}
+ >=kde-apps/kapman-${PV}
+ >=kde-apps/kblocks-${PV}
+ >=kde-apps/kbreakout-${PV}
+ >=kde-apps/kdiamond-${PV}
+ >=kde-apps/kfourinline-${PV}
+ >=kde-apps/kiriki-${PV}
+ >=kde-apps/klickety-${PV}
+ >=kde-apps/klines-${PV}
+ >=kde-apps/kmahjongg-${PV}
+ >=kde-apps/kmines-${PV}
+ >=kde-apps/knetwalk-${PV}
+ >=kde-apps/kshisen-${PV}
+ >=kde-apps/ksquares-${PV}
+"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils
+"
+
+src_install() {
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+
+ doins org.adelie-linux.about-games.desktop
+}
diff --git a/meta-desktop/kde-utilities/Manifest b/meta-desktop/kde-utilities/Manifest
new file mode 100644
index 000000000..2e2b2c282
--- /dev/null
+++ b/meta-desktop/kde-utilities/Manifest
@@ -0,0 +1 @@
+DIST kde-utilities-15.12.3.tar.xz 424 SHA256 120291e9f0fefb3f61722d39b631476f65a326c21b2b5003d5389e3b9d28a8b7 SHA512 ac50c98b78e05418e58cef0dbc0c84a524e50b4ac7b2341ee0c12e8b43fb5754d1bbb56acc12cd8abf7575ac17b28243e5e1604fd804595bfc266195fc2eb303 WHIRLPOOL b2e1a0c76af25bd6f4111bd1668148269367ff07b465ecd5b14e2dd6874f12bcd89413de22378613e4ae6de27176aabeb4a602ed9cadf16edf974c944f54a61e
diff --git a/meta-desktop/kde-utilities/kde-utilities-15.12.3.ebuild b/meta-desktop/kde-utilities/kde-utilities-15.12.3.ebuild
new file mode 100644
index 000000000..c27d2ed84
--- /dev/null
+++ b/meta-desktop/kde-utilities/kde-utilities-15.12.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=6
+
+DESCRIPTION="Desktop utilities from the KDE Software Collection"
+HOMEPAGE="https://www.kde.org/applications/utilities/"
+SRC_URI="mirror://foxkit/meta/${P}.tar.xz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="arm ppc ppc64 x86 x86_64"
+IUSE="experimental kde4"
+
+DEPEND="
+ >=kde-apps/ark-${PV}
+ >=kde-apps/kate-${PV}
+ >=kde-apps/kcalc-${PV}
+ >=kde-apps/kcharselect-${PV}
+ x11-misc/kronometer:5
+ >=kde-apps/ktimer-${PV}
+ >=kde-apps/kwrite-${PV}
+ >=kde-apps/okteta-${PV}
+ kde-misc/rsibreak:5
+
+ x11-misc/xdg-utils
+
+ experimental? ( kde-apps/kfloppy:5 )
+
+ kde4? (
+ kde-apps/kalarm
+ kde-apps/kfilereplace
+ kde-apps/kfind
+ kde-apps/kgpg
+ kde-apps/kjots
+ kde-apps/kleopatra
+ kde-apps/kmag
+ kde-apps/kmousetool
+ kde-apps/kmouth
+ kde-apps/knotes
+ kde-misc/krecipes
+ kde-apps/kremotecontrol
+ kde-misc/krusader
+ kde-apps/ktimetracker
+ kde-apps/sweeper
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+
+ doins org.adelie-linux.about-utilities.desktop
+}