summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-09-29 23:35:20 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-09-29 23:35:20 +0000
commit693d3c8e25df7b049b330bfdc72fce50ee8e7302 (patch)
tree9c8e45129997ac64ae4d30059fb6ede8aacd1497
parent10392dc72a60f6066a547e8d94b8703131f7960a (diff)
parent2c9bb9acd2bdd83f4f7af074a39d5e5cd95f586d (diff)
downloadpackages-693d3c8e25df7b049b330bfdc72fce50ee8e7302.tar.gz
packages-693d3c8e25df7b049b330bfdc72fce50ee8e7302.tar.bz2
packages-693d3c8e25df7b049b330bfdc72fce50ee8e7302.tar.xz
packages-693d3c8e25df7b049b330bfdc72fce50ee8e7302.zip
Merge branch 'pyirc' into 'master'
Add PyIRC See merge request adelie/packages!342
-rw-r--r--user/py3-pyirc/APKBUILD30
-rw-r--r--user/py3-taillight/APKBUILD29
2 files changed, 59 insertions, 0 deletions
diff --git a/user/py3-pyirc/APKBUILD b/user/py3-pyirc/APKBUILD
new file mode 100644
index 000000000..edfbec00b
--- /dev/null
+++ b/user/py3-pyirc/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pyirc
+_pkgname=PyIRC
+reporev="e327ef9a8e7801ab9a418b10fe3c3df6738e4ea7"
+verbase=3.0b1
+pkgver=${verbase}_git20190929
+pkgrel=0
+pkgdesc="An extensible and easy-to-use IRC library for Python"
+url="https://foxkit-us.github.io/PyIRC/"
+arch="noarch"
+license="WTFPL OR LPRAB"
+depends="python3 py3-taillight~0.3"
+makedepends=""
+giturl="https://code.foxkit.us/IRC/PyIRC"
+source="https://dev.sick.bike/dist/$pkgname-$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m unittest discover -s tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0198aeae59e37f3bd94f96bedc294006049794dc208d6a7d18a0e07095d36fa921af08fb8a50be91022305a01304bb6202eb464b8861e595c71c5cf14f7c7850 py3-pyirc-3.0b1_git20190929.tar.gz"
diff --git a/user/py3-taillight/APKBUILD b/user/py3-taillight/APKBUILD
new file mode 100644
index 000000000..66058e581
--- /dev/null
+++ b/user/py3-taillight/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-taillight
+_pkgname=taillight
+pkgver=0.3b4
+pkgrel=0
+pkgdesc="Lightweight, thread-safe signal/slots system with priorities"
+url="https://github.com/Elizafox/taillight"
+arch="noarch"
+license="WTFPL OR LPRAB"
+depends="python3"
+makedepends=""
+# PyPI download doesn't include tests/
+source="https://dev.sick.bike/dist/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m unittest discover -s tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d54e2006d690b87ec7b96975c7d68f5954df993ffd3735100bcff91f3410f33a34b3a07fe22bb40aaad7364d63180b441302b171e52c1345cd90c709749a7bc8 py3-taillight-0.3b4.tar.gz"