summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2021-10-29 03:08:22 +0000
committerZach van Rijn <me@zv.io>2021-10-29 03:08:22 +0000
commitebe5b10441eb3889a40ad355c0e00806222e702e (patch)
tree9a0e60e5a6a380748598b01961879398787d9ab6
parent7430b52ee7e743a225f3ccb7b4326bb84c2f9c87 (diff)
parentad9bdf63fa5c1907ddd631a74f4bca942d9d021e (diff)
downloadpackages-ebe5b10441eb3889a40ad355c0e00806222e702e.tar.gz
packages-ebe5b10441eb3889a40ad355c0e00806222e702e.tar.bz2
packages-ebe5b10441eb3889a40ad355c0e00806222e702e.tar.xz
packages-ebe5b10441eb3889a40ad355c0e00806222e702e.zip
Merge branch 'awilfox/fix/2021-10-automated-builds' into 'master'
Fix automated builds for some packages See merge request adelie/packages!634
-rw-r--r--system/coreutils/APKBUILD4
-rw-r--r--system/easy-kernel/APKBUILD2
-rw-r--r--system/file/APKBUILD4
-rw-r--r--system/findutils/APKBUILD10
-rw-r--r--system/findutils/gnulib-test-datetime.patch24
-rw-r--r--system/findutils/xargs-test-hashbang.patch11
-rw-r--r--system/gmp/APKBUILD6
7 files changed, 25 insertions, 36 deletions
diff --git a/system/coreutils/APKBUILD b/system/coreutils/APKBUILD
index 71c10cca4..a91eaf7b8 100644
--- a/system/coreutils/APKBUILD
+++ b/system/coreutils/APKBUILD
@@ -54,7 +54,9 @@ build() {
}
check() {
- make check
+ # This prevents 'chgrp' tests from breaking inside APK Foundry.
+ env COREUTILS_GROUPS='build' make -C tests check
+ # We can't run gnulb-tests because of multiple chown failures.
}
package() {
diff --git a/system/easy-kernel/APKBUILD b/system/easy-kernel/APKBUILD
index a78758702..580e59ff9 100644
--- a/system/easy-kernel/APKBUILD
+++ b/system/easy-kernel/APKBUILD
@@ -144,7 +144,7 @@ e6a7a5933dbe638be42a1308fd64895e53fe38be1238016a560985127106356570e6ea6ba94e6fbf
9f5279d20fc6eaad78ab27b7fb86553e310369c8a68a2ff60c7cd9895febd3002cae748ad3a8b4fddbb62c6e829104138fc2bbca939e1c88c0bfcf7aa42809bf config-armv7
93ca6d54fc377db12dfa7cf230d362f82d635cd05166815389ef4fb2b065f8b2bba1a78d234bd6a7445dd9b475f2c0ca01e3d4528881cfd2c10040dab174cf6a config-m68k
5945f918daf441e1f92012b608d560b693f09d8fa36eb6c7ecb9935dec6163c5e64e04d7345b3b9c958a15d62878f33ac88a4e24d5fcc60381455842636bd1c7 config-pmmx
-18841b9837ab78e5baddb3fb0c05c1fab6ef8ca99e2fa52da283b78a8c38e314039a26bcb44857c8d40c411e0825033cf094a4c3b8bcbcca084922a9f5ef9b0e config-ppc
+3f9ac256e11b9e469086cbc0d3ec84e7bed4ec79fe40111418eb70786c9d62e8ef8d208472fa65f91b883b959112e40ace18d98314dfa9eeaace6aa821834f8b config-ppc
c61fa4613d0d75a5387d12c2f72dc8ba1e6635cc47cc9fb46253095c6417241ef59639ddf9ad220947804ef0dca921de7df5057b1d02d156bf955b213851aaff config-ppc64
f43ae12574c81f6e0161c547eff93d70ff4686e6ec1654edbdea10447e424218a33b81c664828f82617e4ef522128f2e0460da0c9523538724048174b53a7313 config-sparc64
557db84d1f45c91ed3e3ab5d0e7100766060507ae98632b735580813974e136343500f9683bb51dc3994277716651821523b476bc5143e636ebde14aa5e67f48 config-x86_64
diff --git a/system/file/APKBUILD b/system/file/APKBUILD
index 3825b4cd9..02f675d31 100644
--- a/system/file/APKBUILD
+++ b/system/file/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=file
-pkgver=5.40
+pkgver=5.41
pkgrel=0
pkgdesc="File type identification utility"
url="http://www.darwinsys.com/file/"
@@ -41,4 +41,4 @@ libmagic() {
mv "$pkgdir"/usr/lib "$pkgdir"/usr/share "$subpkgdir"/usr
}
-sha512sums="d76bfe5326e1b40368e055c2e049a24b4ffdbd727371f4f3aa1dd3f53787d16b88550b3cc71ecf02151e2fb3e567eb2598e4707badab8c391eb71113c2dcc319 file-5.40.tar.gz"
+sha512sums="efa94eec7f33b6d63e6a835987e83300accc2d81b6ea04e7bc031e4224594f96905bb5ffa8b0b3a5143084a8f5659349dffca9c78d9f444c1fd9b723ecb0c973 file-5.41.tar.gz"
diff --git a/system/findutils/APKBUILD b/system/findutils/APKBUILD
index dc97a9de3..2b2877abc 100644
--- a/system/findutils/APKBUILD
+++ b/system/findutils/APKBUILD
@@ -2,20 +2,20 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer:
pkgname=findutils
-pkgver=4.7.0
+pkgver=4.8.0
pkgrel=0
pkgdesc="GNU utilities to locate files"
url="https://www.gnu.org/software/findutils/"
arch="all"
license="GPL-3.0+"
depends=""
-checkdepends="coreutils diffutils dejagnu"
+checkdepends="bash coreutils diffutils dejagnu"
makedepends=""
subpackages="$pkgname-doc $pkgname-lang"
source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
gnulib-tests-dont-require-gpg-passphrase.patch
sysmacros.patch
- gnulib-test-datetime.patch
+ xargs-test-hashbang.patch
"
build() {
@@ -39,7 +39,7 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-sha512sums="650a24507f8f4ebff83ad28dd27daa4785b4038dcaadc4fe00823b976e848527074cce3f9ec34065b7f037436d2aa6e9ec099bc05d7472c29864ac2c69de7f2e findutils-4.7.0.tar.xz
+sha512sums="eaa2da304dbeb2cd659b9210ac37da1bde4cd665c12a818eca98541c5ed5cba1050641fc0c39c0a446a5a7a87a8d654df0e0e6b0cee21752ea485188c9f1071e findutils-4.8.0.tar.xz
dc7e9c4fdd36d05ca230e3456a8005a5fcd353db07181e0d17ab66db4eb967e6bdfe3b6f1da0edbb38e973fea89ae174ea31e6839f59d3084b15f08de363f139 gnulib-tests-dont-require-gpg-passphrase.patch
2e214511de4be47dc0df46a83d4102e4b59b5f02c4b8356a1ed0b26d481e17c6604bbf07071960f219ef85e1687878cce69a8be28c46638ee4ebe9f4ce0ed487 sysmacros.patch
-8e367ba108b66ea27b2a289e51acbdf540d7e7ab5dfb8347a007eaf763355707db43c44e530fbec40f47578405880ff99d34eec97570365f2ab3439c4f1bf358 gnulib-test-datetime.patch"
+05402edd764c068c90765ced7322cca7c2d41061fb68b6d412e4010b32aad148489d367bcc447a11fa774cf959d122ec6c63cc7a846d35dea936f1e0bad7aa1c xargs-test-hashbang.patch"
diff --git a/system/findutils/gnulib-test-datetime.patch b/system/findutils/gnulib-test-datetime.patch
deleted file mode 100644
index 2b227fc27..000000000
--- a/system/findutils/gnulib-test-datetime.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- coreutils-8.31/gnulib-tests/test-parse-datetime.c.old 2019-06-01 07:46:25.716292871 +0000
-+++ coreutils-8.31/gnulib-tests/test-parse-datetime.c 2019-06-01 22:07:59.456653669 +0000
-@@ -432,21 +432,5 @@
- ASSERT ( parse_datetime (&result, "TZ=\"\\\\\"", &now));
- ASSERT ( parse_datetime (&result, "TZ=\"\\\"\"", &now));
-
-- /* Outlandishly-long time zone abbreviations should not cause problems. */
-- {
-- static char const bufprefix[] = "TZ=\"";
-- enum { tzname_len = 2000 };
-- static char const bufsuffix[] = "0\" 1970-01-01 01:02:03.123456789";
-- enum { bufsize = sizeof bufprefix - 1 + tzname_len + sizeof bufsuffix };
-- char buf[bufsize];
-- memcpy (buf, bufprefix, sizeof bufprefix - 1);
-- memset (buf + sizeof bufprefix - 1, 'X', tzname_len);
-- strcpy (buf + bufsize - sizeof bufsuffix, bufsuffix);
-- ASSERT (parse_datetime (&result, buf, &now));
-- LOG (buf, now, result);
-- ASSERT (result.tv_sec == 1 * 60 * 60 + 2 * 60 + 3
-- && result.tv_nsec == 123456789);
-- }
--
- return 0;
- }
diff --git a/system/findutils/xargs-test-hashbang.patch b/system/findutils/xargs-test-hashbang.patch
new file mode 100644
index 000000000..53b3f34a0
--- /dev/null
+++ b/system/findutils/xargs-test-hashbang.patch
@@ -0,0 +1,11 @@
+This test fails when using dash as /bin/sh.
+
+This workaround is also being used by Guix.
+--- findutils-4.8.0/tests/xargs/verbose-quote.sh.old 2021-01-01 18:46:51.000000000 -0600
++++ findutils-4.8.0/tests/xargs/verbose-quote.sh 2021-09-11 01:01:01.090000000 -0500
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ # Verify that 'xargs -t' quotes the command properly when needed.
+
+ # Copyright (C) 2019-2021 Free Software Foundation, Inc.
diff --git a/system/gmp/APKBUILD b/system/gmp/APKBUILD
index ab8f1b70b..773adda41 100644
--- a/system/gmp/APKBUILD
+++ b/system/gmp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=gmp
-pkgver=6.1.2
-pkgrel=1
+pkgver=6.2.1
+pkgrel=0
pkgdesc="A free library for arbitrary precision arithmetic"
url="https://gmplib.org/"
arch="all"
@@ -46,4 +46,4 @@ libgmpxx() {
mv "$pkgdir"/usr/lib/libgmpxx.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="9f098281c0593b76ee174b722936952671fab1dae353ce3ed436a31fe2bc9d542eca752353f6645b7077c1f395ab4fdd355c58e08e2a801368f1375690eee2c6 gmp-6.1.2.tar.xz"
+sha512sums="c99be0950a1d05a0297d65641dd35b75b74466f7bf03c9e8a99895a3b2f9a0856cd17887738fa51cf7499781b65c049769271cbcb77d057d2e9f1ec52e07dd84 gmp-6.2.1.tar.xz"