summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-08 02:13:44 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-08 02:13:44 -0600
commit2901ac6f202089bf2080b79ac12d251d6a34f6ad (patch)
tree3f30f819c35c9d6c106c063e56203eb730faee69
parent34bd072dbef9f246959a74237f85c486c0f74fe5 (diff)
downloadpackages-2901ac6f202089bf2080b79ac12d251d6a34f6ad.tar.gz
packages-2901ac6f202089bf2080b79ac12d251d6a34f6ad.tar.bz2
packages-2901ac6f202089bf2080b79ac12d251d6a34f6ad.tar.xz
packages-2901ac6f202089bf2080b79ac12d251d6a34f6ad.zip
user/adelie-kde-theme: Use LookAndFeel package
-rw-r--r--user/adelie-kde-theme/APKBUILD23
-rw-r--r--user/adelie-kde-theme/adelie-kde-theme.js33
-rw-r--r--user/adelie-kde-theme/kdeglobals10
-rw-r--r--user/adelie-kde-theme/kscreenlockerrc13
4 files changed, 13 insertions, 66 deletions
diff --git a/user/adelie-kde-theme/APKBUILD b/user/adelie-kde-theme/APKBUILD
index 5611ea60d..3631bc35c 100644
--- a/user/adelie-kde-theme/APKBUILD
+++ b/user/adelie-kde-theme/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=adelie-kde-theme
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="The Adélie Linux official KDE theme"
url="https://adelielinux.org/"
arch="noarch"
@@ -11,19 +11,18 @@ license="NCSA"
depends="adelie-wallpapers papirus-icons"
makedepends=""
subpackages=""
-source="kdeglobals
- kscreenlockerrc
- adelie-kde-theme.js
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
+ kdeglobals
"
-builddir="$srcdir/"
package() {
- install -D -m644 kdeglobals "$pkgdir"/etc/xdg/kdeglobals
- install -m644 kscreenlockerrc "$pkgdir"/etc/xdg/kscreenlockerrc
- install -D -m644 adelie-kde-theme.js \
- "$pkgdir"/usr/share/plasma/shells/org.kde.plasma.desktop/contents/updates/adelie-kde-theme.js
+ install -D -m644 "$srcdir"/kdeglobals "$pkgdir"/etc/xdg/kdeglobals
+ install -m644 "$builddir"/kscreenlockerrc \
+ "$pkgdir"/etc/xdg/kscreenlockerrc
+ mkdir -p "$pkgdir"/usr/share/plasma/look-and-feel
+ mv "$builddir"/org.adelielinux.*.desktop \
+ "$pkgdir"/usr/share/plasma/look-and-feel/
}
-sha512sums="ed5dfa83a4d2f6b171b3a3238dea626b9ca9e1afd72ae026ef680a5eef0c3fff4aaf7c82f4bf394c26d002fde7517a4c842f9bdb9059107200d17f48e432b940 kdeglobals
-cbf41463121959a2af2743d899b41026679ad0ab88a79b32b070810f986aad31beeafbe4a2ae884f9863cbf6c3533e1bc64338eb521d94cc266284f7b99eda5d kscreenlockerrc
-4b22552ae3e1172431a90637d6cba09d199736641ea245d36aa2819cd33eae7fbc49f112accf90d40c8d6ed928846f6e7de6898e5a896e44fa9082be25e0e57d adelie-kde-theme.js"
+sha512sums="1a839b3c96e5881be9c0b096984d79a320f66f65bdcf2749b31aca7a04d7eb8edc1326649a2fcf4b6f2012c0b5d6967d1066397542fec44c7d1ac44b0599b462 adelie-kde-theme-1.0.tar.xz
+84940738263518df79cebaa3c158ed3713009f1a8cd201a6de06cc2a935845aba8a90a60882b575e5b17321706786a7ee6addc30dc530ce0453821d0ba157616 kdeglobals"
diff --git a/user/adelie-kde-theme/adelie-kde-theme.js b/user/adelie-kde-theme/adelie-kde-theme.js
deleted file mode 100644
index 81e88257a..000000000
--- a/user/adelie-kde-theme/adelie-kde-theme.js
+++ /dev/null
@@ -1,33 +0,0 @@
-// Copyright 2016 Aurélien COUDERC <zecoucou@free.fr>
-//
-// This program is free software: you can redistribute it and/or modify
-// it under the terms of the GNU General Public License as published by
-// the Free Software Foundation, either version 3 of the License, or
-// (at your option) any later version.
-//
-// This program is distributed in the hope that it will be useful,
-// but WITHOUT ANY WARRANTY; without even the implied warranty of
-// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-// GNU General Public License for more details.
-//
-// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-// This script is provided by desktop-base
-// It is run by Plasma 5 on upgrade.
-// Plasma checks that the script is only run once for each version.
-desktops = desktops()
-
-for (desktop in desktops) {
- // Only set up the wallpaper if the plugin is the default.
- // Otherwise it means the user chose another plugin and we don’t want to override that.
- if (desktops[desktop].wallpaperPlugin == 'org.kde.image') {
- desktops[desktop].currentConfigGroup = Array('Wallpaper', 'org.kde.image', 'General')
- if (!desktops[desktop].readConfig('Image')) {
- // Only set up the wallpaper if the wallpaper image is empty (=default).
- // Otherwise it means the user selected a picture and we don’t want to override that.
- desktops[desktop].writeConfig('Image', 'background');
- }
- }
-}
-
diff --git a/user/adelie-kde-theme/kdeglobals b/user/adelie-kde-theme/kdeglobals
index 2ec479dc2..80168401d 100644
--- a/user/adelie-kde-theme/kdeglobals
+++ b/user/adelie-kde-theme/kdeglobals
@@ -1,8 +1,2 @@
-[General]
-ColorScheme=Steel
-
-[Icons]
-Theme=Papirus
-
-[WM]
-activeBackground=104,0,0
+[KDE]
+LookAndFeelPackage=org.adelielinux.kdetheme.desktop
diff --git a/user/adelie-kde-theme/kscreenlockerrc b/user/adelie-kde-theme/kscreenlockerrc
deleted file mode 100644
index 5c3ff6fdd..000000000
--- a/user/adelie-kde-theme/kscreenlockerrc
+++ /dev/null
@@ -1,13 +0,0 @@
-[$Version]
-update_info=kscreenlocker.upd:0.1-autolock
-
-[Greeter]
-WallpaperPlugin=org.kde.image
-
-[Greeter][Wallpaper][org.kde.color][General]
-Color=19,21,23
-
-[Greeter][Wallpaper][org.kde.image][General]
-Color=19,21,23
-FillMode=1
-Image=lockscreen