summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-04 05:54:38 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-07 20:50:20 -0600
commita33cfd93f9c412b0e5a485f8d858287214f39ff9 (patch)
treeab12291386f54c072a8455ee3749028f6841083a
parentff0128e1bdf7c3573dd565a1872c849db015a452 (diff)
downloadpackages-a33cfd93f9c412b0e5a485f8d858287214f39ff9.tar.gz
packages-a33cfd93f9c412b0e5a485f8d858287214f39ff9.tar.bz2
packages-a33cfd93f9c412b0e5a485f8d858287214f39ff9.tar.xz
packages-a33cfd93f9c412b0e5a485f8d858287214f39ff9.zip
user/duktape: New package
Dependency for polkit.
-rw-r--r--user/duktape/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/duktape/APKBUILD b/user/duktape/APKBUILD
new file mode 100644
index 000000000..8d90dee87
--- /dev/null
+++ b/user/duktape/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=duktape
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="Embeddable JavaScript/ECMAScript engine"
+url="https://duktape.org/"
+arch="all"
+options="!check" # No test suite.
+license="MIT"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="https://duktape.org/duktape-$pkgver.tar.xz"
+
+prepare() {
+ default_prepare
+ ln -s "$builddir"/Makefile.sharedlibrary "$builddir"/Makefile
+}
+
+build() {
+ make INSTALL_PREFIX=/usr LIBDIR=/lib
+}
+
+package() {
+ make INSTALL_PREFIX=/usr DESTDIR="$pkgdir" LIBDIR=/lib install
+}
+
+sha512sums="8ff5465c9c335ea08ebb0d4a06569c991b9dc4661b63e10da6b123b882e7375e82291d6b883c2644902d68071a29ccc880dae8229447cebe710c910b54496c1d duktape-2.7.0.tar.xz"