summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-01-02 19:58:45 -0800
committerZach van Rijn <me@zv.io>2024-01-09 05:35:38 -0800
commita3ed9dfa0a435aa99080deb521ec05c92dc10365 (patch)
tree0ca45eba540a963a8514464cbc368458843d3b03
parente6245f3768a75a2c8f49648c87807f9299fcfd9e (diff)
downloadpackages-a3ed9dfa0a435aa99080deb521ec05c92dc10365.tar.gz
packages-a3ed9dfa0a435aa99080deb521ec05c92dc10365.tar.bz2
packages-a3ed9dfa0a435aa99080deb521ec05c92dc10365.tar.xz
packages-a3ed9dfa0a435aa99080deb521ec05c92dc10365.zip
user/spack: bump { 0.20.3 --> 0.21.0 }.
-rw-r--r--user/spack/40841.patch38
-rw-r--r--user/spack/40877.patch26
-rw-r--r--user/spack/APKBUILD8
3 files changed, 2 insertions, 70 deletions
diff --git a/user/spack/40841.patch b/user/spack/40841.patch
deleted file mode 100644
index fb63b32e9..000000000
--- a/user/spack/40841.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From fcf9e19a418b9db1fa517b98d087a5e387d1af8f Mon Sep 17 00:00:00 2001
-From: Harmen Stoppels <me@harmenstoppels.nl>
-Date: Thu, 2 Nov 2023 13:17:14 +0100
-Subject: [PATCH] go/rust bootstrap: no versions if unsupported arch
-
-The lookup in a dictionary causes KeyError on package load for
-unsupported architectures such as i386 and ppc big endian.
----
- var/spack/repos/builtin/packages/go-bootstrap/package.py | 2 +-
- var/spack/repos/builtin/packages/rust-bootstrap/package.py | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/var/spack/repos/builtin/packages/go-bootstrap/package.py b/var/spack/repos/builtin/packages/go-bootstrap/package.py
-index 047f9f3353b93..4f5c8f0073243 100644
---- a/var/spack/repos/builtin/packages/go-bootstrap/package.py
-+++ b/var/spack/repos/builtin/packages/go-bootstrap/package.py
-@@ -59,7 +59,7 @@ class GoBootstrap(Package):
-
- # determine system os and architecture/target
- os = platform.system().lower()
-- target = go_targets[platform.machine().lower()]
-+ target = go_targets.get(platform.machine().lower(), platform.machine().lower())
-
- # construct releases for current system configuration
- for release in go_releases:
-diff --git a/var/spack/repos/builtin/packages/rust-bootstrap/package.py b/var/spack/repos/builtin/packages/rust-bootstrap/package.py
-index 84100bf2424a1..337618e20e38f 100644
---- a/var/spack/repos/builtin/packages/rust-bootstrap/package.py
-+++ b/var/spack/repos/builtin/packages/rust-bootstrap/package.py
-@@ -73,7 +73,7 @@ class RustBootstrap(Package):
-
- # Determine system os and architecture/target.
- os = platform.system().lower()
-- target = rust_targets[platform.machine().lower()]
-+ target = rust_targets.get(platform.machine().lower(), platform.machine().lower())
-
- # Pre-release versions of the bootstrap compiler.
- # Note: These versions are unchecksumed since they will change
diff --git a/user/spack/40877.patch b/user/spack/40877.patch
deleted file mode 100644
index 4aa4368ff..000000000
--- a/user/spack/40877.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 1af592210d9190147e097fe26ddaa583a962557e Mon Sep 17 00:00:00 2001
-From: Zach van Rijn <me@zv.io>
-Date: Fri, 3 Nov 2023 19:06:46 -0500
-Subject: [PATCH] linux-headers: support multiple versions (#40334)
-
-The download URL for linux-headers was hardcoded to 4.x;
-we need to derive the correct URL from the version number.
----
- var/spack/repos/builtin/packages/linux-headers/package.py | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/var/spack/repos/builtin/packages/linux-headers/package.py b/var/spack/repos/builtin/packages/linux-headers/package.py
-index 1236a25ce691e..8e1d995695b06 100644
---- a/var/spack/repos/builtin/packages/linux-headers/package.py
-+++ b/var/spack/repos/builtin/packages/linux-headers/package.py
-@@ -20,6 +20,10 @@ class LinuxHeaders(Package):
- version("6.2.8", sha256="fed0ad87d42f83a70ce019ff2800bc30a855e672e72bf6d54a014d98d344f665")
- version("4.9.10", sha256="bd6e05476fd8d9ea4945e11598d87bc97806bbc8d03556abbaaf809707661525")
-
-+ def url_for_version(self, version):
-+ url = "https://www.kernel.org/pub/linux/kernel/v{0}.x/linux-{1}.tar.xz"
-+ return url.format(version.up_to(1), version)
-+
- def setup_build_environment(self, env):
- # This variable is used in the Makefile. If it is defined on the
- # system, it can break the build if there is no build recipe for
diff --git a/user/spack/APKBUILD b/user/spack/APKBUILD
index c7be74b7a..5f696e7a1 100644
--- a/user/spack/APKBUILD
+++ b/user/spack/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Zach van Rijn <me@zv.io>
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=spack
-pkgver=0.20.3_p1
+pkgver=0.21.0_p1
pkgrel=5
pkgdesc="A flexible package manager for supercomputers."
url="https://spack.io/"
@@ -16,8 +16,6 @@ depends="$makedepends
subpackages=""
# https://git.adelielinux.org/adelie/docs/-/wikis/Developer-Resources/Maintaining-Spack
source="https://git.adelielinux.org/adelie/$pkgname/-/archive/adelie-v$pkgver/$pkgname-adelie-v$pkgver.tar.bz2
- 40841.patch
- 40877.patch
clingo-explicit-libatomic.patch
archspec-fix-cpu-family-detection.patch
openssl-explicit-linux-headers.patch
@@ -69,9 +67,7 @@ package() {
install -D -m644 "${srcdir}"/config.yaml "$pkgdir"/etc/spack/config.yaml;
}
-sha512sums="9629ee48d4f93158c4c2d3f14bc8755e33df1a82428337fc27495b7bbfba3f056c193b95bcb9f90025d89c7759fcf2ef09a1f1639880a8db87a786ee1bd138e2 spack-adelie-v0.20.3_p1.tar.bz2
-195d9dd1da12be338169a4a2a0b12fece1fefd4ac6570111913ce0d50a8e007fc3320340573cee760d1eab55dddfcf7eed04221bd686a59d18d0ab2ef46f65a0 40841.patch
-9381c627598e593f78daf03d1bb8dfa386006b4412a1bca70ae69d97b40e0ad827daf176c8c0e066b15917e2b5abbbae9006624a2d98afcabb3eb44618d6c179 40877.patch
+sha512sums="85ae21de1f6c3d6eb3d3f0edc878820f17bae27236ea89eae0f733fa178eff25da41264960a492a2f34e03bd4f668ba1a2cfc395a814693c23f83b4ac2a80985 spack-adelie-v0.21.0_p1.tar.bz2
30f6d193971bc6f2941141d0da50d339c459f2b9c6157cc2659a589bd2b546fba35d580cad79dd1bc74bcd9de7db31bc937418598d73b68c69876fee6a1c5c73 clingo-explicit-libatomic.patch
a6503238d116b74ff9c4ecd08a984df90ce02f95c3e10e907481d99917c73339db1cc49f2b473a37875b92a9a6607cac72057c0a7b3d9a57d44c89ebe0ad3915 archspec-fix-cpu-family-detection.patch
8ded405082eec192187fb72896c68200985ee1226b2ef7da19ab43f31138972d5b4000cf997cb6e22664a7c100b52b842df07c44e188f87d4250f698d1885ea6 openssl-explicit-linux-headers.patch