summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-11-01 08:13:08 -0500
committerZach van Rijn <me@zv.io>2023-11-01 10:34:31 -0500
commit2005abb029e090f156d3ad508cd6631b385d433c (patch)
tree984464001e3270b33a1cc6204dd4918b3a7c9804
parent2966e80a6d9a08e4bee074e23ce2974f114faad5 (diff)
downloadpackages-2005abb029e090f156d3ad508cd6631b385d433c.tar.gz
packages-2005abb029e090f156d3ad508cd6631b385d433c.tar.bz2
packages-2005abb029e090f156d3ad508cd6631b385d433c.tar.xz
packages-2005abb029e090f156d3ad508cd6631b385d433c.zip
user/spack: miscellaneous improvements.
* Make dependencies explicit https://spack.readthedocs.io/en/latest/getting_started.html#system-prerequisites * Remove cached compiler preferences; this causes problems if e.g. 'ccache' is used ('/usr/local/bin/gcc') when built but the same path does not exist on the installed system. * Do not attempt to use the buildcache (search remote server for pre-built packages). We are the only musl-based distro currrently packaging Spack, and no such binaries exist yet.
-rw-r--r--user/spack/APKBUILD10
-rw-r--r--user/spack/default-no-buildcache.patch13
2 files changed, 21 insertions, 2 deletions
diff --git a/user/spack/APKBUILD b/user/spack/APKBUILD
index e8b1df9ee..26a0e1f72 100644
--- a/user/spack/APKBUILD
+++ b/user/spack/APKBUILD
@@ -2,17 +2,21 @@
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=spack
pkgver=0.19.0_p1
-pkgrel=0
+pkgrel=1
pkgdesc="A flexible package manager for supercomputers."
url="https://spack.io/"
arch="all !ppc" # see #794
license="Apache-2.0 OR MIT"
options="!dbg !strip"
makedepends="python3-dev"
-depends="$makedepends" # due to bootstrap design
+depends="$makedepends
+ gcc g++ gfortran
+ bzip2 file git gnupg gzip libarchive-tools make patch unzip xz
+ "
subpackages=""
# https://git.adelielinux.org/adelie/docs/-/wikis/Developer-Resources/Maintaining-Spack
source="https://git.adelielinux.org/adelie/$pkgname/-/archive/adelie-v$pkgver/$pkgname-adelie-v$pkgver.tar.bz2
+ default-no-buildcache.patch
archspec-fix-cpu-family-detection.patch
"
builddir="$srcdir/$pkgname-adelie-v$pkgver"
@@ -36,6 +40,7 @@ check() {
export SPACK_USER_CACHE_PATH=$builddir/tmp
bin/spack install zlib
rm -fr var/spack/cache
+ rm -fr etc/spack/linux # caches compilers.yaml
}
package() {
@@ -53,4 +58,5 @@ package() {
}
sha512sums="bc0dadee54fdbd15b374d6d768ed204ee66e776d9a86ba876b3023bca2875ce1f6ca4cc6fd15334ac0c0ceddab72910317833af277984d941d06d89dc145643d spack-adelie-v0.19.0_p1.tar.bz2
+eec3e7dd818c39daea7b8d63b04a6c71d9eb3af32dd899cddc3642152252f4e2eebfd53c3c95365117f9a4826f6f29553f44373948e5c474388021302c8a5ce9 default-no-buildcache.patch
a6503238d116b74ff9c4ecd08a984df90ce02f95c3e10e907481d99917c73339db1cc49f2b473a37875b92a9a6607cac72057c0a7b3d9a57d44c89ebe0ad3915 archspec-fix-cpu-family-detection.patch"
diff --git a/user/spack/default-no-buildcache.patch b/user/spack/default-no-buildcache.patch
new file mode 100644
index 000000000..f0cd1bb1f
--- /dev/null
+++ b/user/spack/default-no-buildcache.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/spack/spack/cmd/install.py b/lib/spack/spack/cmd/install.py
+index 3f9a948a23..bc46e98395 100644
+--- a/lib/spack/spack/cmd/install.py
++++ b/lib/spack/spack/cmd/install.py
+@@ -120,7 +120,7 @@ def setup_parser(subparser):
+ "--use-cache",
+ action="store_true",
+ dest="use_cache",
+- default=True,
++ default=False,
+ help="check for pre-built Spack packages in mirrors (default)",
+ )
+ cache_group.add_argument(