summaryrefslogtreecommitdiff
path: root/bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-30 09:27:55 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-09 15:21:38 -0500
commite50c8b2647ce482654ab0e4f77a88893b497ed37 (patch)
treeeb0c442d10d190933dac120b525e6779e44ea2bd /bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch
parentecce2855f3220b8b9b39c58ef05c97643fd62f1b (diff)
downloadpackages-e50c8b2647ce482654ab0e4f77a88893b497ed37.tar.gz
packages-e50c8b2647ce482654ab0e4f77a88893b497ed37.tar.bz2
packages-e50c8b2647ce482654ab0e4f77a88893b497ed37.tar.xz
packages-e50c8b2647ce482654ab0e4f77a88893b497ed37.zip
bootstrap/rust-1.{61-79}: New package
Diffstat (limited to 'bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch b/bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..2303b2a62
--- /dev/null
+++ b/bootstrap/rust-1.70/0010-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,60 @@
+From db350174e9e5e2fc1b89fa6736002e63fe79ed1e Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 10/13] Ignore broken and non-applicable tests
+
+c-link-to-rust-va-list-fn: unstable feature, broken on aarch64, #56475
+env-funky-keys: can't handle LD_PRELOAD (e.g. sandbox)
+long-linker-command-lines: takes >10 minutes to run (but still passes)
+sysroot-crates-are-unstable: can't run rustc without RPATH
+---
+ tests/run-make/c-link-to-rust-va-list-fn/Makefile | 2 ++
+ tests/run-make/long-linker-command-lines/Makefile | 2 ++
+ tests/run-make/sysroot-crates-are-unstable/Makefile | 2 ++
+ tests/ui/env-funky-keys.rs | 1 +
+ 4 files changed, 7 insertions(+)
+
+diff --git a/tests/run-make/c-link-to-rust-va-list-fn/Makefile b/tests/run-make/c-link-to-rust-va-list-fn/Makefile
+index 596c0fce3ceae..3a156893f9199 100644
+--- a/tests/run-make/c-link-to-rust-va-list-fn/Makefile
++++ b/tests/run-make/c-link-to-rust-va-list-fn/Makefile
+@@ -1,4 +1,6 @@
+ # ignore-cross-compile
++# ignore-aarch64
++
+ include ../tools.mk
+
+ all:
+diff --git a/tests/run-make/long-linker-command-lines/Makefile b/tests/run-make/long-linker-command-lines/Makefile
+index f864ea74f4a95..f16eaf544cc3f 100644
+--- a/tests/run-make/long-linker-command-lines/Makefile
++++ b/tests/run-make/long-linker-command-lines/Makefile
+@@ -1,4 +1,6 @@
+ # ignore-cross-compile
++# ignore-test
++
+ include ../tools.mk
+
+ all:
+diff --git a/tests/run-make/sysroot-crates-are-unstable/Makefile b/tests/run-make/sysroot-crates-are-unstable/Makefile
+index 30c33c5c13d20..d733bb1c557f5 100644
+--- a/tests/run-make/sysroot-crates-are-unstable/Makefile
++++ b/tests/run-make/sysroot-crates-are-unstable/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ -include ../tools.mk
+
+ all:
+diff --git a/tests/ui/env-funky-keys.rs b/tests/ui/env-funky-keys.rs
+index 46e20d8c61f52..b598ebfbb45a1 100644
+--- a/tests/ui/env-funky-keys.rs
++++ b/tests/ui/env-funky-keys.rs
+@@ -1,6 +1,7 @@
+ // run-pass
+ // Ignore this test on Android, because it segfaults there.
+
++// ignore-test
+ // ignore-android
+ // ignore-windows
+ // ignore-emscripten no execve