summaryrefslogtreecommitdiff
path: root/dev-util/itstool/itstool-2.0.2-r3.ebuild
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-10-28 22:19:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-10-28 22:19:58 -0500
commitb8b7cfb32eb6475942876933fd69fb342e222a0a (patch)
tree69d6ecc5765e39f4f2a7e8b0cc419f6554b2a710 /dev-util/itstool/itstool-2.0.2-r3.ebuild
parent9a662f103d61ce402bdb05d46d5ba1aebd3a63df (diff)
downloadpackages-b8b7cfb32eb6475942876933fd69fb342e222a0a.tar.gz
packages-b8b7cfb32eb6475942876933fd69fb342e222a0a.tar.bz2
packages-b8b7cfb32eb6475942876933fd69fb342e222a0a.tar.xz
packages-b8b7cfb32eb6475942876933fd69fb342e222a0a.zip
dev-util/itstool: add local copy with Python 3 patch
Diffstat (limited to 'dev-util/itstool/itstool-2.0.2-r3.ebuild')
-rw-r--r--dev-util/itstool/itstool-2.0.2-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/itstool/itstool-2.0.2-r3.ebuild b/dev-util/itstool/itstool-2.0.2-r3.ebuild
new file mode 100644
index 000000000..aced2a82e
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.2-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are HPND/as-is || GPL-3
+LICENSE="GPL-3+ || ( HPND GPL-3+ )"
+SLOT="0"
+KEYWORDS="alpha arm arm64 hppa m68k mips ppc ppc64 sparc64 x86 x86_64"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( ${FILESDIR}/${P}-python3.patch )
+
+pkg_setup() {
+ DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+ default
+}