summaryrefslogtreecommitdiff
path: root/experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-31 20:53:28 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-09 15:21:38 -0500
commit79a51285be9c224976f6bccfb4096407a19a5dac (patch)
treec3b1d22897f126174e0f9c7cf2652fa1ed785b2e /experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch
parente50c8b2647ce482654ab0e4f77a88893b497ed37 (diff)
downloadpackages-79a51285be9c224976f6bccfb4096407a19a5dac.tar.gz
packages-79a51285be9c224976f6bccfb4096407a19a5dac.tar.bz2
packages-79a51285be9c224976f6bccfb4096407a19a5dac.tar.xz
packages-79a51285be9c224976f6bccfb4096407a19a5dac.zip
experimental/rust-beta: Add 1.81.0 beta patchset
Diffstat (limited to 'experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch b/experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..b8b1b8932
--- /dev/null
+++ b/experimental/rust-beta/0009-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,47 @@
+From cc6d3d3ab26517d5f8f09536b016154944bdceff Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 09/12] Ignore broken and non-applicable tests
+
+env-funky-keys: can't handle LD_PRELOAD (e.g. sandbox)
+long-linker-command-lines: takes >10 minutes to run (but still passes)
+sysroot-crates-are-unstable: can't run rustc without RPATH
+---
+ tests/run-make/long-linker-command-lines/Makefile | 2 ++
+ tests/run-make/sysroot-crates-are-unstable/Makefile | 2 ++
+ tests/ui/process/env-funky-keys.rs | 1 +
+ 3 files changed, 7 insertions(+)
+
+diff --git a/tests/run-make/long-linker-command-lines/Makefile b/tests/run-make/long-linker-command-lines/Makefile
+index f864ea74f4a95..f16eaf544cc3f 100644
+--- a/tests/run-make/long-linker-command-lines/Makefile
++++ b/tests/run-make/long-linker-command-lines/Makefile
+@@ -1,4 +1,6 @@
+ # ignore-cross-compile
++# ignore-test
++
+ include ../tools.mk
+
+ export LD_LIBRARY_PATH := $(HOST_RPATH_DIR)
+diff --git a/tests/run-make/sysroot-crates-are-unstable/Makefile b/tests/run-make/sysroot-crates-are-unstable/Makefile
+index 30c33c5c13d20..d733bb1c557f5 100644
+--- a/tests/run-make/sysroot-crates-are-unstable/Makefile
++++ b/tests/run-make/sysroot-crates-are-unstable/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ -include ../tools.mk
+
+ all:
+diff --git a/tests/ui/env-funky-keys.rs b/tests/ui/env-funky-keys.rs
+index 314ccaea01525..7f5b9efaa10b1 100644
+--- a/tests/ui/process/env-funky-keys.rs
++++ b/tests/ui/process/env-funky-keys.rs
+@@ -1,6 +1,7 @@
+ //@ run-pass
+ // Ignore this test on Android, because it segfaults there.
+
++//@ ignore-test
+ //@ ignore-android
+ //@ ignore-windows
+ //@ ignore-wasm32 no execve