summaryrefslogtreecommitdiff
path: root/experimental
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-04 20:27:02 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-04 20:27:02 +0000
commit1a2f56911fe9fb165f1ac3bea19897b76d1d49b5 (patch)
tree527615f90d00c82535e03bf26c9f790af7f98808 /experimental
parent474dbb6054045d2916a25e5d1fc0950c2ad1adad (diff)
downloadpackages-1a2f56911fe9fb165f1ac3bea19897b76d1d49b5.tar.gz
packages-1a2f56911fe9fb165f1ac3bea19897b76d1d49b5.tar.bz2
packages-1a2f56911fe9fb165f1ac3bea19897b76d1d49b5.tar.xz
packages-1a2f56911fe9fb165f1ac3bea19897b76d1d49b5.zip
user/qt5-qtwebkit: Bump to 5.212.0 git snapshot
This is required to build against Qt 5.12 and supports ppc64.
Diffstat (limited to 'experimental')
-rw-r--r--experimental/qt5-qtwebkit/APKBUILD94
-rw-r--r--experimental/qt5-qtwebkit/jsc-port-to-musl.patch81
-rw-r--r--experimental/qt5-qtwebkit/musl-thread-stacksize.patch49
3 files changed, 0 insertions, 224 deletions
diff --git a/experimental/qt5-qtwebkit/APKBUILD b/experimental/qt5-qtwebkit/APKBUILD
deleted file mode 100644
index c7e0834e5..000000000
--- a/experimental/qt5-qtwebkit/APKBUILD
+++ /dev/null
@@ -1,94 +0,0 @@
-# Contributor: A. Wilcox <awilfox@adelielinux.org>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=qt5-qtwebkit
-_realname=qtwebkit
-pkgver=5.212.0_alpha2
-_realver=$(printf '%s' "$pkgver" | sed 's/_/-/')
-pkgrel=0
-pkgdesc="Open source Web browser engine"
-url="https://github.com/annulen/webkit"
-arch="all"
-license="LGPL-2.1+ AND BSD-3-Clause AND Others"
-depends="gst-plugins-base"
-depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev ninja sqlite-dev icu-dev ruby perl bison flex gperf
- libxml2-dev libxslt-dev libjpeg-turbo-dev libpng-dev zlib-dev glib-dev
- gstreamer-dev fontconfig-dev qt5-qtsensors-dev qt5-qtpositioning-dev
- qt5-qtdeclarative-dev qt5-qtwebchannel-dev libxcomposite-dev
- libxrender-dev gst-plugins-base-dev hyphen-dev libexecinfo-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/annulen/webkit/releases/download/$_realname-$_realver/$_realname-$_realver.tar.xz
- jsc-port-to-musl.patch
- musl-thread-stacksize.patch
- "
-builddir="$srcdir"/$_realname-$_realver
-
-unpack() {
- default_unpack
- # just ripped from Firefox's APKBUILD...
- [ -z $SKIP_PYTHON ] || return 0
- msg "Killing all remaining hope for humanity and building Python 2..."
- cd "$srcdir"
- [ -d python ] && rm -r python
- mkdir python
- cd python
- # 19:39 <+solar> just make the firefox build process build its own py2 copy
- curl -O https://www.python.org/ftp/python/2.7.15/Python-2.7.15.tar.xz
- tar xJf Python-2.7.15.tar.xz
- cd Python-2.7.15
- # 20:03 <calvin> TheWilfox: there's always violence
- ./configure --prefix="$srcdir/python"
- make -j $JOBS
- # 6 tests failed:
- # test__locale test_os test_posix test_re test_strptime test_time
- # make test
- make -j $JOBS install
-}
-
-build() {
- cd "$builddir"
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- export PATH="$srcdir/python/bin:$PATH"
- # We can enable the JIT when it is stable on all Tier 1 platforms:
- # pmmx (ensure no SSE)
- # ppc
- # ppc64
- #
- # DONE:
- # aarch64
- # armv7
- # x86_64
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- -DENABLE_JIT=OFF \
- -DPORT=Qt \
- -DUSE_SYSTEM_MALLOC=ON \
- ${CMAKE_CROSSOPTS}
- # too memory hungry
- if [ -z "$JOBS" ] || [ $JOBS -gt 32 ]; then
- make -j32
- else
- make
- fi
-}
-
-check() {
- cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="b15985aab20c5618dc1f71a0d91f02dbed993516272090a4a12990714bf4c9554ccbdcf9d6a143bf46fcc2c170f691e571114d61686fe49791f8d5c540785758 qtwebkit-5.212.0-alpha2.tar.xz
-19efd97c5f628108d30cc0e5e53f689725cc480ffe1ea90577e5f961d7f35a6a434dda5a03c73c0fb74a30c46ced32bcf580340a2eaf4e72960e61c28ed34dba jsc-port-to-musl.patch
-a8df6d20346882e49745dbdf9bdf2eddf2f3e1ac3301e9fd826397fa746d1d9228deaf2eab0316fa977a85032d6c091559cd5404b7a576e3adc0bec64a5a4ad9 musl-thread-stacksize.patch"
diff --git a/experimental/qt5-qtwebkit/jsc-port-to-musl.patch b/experimental/qt5-qtwebkit/jsc-port-to-musl.patch
deleted file mode 100644
index 0b2d7dfce..000000000
--- a/experimental/qt5-qtwebkit/jsc-port-to-musl.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -Naur qtwebkit-5.212.0-alpha2-original/Source/JavaScriptCore/heap/MachineStackMarker.cpp qtwebkit-5.212.0-alpha2/Source/JavaScriptCore/heap/MachineStackMarker.cpp
---- qtwebkit-5.212.0-alpha2-original/Source/JavaScriptCore/heap/MachineStackMarker.cpp 2017-06-04 20:16:05.000000000 +0000
-+++ qtwebkit-5.212.0-alpha2/Source/JavaScriptCore/heap/MachineStackMarker.cpp 2018-09-26 02:13:44.660000000 +0000
-@@ -566,7 +566,7 @@
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__) && ENABLE(JIT)
-+#elif defined(__linux__) && ENABLE(JIT)
-
- #if CPU(X86)
- return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESP]);
-@@ -665,7 +665,7 @@
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__)
-+#elif defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -747,7 +747,7 @@
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__)
-+#elif defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -838,7 +838,7 @@
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__)
-+#elif defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-diff -Naur qtwebkit-5.212.0-alpha2-original/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp qtwebkit-5.212.0-alpha2/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
---- qtwebkit-5.212.0-alpha2-original/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp 2017-06-04 20:16:06.000000000 +0000
-+++ qtwebkit-5.212.0-alpha2/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp 2018-09-26 02:12:36.770000000 +0000
-@@ -828,7 +828,7 @@
- #if YYERROR_VERBOSE
-
- # ifndef yystrlen
--# if defined __GLIBC__ && defined _STRING_H
-+# if defined __linux__ && defined _STRING_H
- # define yystrlen strlen
- # else
- /* Return the length of YYSTR. */
-@@ -844,7 +844,7 @@
- # endif
-
- # ifndef yystpcpy
--# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
-+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
- # define yystpcpy stpcpy
- # else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
-diff -Naur qtwebkit-5.212.0-alpha2-original/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp qtwebkit-5.212.0-alpha2/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
---- qtwebkit-5.212.0-alpha2-original/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp 2017-06-04 20:16:06.000000000 +0000
-+++ qtwebkit-5.212.0-alpha2/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp 2018-09-26 02:12:54.740000000 +0000
-@@ -1835,7 +1835,7 @@
- #if YYERROR_VERBOSE
-
- # ifndef yystrlen
--# if defined __GLIBC__ && defined _STRING_H
-+# if defined __linux__ && defined _STRING_H
- # define yystrlen strlen
- # else
- /* Return the length of YYSTR. */
-@@ -1851,7 +1851,7 @@
- # endif
-
- # ifndef yystpcpy
--# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
-+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
- # define yystpcpy stpcpy
- # else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
diff --git a/experimental/qt5-qtwebkit/musl-thread-stacksize.patch b/experimental/qt5-qtwebkit/musl-thread-stacksize.patch
deleted file mode 100644
index e790222dc..000000000
--- a/experimental/qt5-qtwebkit/musl-thread-stacksize.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- qtwebkit-5.212.0-alpha2/Source/WTF/wtf/ThreadingPthreads.cpp.old 2017-06-04 15:16:06.000000000 -0500
-+++ qtwebkit-5.212.0-alpha2/Source/WTF/wtf/ThreadingPthreads.cpp 2018-09-05 02:29:45.980000000 +0000
-@@ -107,10 +107,11 @@
- void initializeThreading()
- {
- static bool isInitialized;
-+ pthread_attr_t attr;
-
- if (isInitialized)
- return;
-
- isInitialized = true;
-
- WTF::double_conversion::initialize();
-@@ -122,6 +122,11 @@
- ThreadIdentifierData::initializeOnce();
- wtfThreadData();
- initializeDates();
-+
-+ pthread_attr_init(&attr);
-+ pthread_attr_setstacksize(&attr, 2097152);
-+ pthread_setattr_default_np(&attr);
-+ pthread_attr_destroy(&attr);
- }
-
- static ThreadMap& threadMap()
-@@ -171,6 +171,7 @@
- pthread_t threadHandle;
- pthread_attr_t attr;
- pthread_attr_init(&attr);
-+ pthread_attr_setstacksize(&attr, 2097152);
- #if HAVE(QOS_CLASSES)
- pthread_attr_set_qos_class_np(&attr, QOS_CLASS_USER_INITIATED, 0);
- #endif
---- qtwebkit-5.212.0-alpha2/Source/JavaScriptCore/runtime/Options.h.old 2017-06-04 20:16:05.000000000 +0000
-+++ qtwebkit-5.212.0-alpha2/Source/JavaScriptCore/runtime/Options.h 2018-09-26 03:02:39.700000000 +0000
-@@ -112,9 +112,9 @@
- \
- v(bool, reportMustSucceedExecutableAllocations, false, nullptr) \
- \
-- v(unsigned, maxPerThreadStackUsage, 4 * MB, nullptr) \
-- v(unsigned, reservedZoneSize, 128 * KB, nullptr) \
-- v(unsigned, errorModeReservedZoneSize, 64 * KB, nullptr) \
-+ v(unsigned, maxPerThreadStackUsage, 512 * KB, nullptr) \
-+ v(unsigned, reservedZoneSize, 32 * KB, nullptr) \
-+ v(unsigned, errorModeReservedZoneSize, 16 * KB, nullptr) \
- \
- v(bool, crashIfCantAllocateJITMemory, false, nullptr) \
- v(unsigned, jitMemoryReservationSize, 0, "Set this number to change the executable allocation size in ExecutableAllocatorFixedVMPool. (In bytes.)") \