summaryrefslogtreecommitdiff
path: root/experimental
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 11:40:07 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 20:45:50 -0500
commitc646b6946c2c1e62c6c0f55c9c9dfa5cdae0c021 (patch)
tree197d64fe8150e1d0e250582b310cbb3c13c21b57 /experimental
parent15ce70d3172a3485207d9905f00ca21370fda597 (diff)
downloadpackages-c646b6946c2c1e62c6c0f55c9c9dfa5cdae0c021.tar.gz
packages-c646b6946c2c1e62c6c0f55c9c9dfa5cdae0c021.tar.bz2
packages-c646b6946c2c1e62c6c0f55c9c9dfa5cdae0c021.tar.xz
packages-c646b6946c2c1e62c6c0f55c9c9dfa5cdae0c021.zip
experimental/py3-filelock: new package
Diffstat (limited to 'experimental')
-rw-r--r--experimental/py3-filelock/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/experimental/py3-filelock/APKBUILD b/experimental/py3-filelock/APKBUILD
new file mode 100644
index 000000000..06392a74b
--- /dev/null
+++ b/experimental/py3-filelock/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer:
+pkgname=py3-filelock
+_pkgname=filelock
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=3.0.12
+pkgrel=0
+pkgdesc="A platform independent file lock for Python"
+url="https://pypi.python.org/pypi/filelock"
+arch="noarch"
+# Certified net clean
+license="Unlicense"
+depends="python3"
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="09b8b16c12a60044a259a5d644bc8066660871104a7f4cd431431173d475b9f15744adfb8d86ec8cda69f2a1b52bd14cb8a066d70fa5e49c449bc5ee702ec2a0 py3-filelock-3.0.12.tar.gz"