summaryrefslogtreecommitdiff
path: root/experimental
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-29 03:34:01 -0500
committerMax Rees <maxcrees@me.com>2019-09-17 14:33:32 -0500
commit34ee2b0b8f8cfb7eb5ba00052e1b864a6aed29c5 (patch)
treee661bbd66b470f28e2ad73ef191275528cfe534f /experimental
parentf9ba226858a27bb322bad90ad988971f9afa8314 (diff)
downloadpackages-34ee2b0b8f8cfb7eb5ba00052e1b864a6aed29c5.tar.gz
packages-34ee2b0b8f8cfb7eb5ba00052e1b864a6aed29c5.tar.bz2
packages-34ee2b0b8f8cfb7eb5ba00052e1b864a6aed29c5.tar.xz
packages-34ee2b0b8f8cfb7eb5ba00052e1b864a6aed29c5.zip
experimental/patchelf: new package
At least one test fails on x86_64. GitHub indicates that there are probably other test failures on other arches. https://github.com/NixOS/patchelf/issues?utf8=%E2%9C%93&q=is%3Aissue+is%3Aopen+set-rpath-library.sh
Diffstat (limited to 'experimental')
-rw-r--r--experimental/patchelf/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/experimental/patchelf/APKBUILD b/experimental/patchelf/APKBUILD
new file mode 100644
index 000000000..04652cdde
--- /dev/null
+++ b/experimental/patchelf/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=patchelf
+pkgver=0.10
+pkgrel=0
+pkgdesc="Utility to modify the dynamic linker and RPATH of ELF executables"
+url="https://nixos.org/patchelf.html"
+arch="all"
+license="GPL-3.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://nixos.org/releases/patchelf/patchelf-$pkgver/patchelf-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="647ad13b7d45b3c5d20683ef8fe9760cb7f213e879231b6c5780bf32771adfbf7c5e5ce694c08e5681dceda63857d7d8a2d53efb60f799d3e7290cebc02ab501 patchelf-0.10.tar.bz2"