summaryrefslogtreecommitdiff
path: root/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-10-29 07:07:21 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-10-29 07:07:21 -0500
commit95bc4e36e9b1247a847014ce51f0a9f1cc3cd195 (patch)
tree84480e1f652cb610c09f3b34081f26b8b8ebb780 /games-misc/openmsx/openmsx-0.3.1-r3.ebuild
parent1b21930673fe628a3a51cfdb201bd91649f14441 (diff)
downloadpackages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.tar.gz
packages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.tar.bz2
packages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.tar.xz
packages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.zip
games-misc/openmsx: Python 3 patch
Diffstat (limited to 'games-misc/openmsx/openmsx-0.3.1-r3.ebuild')
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/openmsx/openmsx-0.3.1-r3.ebuild b/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
new file mode 100644
index 000000000..84b28b408
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+inherit python-any-r1 games
+
+DESCRIPTION="An ambiguously named music replacement set for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/openmsx/"
+SRC_URI="http://bundles.openttdcoop.org/openmsx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=( ${FILESDIR}/${P}-python3.patch )
+
+S=${WORKDIR}/${P}-source
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_compile() {
+ emake _V= bundle || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/openttd/gm/${P}
+ doins ${P}/{*.mid,openmsx.obm} || die
+ dodoc ${P}/{changelog.txt,readme.txt} || die
+ prepgamesdirs
+}