summaryrefslogtreecommitdiff
path: root/harmony/glib-networking
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
commitfd2bb2f751c13b3c0c002b8e012810902b9da364 (patch)
tree17b2e38c966c9f96cfa568c1f572261a289590e6 /harmony/glib-networking
parentb0a5136bf3326ba38b360be288d06f9a27f2a4d2 (diff)
downloadpackages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.gz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.bz2
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.xz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.zip
harmony -> system
Diffstat (limited to 'harmony/glib-networking')
-rw-r--r--harmony/glib-networking/APKBUILD43
-rw-r--r--harmony/glib-networking/proxy-test.patch13
2 files changed, 0 insertions, 56 deletions
diff --git a/harmony/glib-networking/APKBUILD b/harmony/glib-networking/APKBUILD
deleted file mode 100644
index 65ae109a0..000000000
--- a/harmony/glib-networking/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=glib-networking
-pkgver=2.54.1
-_maj=${pkgver%%.*}
-_min=${pkgver#${_maj}.}
-_min=${_min%%.*}
-_ver=$_maj.$_min
-pkgrel=1
-pkgdesc="Networking support for GLib"
-url="http://www.gnome.org"
-arch="all"
-license="LGPL-2.1+"
-depends="ca-certificates"
-makedepends="glib-dev gnutls-dev libproxy-dev intltool libgcrypt-dev bash p11-kit-dev"
-install=
-subpackages="$pkgname-lang"
-source="http://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz"
-
-build() {
- cd "$builddir"
- CONFIG_SHELL=/bin/bash ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-more-warnings \
- --with-libproxy \
- --with-gnutls
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- rm -f "$pkgdir"/usr/lib/gio/modules/*.a
-}
-
-sha512sums="8356d835914e33df43f4f2bb6a915ddcd48dd0565e4d5bc1f1d692e9c3124ee4421b99f87f2586f74e9fed24ef7421159f3242fd1eb7bd74950bd25e860896ec glib-networking-2.54.1.tar.xz"
diff --git a/harmony/glib-networking/proxy-test.patch b/harmony/glib-networking/proxy-test.patch
deleted file mode 100644
index 2cab5d9f6..000000000
--- a/harmony/glib-networking/proxy-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./Makefile.am.orig
-+++ ./Makefile.am
-@@ -11,9 +11,9 @@
-
- if HAVE_GNOME_PROXY
- SUBDIRS += proxy/gnome
-+SUBDIRS += proxy/tests
- endif
-
--SUBDIRS += proxy/tests
-
- if HAVE_GNUTLS
- SUBDIRS += tls/gnutls