summaryrefslogtreecommitdiff
path: root/harmony/gnutls
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
commitfd2bb2f751c13b3c0c002b8e012810902b9da364 (patch)
tree17b2e38c966c9f96cfa568c1f572261a289590e6 /harmony/gnutls
parentb0a5136bf3326ba38b360be288d06f9a27f2a4d2 (diff)
downloadpackages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.gz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.bz2
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.xz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.zip
harmony -> system
Diffstat (limited to 'harmony/gnutls')
-rw-r--r--harmony/gnutls/APKBUILD74
-rw-r--r--harmony/gnutls/tests-date-compat.patch12
2 files changed, 0 insertions, 86 deletions
diff --git a/harmony/gnutls/APKBUILD b/harmony/gnutls/APKBUILD
deleted file mode 100644
index b64faaa64..000000000
--- a/harmony/gnutls/APKBUILD
+++ /dev/null
@@ -1,74 +0,0 @@
-# Contriburo: Łukasz Jendrysik <scadu@yandex.com>
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=gnutls
-pkgver=3.6.1
-pkgrel=0
-pkgdesc="A TLS protocol implementation"
-url="http://www.gnutls.org/"
-arch="all"
-license="GPL"
-checkdepends="diffutils"
-makedepends="nettle-dev zlib-dev libtasn1-dev p11-kit-dev libunistring-dev texinfo"
-subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-utils $pkgname-c++:xx"
-_v=${pkgver%.*}
-case $pkgver in
-*.*.*.*) _v=${_v%.*};;
-esac
-source="https://www.gnupg.org/ftp/gcrypt/gnutls/v${_v}/$pkgname-$pkgver.tar.xz
- tests-date-compat.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-# secfixes:
-# 3.5.13-r0:
-# - CVE-2017-7507
-
-build() {
- cd "$builddir"
- LIBS="-lgmp" ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-openssl-compatibility \
- --disable-rpath \
- --disable-static \
- --disable-guile \
- --disable-valgrind-tests \
- --without-included-libtasn1 \
- --enable-cxx \
- --enable-manpages \
- --enable-tests \
- --disable-full-test-suite \
- --disable-sslv2-support \
- --with-zlib \
- --with-p11-kit
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
-}
-
-utils() {
- pkgdesc="Command line tools for TLS protocol"
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
-}
-
-xx() {
- pkgdesc="The C++ interface to GnuTLS"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/lib*xx.so.* "$subpkgdir"/usr/lib/
-}
-
-sha512sums="1f2bd3203ea96844c531be700b44623b79f46743143edf97011aab07895ca18d62f1659c7fafc5e1c4b0686fde490836f00358bdd60d6ac0b842526db002da23 gnutls-3.6.1.tar.xz
-14b1be86a0180c914aaaada261ccf01914d48df9510b57572e4f32683d1dd984a907ecf2c848cc4773b1c139059de26383a2c617f509f8c75b985668a23fd28d tests-date-compat.patch"
diff --git a/harmony/gnutls/tests-date-compat.patch b/harmony/gnutls/tests-date-compat.patch
deleted file mode 100644
index 2717ab230..000000000
--- a/harmony/gnutls/tests-date-compat.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Busybox date does not support %N, this is GNU extension.
---- a/tests/scripts/common.sh
-+++ b/tests/scripts/common.sh
-@@ -59,7 +59,7 @@
- }
-
- # Find a port number not currently in use.
--GETPORT='rc=0; myrandom=$(date +%N | sed s/^0*//)
-+GETPORT='rc=0; myrandom=$(date +%s | sed s/^0*//)
- while test $rc = 0;do
- PORT="$(((($$<<15)|$myrandom) % 63001 + 2000))"
- check_if_port_in_use $PORT;rc=$?