summaryrefslogtreecommitdiff
path: root/harmony/libtool/libtool.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-27 14:34:02 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-27 14:34:02 -0600
commit7553795ec2d735c01dbdde129a65b7f45d5aa999 (patch)
treeb3970009a8246b0c17a105fe6b10c8077fc2b763 /harmony/libtool/libtool.patch
parente2b01859c88d221992403d1293d42da33002be4d (diff)
downloadpackages-7553795ec2d735c01dbdde129a65b7f45d5aa999.tar.gz
packages-7553795ec2d735c01dbdde129a65b7f45d5aa999.tar.bz2
packages-7553795ec2d735c01dbdde129a65b7f45d5aa999.tar.xz
packages-7553795ec2d735c01dbdde129a65b7f45d5aa999.zip
Add harmony/ repo for packages still being discussed
See https://wiki.adelielinux.org/wiki/Project:Harmony
Diffstat (limited to 'harmony/libtool/libtool.patch')
-rw-r--r--harmony/libtool/libtool.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/harmony/libtool/libtool.patch b/harmony/libtool/libtool.patch
new file mode 100644
index 000000000..4302b7e07
--- /dev/null
+++ b/harmony/libtool/libtool.patch
@@ -0,0 +1,41 @@
+diff --git a/main/libtool/APKBUILD b/main/libtool/APKBUILD
+index de86f2aeb7..3a7d137533 100644
+--- a/main/libtool/APKBUILD
++++ b/main/libtool/APKBUILD
+@@ -4,13 +4,14 @@ pkgver=2.4.6
+ pkgrel=1
+ pkgdesc="A generic library support script"
+ arch="all"
+-license='GPL'
++license="GPL"
+ url="http://www.gnu.org/software/libtool"
+ source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz
+ libtool-fix-cross-compile.patch
+ "
+ depends="bash libltdl"
+ makedepends="m4 help2man"
++checkdepends="mawk autoconf automake gzip"
+ subpackages="libltdl $pkgname-doc"
+ options="libtool"
+
+@@ -23,7 +24,7 @@ build() {
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+- || return 1
++ lt_cv_shlibpath_overrides_runpath=yes
+ make
+ }
+
+@@ -32,6 +33,11 @@ package() {
+ make DESTDIR="$pkgdir" install
+ }
+
++check() {
++ cd "$builddir"
++ make check
++}
++
+ libltdl() {
+ pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
+ depends=