summaryrefslogtreecommitdiff
path: root/harmony/sed
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
commitfd2bb2f751c13b3c0c002b8e012810902b9da364 (patch)
tree17b2e38c966c9f96cfa568c1f572261a289590e6 /harmony/sed
parentb0a5136bf3326ba38b360be288d06f9a27f2a4d2 (diff)
downloadpackages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.gz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.bz2
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.xz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.zip
harmony -> system
Diffstat (limited to 'harmony/sed')
-rw-r--r--harmony/sed/APKBUILD49
-rw-r--r--harmony/sed/disable-mbrtowc-test.patch10
-rw-r--r--harmony/sed/localename-test-fix.patch34
-rw-r--r--harmony/sed/sed.post-deinstall6
4 files changed, 0 insertions, 99 deletions
diff --git a/harmony/sed/APKBUILD b/harmony/sed/APKBUILD
deleted file mode 100644
index 08fe6a55a..000000000
--- a/harmony/sed/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=sed
-pkgver=4.4
-pkgrel=1
-subpackages="$pkgname-doc"
-pkgdesc="GNU stream editor"
-url="http://www.gnu.org/software/sed"
-arch="all"
-license="GPL"
-options="!checkroot"
-makedepends="perl"
-install="$pkgname.post-deinstall"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
- disable-mbrtowc-test.patch
- localename-test-fix.patch
- "
-
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --bindir=/bin \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-i18n \
- --disable-nls
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-
- rm -rf "$pkgdir"/usr/lib/charset.alias || true
- rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
-}
-
-sha512sums="4e1b0a7403913f1e25047eb2292a0a9b3488b15b4463ce2803e05eaecbc2da19f477a18e6a70c992461c38ced90774415091aa2d8ce85cb74e391610d9eedb70 sed-4.4.tar.xz
-aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch
-3fbf7f5fbdef19f1212c4efad560b85e62744eecfe60eceaba1c8d093764f34bff844d31d704afdc064ca3d31bb7e46860a4b91e671b96930554a72953e88edf localename-test-fix.patch"
diff --git a/harmony/sed/disable-mbrtowc-test.patch b/harmony/sed/disable-mbrtowc-test.patch
deleted file mode 100644
index 51cdf3c25..000000000
--- a/harmony/sed/disable-mbrtowc-test.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- sed-4.4/gnulib-tests/test-mbrtowc5.sh.old 2016-12-31 13:54:43.000000000 +0000
-+++ sed-4.4/gnulib-tests/test-mbrtowc5.sh 2017-07-30 17:29:50.879924130 +0000
-@@ -1,6 +1,2 @@
- #!/bin/sh
--# Test whether the POSIX locale has encoding errors.
--LC_ALL=C \
--./test-mbrtowc${EXEEXT} 5 || exit
--LC_ALL=POSIX \
--./test-mbrtowc${EXEEXT} 5
-+exit 77
diff --git a/harmony/sed/localename-test-fix.patch b/harmony/sed/localename-test-fix.patch
deleted file mode 100644
index 8a5d68dde..000000000
--- a/harmony/sed/localename-test-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- sed-4.4/gnulib-tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ sed-4.4/gnulib-tests/localename.c 2017-07-30 16:40:47.098541270 +0000
-@@ -40,7 +40,7 @@
- # if defined __APPLE__ && defined __MACH__
- # include <xlocale.h>
- # endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined __linux__
- # include <langinfo.h>
- # endif
- # if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
- locale_t thread_locale = uselocale (NULL);
- if (thread_locale != LC_GLOBAL_LOCALE)
- {
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
- /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
- glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
-- const char *name =
-- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
-+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
- if (name[0] == '\0')
- /* Fallback code for glibc < 2.4, which did not implement
- nl_langinfo (_NL_LOCALE_NAME (category)). */
- name = thread_locale->__names[category];
-+# endif
- return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
- /* FreeBSD, Mac OS X */
diff --git a/harmony/sed/sed.post-deinstall b/harmony/sed/sed.post-deinstall
deleted file mode 100644
index 5ec0031a4..000000000
--- a/harmony/sed/sed.post-deinstall
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-# we cannot rely on the busybox trigger since sed might be used from install
-# scripts
-
-[ -x /bin/busybox ] && exec /bin/busybox --install -s