summaryrefslogtreecommitdiff
path: root/harmony/strace
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
commitfd2bb2f751c13b3c0c002b8e012810902b9da364 (patch)
tree17b2e38c966c9f96cfa568c1f572261a289590e6 /harmony/strace
parentb0a5136bf3326ba38b360be288d06f9a27f2a4d2 (diff)
downloadpackages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.gz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.bz2
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.xz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.zip
harmony -> system
Diffstat (limited to 'harmony/strace')
-rw-r--r--harmony/strace/APKBUILD65
-rw-r--r--harmony/strace/disable-fortify.patch39
-rw-r--r--harmony/strace/fix-ppc-pt-regs-collision.patch19
-rw-r--r--harmony/strace/nlattr-fix.patch21
4 files changed, 0 insertions, 144 deletions
diff --git a/harmony/strace/APKBUILD b/harmony/strace/APKBUILD
deleted file mode 100644
index aecde405f..000000000
--- a/harmony/strace/APKBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=strace
-pkgver=4.19
-pkgrel=0
-pkgdesc="A useful diagnositic, instructional, and debugging tool"
-url="https://strace.io/"
-arch="all"
-license="BSD"
-depends=""
-makedepends="linux-headers autoconf automake"
-subpackages="$pkgname-doc"
-options="!checkroot"
-source="$pkgname-$pkgver.tar.gz::https://github.com/strace/$pkgname/archive/v$pkgver.tar.gz
- disable-fortify.patch
- fix-ppc-pt-regs-collision.patch
- nlattr-fix.patch
- "
-
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- case "$CLIBC" in
- musl) export CFLAGS="$CFLAGS -Dsigcontext_struct=sigcontext" ;;
- esac
-
- case "$CARCH" in
- s390x)
- # __SIGNAL_FRAMESIZE is defined in asm/sigcontext.h
- # but including it would make conflict with struct sigcontext
- # since we compile with it in musl.
- # Temporarily add this until musl upstream has a proper fix
- # for struct sigcontext.
- export CFLAGS="$CFLAGS -D__SIGNAL_FRAMESIZE=160"
- ;;
- esac
-
- ./bootstrap
-
- ac_cv_have_long_long_off_t=yes \
- st_cv_m32_mpers=no \
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
-}
-
-sha512sums="fbf953d64b43785648e2df0eb6beee409c6b6f6c6a4d227b54c02a049031c5ff3a3a6af52a68a2980d89eb06dcafc36be5f8784728e9a28348145cdb4a7764f9 strace-4.19.tar.gz
-273b92ebf0069f19bef7ec26c7860e2af7ef01e782255c70ded1ae5e967f8f6bf031ecba96612c6083bf58f46278ba4ab3ec0fb35b08c8c8d668191f97adee52 disable-fortify.patch
-b70cee89dd49a2b5a69dc2a56c3a11169d3306e1a73981155188b574486965c034aa52b4ac1c6edff5ef55c9d52f27750acb242fac095a8a9f69689b51b3fad1 fix-ppc-pt-regs-collision.patch
-44b1872cf996caa4970fa6c2875a3a2cffe4a38455e328d968bd7855ef9a05cf41190794dc137bc8667576635f5271057cf0e6cde9a6c7aee66afd1dba9bdba0 nlattr-fix.patch"
diff --git a/harmony/strace/disable-fortify.patch b/harmony/strace/disable-fortify.patch
deleted file mode 100644
index 26b2978c5..000000000
--- a/harmony/strace/disable-fortify.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Subject: [PATCH] don't use fortify-headers on netlink test sources
-From: A. Wilcox <AWilcox@Wilcox-Tech.com>
-
-We can't use fortify-headers on netlink tests because it tests what happens
-when a buffer overrun occurs.
-
---- strace-4.18/tests/netlink_protocol.c.old 2017-07-05 07:08:09.000000000 +0000
-+++ strace-4.18/tests/netlink_protocol.c 2017-08-17 01:09:45.822502012 +0000
-@@ -28,6 +28,8 @@
- * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-+#define _FORTIFY_SOURCE 0
-+
- #include "tests.h"
-
- #ifdef HAVE_SYS_XATTR_H
---- strace-4.18/tests/netlink_sock_diag.c.old 2017-07-05 07:08:09.000000000 +0000
-+++ strace-4.18/tests/netlink_sock_diag.c 2017-08-17 01:10:00.935807300 +0000
-@@ -27,6 +27,8 @@
- * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-+#define _FORTIFY_SOURCE 0
-+
- #include "tests.h"
- #include <stdio.h>
- #include <string.h>
---- strace-4.18/tests/nlattr.c.old 2017-07-05 07:08:09.000000000 +0000
-+++ strace-4.18/tests/nlattr.c 2017-08-17 01:10:11.862453682 +0000
-@@ -28,6 +28,8 @@
- * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-+#define _FORTIFY_SOURCE 0
-+
- #include "tests.h"
-
- #include <stdio.h>
diff --git a/harmony/strace/fix-ppc-pt-regs-collision.patch b/harmony/strace/fix-ppc-pt-regs-collision.patch
deleted file mode 100644
index 6de0fcdd6..000000000
--- a/harmony/strace/fix-ppc-pt-regs-collision.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/ptrace.h
-+++ b/ptrace.h
-@@ -48,7 +48,15 @@
- # define ptrace_peeksiginfo_args XXX_ptrace_peeksiginfo_args
- #endif
-
--#include <linux/ptrace.h>
-+#if defined(__powerpc__) || defined(__powerpc64__)
-+# include <linux/types.h>
-+# define __ASSEMBLY__
-+# include <linux/ptrace.h>
-+# undef __ASSEMBLY__
-+#else
-+# include <linux/ptrace.h>
-+#endif
-+
-
- #ifdef HAVE_STRUCT_IA64_FPREG
- # undef ia64_fpreg
diff --git a/harmony/strace/nlattr-fix.patch b/harmony/strace/nlattr-fix.patch
deleted file mode 100644
index 6d480fabb..000000000
--- a/harmony/strace/nlattr-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- strace-4.18/tests/nlattr.c.old 2017-07-05 07:08:09.000000000 +0000
-+++ strace-4.18/tests/nlattr.c 2017-08-17 00:25:26.734218699 +0000
-@@ -61,7 +61,7 @@
- };
- struct msg *msg;
- struct nlattr *nla;
-- unsigned int msg_len;
-+ uint32_t msg_len;
- long rc;
-
- /* fetch fail: len < sizeof(struct nlattr) */
-@@ -259,7 +259,7 @@
- };
- struct msg *msg;
- struct nlattr *nla;
-- unsigned int msg_len;
-+ uint32_t msg_len;
- long rc;
-
- msg_len = NLMSG_SPACE(sizeof(msg->udm)) + sizeof(*nla);
-