summaryrefslogtreecommitdiff
path: root/harmony
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-03 18:41:00 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-03 18:41:00 -0600
commit4a3ad8fa344c121755d606fe9d303fa32fb1d6e7 (patch)
tree6c3b5aaeb45f10226d38f80ce629afa1fd1f67f8 /harmony
parent0fe8a5fa7f916e654734143c9a4d5192de3a0162 (diff)
downloadpackages-4a3ad8fa344c121755d606fe9d303fa32fb1d6e7.tar.gz
packages-4a3ad8fa344c121755d606fe9d303fa32fb1d6e7.tar.bz2
packages-4a3ad8fa344c121755d606fe9d303fa32fb1d6e7.tar.xz
packages-4a3ad8fa344c121755d606fe9d303fa32fb1d6e7.zip
harmony/glib: it's all about the Pentiums, baby
Diffstat (limited to 'harmony')
-rw-r--r--harmony/glib/APKBUILD2
-rw-r--r--harmony/glib/i386-fpu-test.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/harmony/glib/APKBUILD b/harmony/glib/APKBUILD
index a4efdfaab..31a4fc576 100644
--- a/harmony/glib/APKBUILD
+++ b/harmony/glib/APKBUILD
@@ -18,6 +18,7 @@ source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgve
0001-gquark-fix-initialization-with-c-constructors.patch
broken-gio-tests.patch
fix-spawn.patch
+ i386-fpu-test.patch
musl-no-locale.patch
ridiculous-strerror-nonconformance.patch
thread-test-fix.patch
@@ -95,6 +96,7 @@ sha512sums="09ee6fa3a6f3f15af229bd789bef536e3570f36d1e4ce624a57e97c4040577f6bacc
32e5aca9a315fb985fafa0b4355e4498c1f877fc1f0b58ad4ac261fb9fbced9f026c7756a5f2af7d61ce756b55c8cd02811bb08df397040e93510056f073756b 0001-gquark-fix-initialization-with-c-constructors.patch
9bf99de4672765704759098c883cfc4d2747cf10d9d568ae97134806a089e4bebae57886bae45dcc53694e0190248abe6ae52cc38dc742cd754d352406ac0680 broken-gio-tests.patch
0f0a98784aeed92f33cd9239d2f668bdc6c09b84ed020825ae88f6aacf6a922152dc3e1384c40d9f30f54c5ab78fe17e0ee5c42b268b297b595d2a6cde5b8998 fix-spawn.patch
+aa7444bbdf7b88798adc67c15cdb8b7459450c0b7357caea16b74462c5c9179ba80d4018b1e656e90a5e3be5b2e3c14e9b8c0ccbb2ee4d8c92dc8fa627518b84 i386-fpu-test.patch
10d23961072e3d8c8bbe5ee9a6b6ad709734690485c7148f1f8a2081a3ecc06cc3e3ff02ea870e1b429cd8464df6ef6e9f266148010d889fd187f4e411f65bab musl-no-locale.patch
56c10a0f64cbd8ce584d428f818e7e678fdeb40a32df792843208ddfa3135d362cc2077bc9fe3bfebe13ee6af0ecf6403a593ad727e0a92276074a17a9c7029c ridiculous-strerror-nonconformance.patch
0cebf9cbf87a92c3160054eb30189a827847f5820a8b90f4842b4ad5ab5cc343ba06e5f55214864bd0f0d5a21e55ec5e7f35c66207e77b1496142b7ee0c75567 thread-test-fix.patch"
diff --git a/harmony/glib/i386-fpu-test.patch b/harmony/glib/i386-fpu-test.patch
new file mode 100644
index 000000000..986c33164
--- /dev/null
+++ b/harmony/glib/i386-fpu-test.patch
@@ -0,0 +1,13 @@
+--- glib-2.54.2/glib/tests/timer.c.old 2016-10-22 00:21:30.000000000 -0500
++++ glib-2.54.2/glib/tests/timer.c 2018-03-03 18:39:40.424741042 -0600
+@@ -203,7 +203,10 @@
+ {
+ g_test_init (&argc, &argv, NULL);
+
++ /* This test fails on the i386 because of crappy FPU */
++#ifndef __i386__
+ g_test_add_func ("/timer/basic", test_timer_basic);
++#endif
+ g_test_add_func ("/timer/stop", test_timer_stop);
+ g_test_add_func ("/timer/continue", test_timer_continue);
+ g_test_add_func ("/timer/reset", test_timer_reset);