summaryrefslogtreecommitdiff
path: root/legacy/paxmark/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-10-04 17:54:03 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-10-04 17:54:03 +0000
commite21600c2762dffef8a31efad44cf9e172fdf6a72 (patch)
tree7824fd090bab27b1e8144b351ae682a05a154638 /legacy/paxmark/APKBUILD
parent72faf6a61ea307660f79d43519eadb952d853db5 (diff)
parentbadaa27d5febffd453f89d2f1a3bd3f5338bfef0 (diff)
downloadpackages-e21600c2762dffef8a31efad44cf9e172fdf6a72.tar.gz
packages-e21600c2762dffef8a31efad44cf9e172fdf6a72.tar.bz2
packages-e21600c2762dffef8a31efad44cf9e172fdf6a72.tar.xz
packages-e21600c2762dffef8a31efad44cf9e172fdf6a72.zip
Merge branch 'remove-paxmark' into 'master'
Move system/paxmark to legacy/ See merge request adelie/packages!335
Diffstat (limited to 'legacy/paxmark/APKBUILD')
-rw-r--r--legacy/paxmark/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/legacy/paxmark/APKBUILD b/legacy/paxmark/APKBUILD
new file mode 100644
index 000000000..3c9c69400
--- /dev/null
+++ b/legacy/paxmark/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=paxmark
+pkgver=0.11
+pkgrel=1
+pkgdesc="Manage PaX marking of executables"
+url="https://alpinelinux.org"
+arch="noarch"
+options="!check"
+license="GPL-2.0-only"
+depends="attr bash"
+makedepends=""
+install=""
+subpackages=""
+source="paxmark"
+
+package() {
+ mkdir -p "$pkgdir"/usr/sbin
+ install -m755 "$srcdir"/paxmark "$pkgdir"/usr/sbin
+ ln -s paxmark "$pkgdir"/usr/sbin/paxmark.sh
+}
+
+sha512sums="ed904790bfa6c86e216e2c8c1ed8fb1f997b7d1a55f997459655e402d8eec6447095709e38472cf909ea4d03e623e3e0eeddc0da57378901fe9d18d8c14b68d8 paxmark"