summaryrefslogtreecommitdiff
path: root/legacy/telegram/rlottie.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-07-03 17:12:43 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:02 -0500
commit9ac6bc00a1563dc270d2464054709bdfd0592af0 (patch)
tree4de9184024cc83be041c79ce0b1acf4da9448e7d /legacy/telegram/rlottie.patch
parent8a240ed95da6e3299fd0542d2799499866080494 (diff)
downloadpackages-9ac6bc00a1563dc270d2464054709bdfd0592af0.tar.gz
packages-9ac6bc00a1563dc270d2464054709bdfd0592af0.tar.bz2
packages-9ac6bc00a1563dc270d2464054709bdfd0592af0.tar.xz
packages-9ac6bc00a1563dc270d2464054709bdfd0592af0.zip
user/telegram: Move to legacy/
Big-endian support never landed, which takes out two architectures. Telegram never built properly on ARMv7, which takes out another one. This violates our policy of packages in user/ being available for a minimum of 5 of 6 architectures unless it is a system-specific package. Additionally, there have been internal disagreements on how to approach handling of the API key material. On the personal side, I don't have a lot of time to chase upstream, and I don't want to ship something potentially security-sensitive in such a state.
Diffstat (limited to 'legacy/telegram/rlottie.patch')
-rw-r--r--legacy/telegram/rlottie.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/legacy/telegram/rlottie.patch b/legacy/telegram/rlottie.patch
new file mode 100644
index 000000000..6bd2ff6c3
--- /dev/null
+++ b/legacy/telegram/rlottie.patch
@@ -0,0 +1,16 @@
+No CMake config exists for rlottie; use pkgconf instead.
+
+--- a/cmake/external/rlottie/CMakeLists.txt 2020-01-17 18:21:17.000000000 +0100
++++ b/cmake/external/rlottie/CMakeLists.txt 2020-01-18 00:37:40.280438388 +0100
+@@ -8,8 +8,9 @@
+ add_library(external_rlottie INTERFACE IMPORTED GLOBAL)
+ add_library(desktop-app::external_rlottie ALIAS external_rlottie)
+
+- find_package(rlottie REQUIRED)
+- target_link_libraries(external_rlottie INTERFACE rlottie::rlottie)
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(RLOTTIE REQUIRED rlottie)
++ target_link_libraries(external_rlottie INTERFACE ${RLOTTIE_LIBRARIES})
+ else()
+ add_library(external_rlottie OBJECT)
+ add_library(desktop-app::external_rlottie ALIAS external_rlottie)