summaryrefslogtreecommitdiff
path: root/scripts/bootstrap-abuild
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-12-08 23:56:37 -0600
committerZach van Rijn <me@zv.io>2022-12-08 23:56:37 -0600
commit31dea3d20c273c791cdb094a828cf555d81871c0 (patch)
tree1f1c10088685bada21ebbd7c4c4e2d12d0d6d5fa /scripts/bootstrap-abuild
parent6711bd463a80186880d0762e1b21e200798e4ef4 (diff)
downloadpackages-31dea3d20c273c791cdb094a828cf555d81871c0.tar.gz
packages-31dea3d20c273c791cdb094a828cf555d81871c0.tar.bz2
packages-31dea3d20c273c791cdb094a828cf555d81871c0.tar.xz
packages-31dea3d20c273c791cdb094a828cf555d81871c0.zip
Miscellaneous cleaning & updating. Mega descriptive i know.
Diffstat (limited to 'scripts/bootstrap-abuild')
-rwxr-xr-xscripts/bootstrap-abuild39
1 files changed, 14 insertions, 25 deletions
diff --git a/scripts/bootstrap-abuild b/scripts/bootstrap-abuild
index 4333113a8..c35dd2f51 100755
--- a/scripts/bootstrap-abuild
+++ b/scripts/bootstrap-abuild
@@ -14,28 +14,6 @@ git config --global http.sslCAInfo "${CURL_CA_BUNDLE}";
mkdir -p "${DEST}";
cd "${DEST}"; # this directory will already exist if correct
-if false; then # provided by latest 'bootstrap'
-##
-# Perl
-#
-nprl=perl;
-vprl=5.36.0;
-test ! -f ._${vprl}-${vprl} && \
-(
- test ! -d ${nprl}-${vprl} \
- && curl -s https://www.cpan.org/src/${vprl%%.*}.0/perl-${vprl}.tar.gz \
- | tar -xzf - \
- ;
- cd ${nprl}-${vprl};
- rm -fr x; mkdir x; cd x;
- ../Configure -des;
- make -j$(nproc);
- make install;
-)
-touch ._${nprl}-${vprl};
-rm -fr ${nprl}-${vprl};
-fi
-
##
# musl
#
@@ -53,7 +31,7 @@ test ! -f ._${nmus}-${vmus} && \
cd ${nmus}-${vmus};
rm -fr x; mkdir x; cd x;
../configure \
- --prefix="${DEST}" \
+ --prefix=/usr \
--enable-static \
--enable-shared \
;
@@ -279,6 +257,11 @@ test ! -f ._${natl}-${vatl} && \
sed -i Make.rules \
-e '/targets += $(__shlibs) $(shobjs)/d' \
; # disable shared libs
+ sed -i Make.rules \
+ -e '/CC.*:=/d' \
+ -e '/AR.*:=/d' \
+ -e '/LD.*:=/d' \
+ ; # inherit from environment
sed -i src/Makefile \
-e 's/$(install-libapk_so)//g' -e 's/$(libapk_so)//g' \
-e 's/ version.o/ version.o strlcpy.o/' \
@@ -331,14 +314,20 @@ test ! -f ._${nfrt}-${vfrt#*:} && \
;
cd ${nfrt}-${vfrt};
git checkout ${vfrt};
+ while read k; do curl -s ${k} | patch -p1 || true; done <<EOF
+https://git.alpinelinux.org/aports/plain/main/fakeroot/do-not-redefine-id_t.patch?id=bb497eeb2155d0332284942105692bc05fec25a9
+https://git.alpinelinux.org/aports/plain/main/fakeroot/fakeroot-no64.patch?id=bb497eeb2155d0332284942105692bc05fec25a9
+https://git.alpinelinux.org/aports/plain/main/fakeroot/fakeroot-stdint.patch?id=bb497eeb2155d0332284942105692bc05fec25a9
+https://git.alpinelinux.org/aports/plain/main/fakeroot/fix-format.patch?id=bb497eeb2155d0332284942105692bc05fec25a9
+https://git.alpinelinux.org/aports/plain/main/fakeroot/fix-shell-in-fakeroot.patch?id=bb497eeb2155d0332284942105692bc05fec25a9
+EOF
./bootstrap;
f=$(mktemp); # needed due to "error: unknown type name 'cap_user_header_t'"
echo > ${f} "#include <linux/capability.h>";
cat libfakeroot.c >> ${f};
mv ${f} libfakeroot.c;
rm -fr x; mkdir x; cd x;
- # -D_ID_T is for "error: conflicting types for 'id_t'; have 'int'"
- CFLAGS="-D_ID_T" \
+ CFLAGS="-D_STAT_VER=0 $CFLAGS" \
../configure \
--prefix="${DEST}" \
;