summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-07-22 04:35:28 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-07-22 04:35:28 -0500
commitd8b10a28a5c35b9c5d57527e47c275977da1dffc (patch)
tree362a7bb15d005ba4008dd6d96f5ecc41d80cea8f /sys-apps
parent55c5f1f459d223f8682f8883dd9b2671bee25a9b (diff)
downloadpackages-d8b10a28a5c35b9c5d57527e47c275977da1dffc.tar.gz
packages-d8b10a28a5c35b9c5d57527e47c275977da1dffc.tar.bz2
packages-d8b10a28a5c35b9c5d57527e47c275977da1dffc.tar.xz
packages-d8b10a28a5c35b9c5d57527e47c275977da1dffc.zip
sys-apps/apk-tools: version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/apk-tools/apk-tools-2.6.6-r1.ebuild47
-rw-r--r--sys-apps/apk-tools/files/apk-tools-2.6.6-revisions-are-equal.patch28
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/apk-tools/apk-tools-2.6.6-r1.ebuild b/sys-apps/apk-tools/apk-tools-2.6.6-r1.ebuild
new file mode 100644
index 000000000..94318cf68
--- /dev/null
+++ b/sys-apps/apk-tools/apk-tools-2.6.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2015-2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=6
+
+DESCRIPTION="The Alpine Linux Package Keeper (APK)"
+HOMEPAGE="http://alpinelinux.org/"
+SRC_URI="http://git.alpinelinux.org/cgit/apk-tools/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="arm mips ppc x86 x86_64 ~alpha ~arm64 ~hppa ~ppc64 ~sparc64"
+IUSE="static" # lua
+
+DEPEND="dev-libs/libfetch[ssl]"
+RDEPEND="${DEPEND}
+ >=dev-libs/openssl-1.0.1p
+ static? ( >=dev-libs/openssl-1.0.1p[static-libs] )
+ sys-libs/zlib
+ static? ( sys-libs/zlib[static-libs] )
+"
+# lua? ( dev-lang/lua:5.2 )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-use-sha256-signature.patch
+ "${FILESDIR}"/${P}-revisions-are-equal.patch
+ )
+
+src_configure() {
+ #if ! use lua; then
+ echo 'LUAAPK=' >> "${S}"/config.mk
+ echo 'export LUAAPK' >> "${S}"/config.mk
+ #fi
+}
+
+src_compile () {
+ export CFLAGS=-Wno-error=unused-result
+ emake
+ use static && emake static
+}
+
+pkg_preinst () {
+ mkdir -p "${D}"/usr/sbin
+ mv "${D}"/sbin/apk "${D}"/usr/sbin/apk
+ use static && "${D}"/sbin/apk.static "${D}"/usr/sbin/apk.static
+ rmdir "${D}"/sbin
+}
diff --git a/sys-apps/apk-tools/files/apk-tools-2.6.6-revisions-are-equal.patch b/sys-apps/apk-tools/files/apk-tools-2.6.6-revisions-are-equal.patch
new file mode 100644
index 000000000..d227d560c
--- /dev/null
+++ b/sys-apps/apk-tools/files/apk-tools-2.6.6-revisions-are-equal.patch
@@ -0,0 +1,28 @@
+From 072a8a45280f38317f2d9676e0a4c5f973635e20 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Fri, 22 Jul 2016 04:32:12 -0500
+Subject: [PATCH] version: consider pkg-rX and pkg to be the same version
+
+---
+ src/version.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/version.c b/src/version.c
+index 212a5d1..5a790b5 100644
+--- a/src/version.c
++++ b/src/version.c
+@@ -218,6 +218,11 @@
+ if (at == bt)
+ return APK_VERSION_EQUAL;
+
++ /* if only difference is pkgrev, they are equal. */
++ if ((at == TOKEN_REVISION_NO && bt == TOKEN_END) ||
++ (at == TOKEN_END && bt == TOKEN_REVISION_NO))
++ return APK_VERSION_EQUAL;
++
+ /* leading version components and their values are equal,
+ * now the non-terminating version is greater unless it's a suffix
+ * indicating pre-release */
+--
+2.9.2
+