summaryrefslogtreecommitdiff
path: root/sys-libs/librpc
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-06-11 08:41:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-06-11 08:41:26 +0000
commit2f6caac6019e3182486965f7f09baed7e93e1be9 (patch)
tree2d5d4350a1bbf9bafdb5f0a5260714a6190c668d /sys-libs/librpc
parenta37f6bfc3fde25205ebac44b82f1586b924c61da (diff)
downloadpackages-2f6caac6019e3182486965f7f09baed7e93e1be9.tar.gz
packages-2f6caac6019e3182486965f7f09baed7e93e1be9.tar.bz2
packages-2f6caac6019e3182486965f7f09baed7e93e1be9.tar.xz
packages-2f6caac6019e3182486965f7f09baed7e93e1be9.zip
The New Plan
ebuild branch has old ebuilds. profiles dir still has CFLAGS. Everything else is removed or modified for changing of upstream to Alpine.
Diffstat (limited to 'sys-libs/librpc')
-rw-r--r--sys-libs/librpc/Manifest1
-rw-r--r--sys-libs/librpc/files/librpc-20151104-fix-throw-decls.patch27
-rw-r--r--sys-libs/librpc/files/librpc-20151104-perror.patch11
-rw-r--r--sys-libs/librpc/files/librpc-20151104-sys-types.patch14
-rw-r--r--sys-libs/librpc/librpc-20151104.ebuild29
5 files changed, 0 insertions, 82 deletions
diff --git a/sys-libs/librpc/Manifest b/sys-libs/librpc/Manifest
deleted file mode 100644
index e93a57ca8..000000000
--- a/sys-libs/librpc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST librpc-20151104.tar.gz 91567 SHA256 1ffc8d719fcb28fccf4bc5ef9dbfb0ede247fa30deb01e3767727c1dcfc3b2de SHA512 7d175bb6b842e92c82b6c87b33ae091d2383902f846a9b6ec75181c04aa94b98f0dce22496651de763f3c8d3633e7cdd78873a0bcb4c4128e90cd357042d323c WHIRLPOOL 62e2c6c84069a73b70abc25c1cb426395abedb7788993d2db58b65622cf8a65332cd26f12909e5a6980a0f51d9057bc7e3ff0d3f88afb7fd161cf973cd8f1a61
diff --git a/sys-libs/librpc/files/librpc-20151104-fix-throw-decls.patch b/sys-libs/librpc/files/librpc-20151104-fix-throw-decls.patch
deleted file mode 100644
index fb97933ff..000000000
--- a/sys-libs/librpc/files/librpc-20151104-fix-throw-decls.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- librpc-uclibc-a921e3d/rpc/compat.h.old 2015-11-04 19:33:16.000000000 +0100
-+++ librpc-uclibc-a921e3d/rpc/compat.h 2016-08-30 10:01:17.226733271 +0100
-@@ -4,6 +4,24 @@
- #define _XOPEN_SOURCE
- #define _GNU_SOURCE
-
-+#if !defined(__THROW)
-+# if defined(__cplusplus)
-+# define __THROW throw()
-+# else
-+# define __THROW
-+# endif
-+#endif
-+
-+#if !defined(__BEGIN_DECLS) && !defined(__END_DECLS)
-+# if defined(__cplusplus)
-+# define __BEGIN_DECLS extern "C" {
-+# define __END_DECLS }
-+# else
-+# define __BEGIN_DECLS
-+# define __END_DECLS
-+# endif
-+#endif
-+
- #include <features.h>
- #include <errno.h>
-
diff --git a/sys-libs/librpc/files/librpc-20151104-perror.patch b/sys-libs/librpc/files/librpc-20151104-perror.patch
deleted file mode 100644
index c5f0fc2c0..000000000
--- a/sys-libs/librpc/files/librpc-20151104-perror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- librpc-uclibc-a921e3d/clnt_perror.c.old 2015-11-04 19:33:16.000000000 +0100
-+++ librpc-uclibc-a921e3d/clnt_perror.c 2016-08-30 10:11:16.410813772 +0100
-@@ -428,7 +428,7 @@
- }
-
-
--static void __attribute_used__
-+static void __attribute__((used))
- free_mem (void)
- {
- free (buf);
diff --git a/sys-libs/librpc/files/librpc-20151104-sys-types.patch b/sys-libs/librpc/files/librpc-20151104-sys-types.patch
deleted file mode 100644
index 197f5e0e6..000000000
--- a/sys-libs/librpc/files/librpc-20151104-sys-types.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- librpc-uclibc-a921e3d/rpc/types.h.old 2015-11-04 19:33:16.000000000 +0100
-+++ librpc-uclibc-a921e3d/rpc/types.h 2016-08-30 10:08:22.426289916 +0100
-@@ -79,6 +79,11 @@
- #include <sys/types.h>
- #endif
-
-+#if !defined(__GLIBC__) && !defined(__UCLIBC__)
-+typedef gid_t __gid_t;
-+typedef uid_t __uid_t;
-+#endif
-+
- #include <sys/time.h>
- #include <sys/param.h>
-
diff --git a/sys-libs/librpc/librpc-20151104.ebuild b/sys-libs/librpc/librpc-20151104.ebuild
deleted file mode 100644
index 869bd623a..000000000
--- a/sys-libs/librpc/librpc-20151104.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 2016 Adélie Linux Team
-# Distributed under the terms of the NCSA License
-
-EAPI=6
-
-CMAKE_MIN_VERSION=2.6
-# Required for silliness.
-CMAKE_IN_SOURCE_BUILD=true
-
-inherit cmake-utils
-
-DESCRIPTION="Standalone librpc forked from uclibc"
-HOMEPAGE="http://openwrt.org/"
-SRC_URI="http://git.openwrt.org/project?p=project/librpc-uclibc.git;a=snapshot;h=a921e3ded051746f9f7cd5e5a312fb6771716aac;sf=tgz -> librpc-20151104.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="mips ~ppc ~ppc64 x86 x86_64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/librpc-uclibc-a921e3d"
-
-PATCHES=( "${FILESDIR}/${P}-fix-throw-decls.patch"
- "${FILESDIR}/${P}-perror.patch"
- "${FILESDIR}/${P}-sys-types.patch"
-)