summaryrefslogtreecommitdiff
path: root/system/abuild
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-19 22:29:44 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-19 22:29:44 -0500
commit6a9b6c9d44711b15ffa435b8cb9d8e16b4d4f2b8 (patch)
treed9ee254f637d2b9104e732a6e7806278fc71749d /system/abuild
parent9525f51dde4cbbadc078d05abdaff4b8c28f9e97 (diff)
downloadpackages-6a9b6c9d44711b15ffa435b8cb9d8e16b4d4f2b8.tar.gz
packages-6a9b6c9d44711b15ffa435b8cb9d8e16b4d4f2b8.tar.bz2
packages-6a9b6c9d44711b15ffa435b8cb9d8e16b4d4f2b8.tar.xz
packages-6a9b6c9d44711b15ffa435b8cb9d8e16b4d4f2b8.zip
system/abuild: bump to 3.2.0_rc1, add -doc
Diffstat (limited to 'system/abuild')
-rw-r--r--system/abuild/0001-abuild-add-env-option-to-require-tests.patch33
-rw-r--r--system/abuild/APKBUILD25
-rw-r--r--system/abuild/adelie-customisations.patch48
-rw-r--r--system/abuild/newapkbuild-cmake.patch35
-rw-r--r--system/abuild/posix-abuild.patch68
5 files changed, 8 insertions, 201 deletions
diff --git a/system/abuild/0001-abuild-add-env-option-to-require-tests.patch b/system/abuild/0001-abuild-add-env-option-to-require-tests.patch
deleted file mode 100644
index 49497421b..000000000
--- a/system/abuild/0001-abuild-add-env-option-to-require-tests.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d85a92478fc8a95bdcb4bf84c30c20ca935abc08 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Tue, 24 Oct 2017 14:48:52 +0200
-Subject: [PATCH] abuild: add env option to require tests
-
-This adds an env option REQUIRE_CHECK to require testsuites to
-be run. This does not clutter getopts so it can be safely removed
-afterwards when we enforce tests globally. This will allow our CI
-infrastructure to enforce testsuites where possible.
----
- abuild.in | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/abuild.in b/abuild.in
-index 41b465d..7e3c818 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -226,6 +226,12 @@ default_sanitycheck() {
- check_secfixes_comment || return 1
-
- makedepends_has 'g++' && ! options_has toolchain && warning "g++ should not be in makedepends"
-+
-+ if ! options_has "!check" && [ -n "$REQUIRE_CHECK" ]; then
-+ (unset check; . "$APKBUILD"; type check >/dev/null 2>&1) || \
-+ die "Testsuites (abuild check) are required or needs to be explicitly disabled!"
-+ fi
-+
- return 0
- }
-
---
-2.14.2
-
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 8dd1c12b6..5db264711 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,10 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abuild
-pkgver=3.1.0
-_ver=${pkgver%_git*}
-pkgrel=2
-pkgdesc="Script to build Alpine Packages"
-url="http://git.alpinelinux.org/cgit/abuild/"
+pkgver=3.2.0_rc1
+pkgrel=0
+pkgdesc="Script to build APK packages"
+url="https://code.foxkit.us/adelie/aports"
arch="all"
license="GPL-2.0"
depends="fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
@@ -17,16 +16,12 @@ makedepends_host="openssl-dev zlib-dev"
makedepends="$makedepends_host $makedepends_build"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
- abuild-rootbld:_rootbld:noarch"
+ abuild-rootbld:_rootbld:noarch $pkgname-doc"
options="suid !check"
pkggroups="abuild"
-source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
- posix-abuild.patch
- newapkbuild-cmake.patch
- adelie-customisations.patch
- 0001-abuild-add-env-option-to-require-tests.patch
+source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz
"
-builddir="$srcdir/$pkgname-$_ver"
+builddir="$srcdir/$pkgname-$pkgver+adelie"
prepare() {
default_prepare
@@ -71,8 +66,4 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="bb9093d67942e3a63e4e053692c0bca30940cae05955518206cd9f7029211a188b7f442456ae126e61cbdca224eddb31e967d5cf0637e16893163cc963871a52 abuild-3.1.0.tar.xz
-86194084e95cdb42d4b1bc3d4ff2b8144125aa4e7f74f8c97023c55f2304d27d8c377baf5075666c9b43323506357b962d83d4a30a3f41cde7b53542889adf2d posix-abuild.patch
-705c393b37c37a364473590190122a43a2962946290a873e6685cd4eb43c4874bfdf7489e7b655f870b332dee38edca5dcf2d3906461001875a55b9e6549b824 newapkbuild-cmake.patch
-e27f29b94fe55fe59ab9dc28986cd1755a41221ad6b4457c7c0b268e561f7c6946ea6fcb8b7ace897acfde2e4660ec7150ef43fb0c71c6c20dfd38aa1d062140 adelie-customisations.patch
-e02cc44c8ad9dd61c9b80684b8cf5b64477a6fd6221cde9efea2a7594c6e7ce01a51f8bd4b80d72f82f7caf93217979fb0b354c420983891fa93f34c4252a035 0001-abuild-add-env-option-to-require-tests.patch"
+sha512sums="8d9e66ec6a4e814f9be0a10b53c4b183afa97c9969d9bb86fdec0b9096756d6343cec4840fb61a5812eb4879e61c106adbdd286e63d9cfc4f8b66b6cad79557b abuild-3.2.0_rc1+adelie.tar.xz"
diff --git a/system/abuild/adelie-customisations.patch b/system/abuild/adelie-customisations.patch
deleted file mode 100644
index db7280abc..000000000
--- a/system/abuild/adelie-customisations.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/functions.sh.in b/functions.sh.in
-index 4f2c023..a4de25c 100644
---- a/functions.sh.in
-+++ b/functions.sh.in
-@@ -5,16 +5,20 @@ program=${0##*/}
-
- arch_to_hostspec() {
- case "$1" in
-- aarch64) echo "aarch64-alpine-linux-musl" ;;
-- armel) echo "armv5-alpine-linux-musleabi" ;;
-- armhf) echo "armv6-alpine-linux-muslgnueabihf" ;;
-- armv7) echo "armv7-alpine-linux-musleabihf" ;;
-- ppc) echo "powerpc-alpine-linux-musl" ;;
-- ppc64) echo "powerpc64-alpine-linux-musl" ;;
-- ppc64le) echo "powerpc64le-alpine-linux-musl" ;;
-- s390x) echo "s390x-alpine-linux-musl" ;;
-- x86) echo "i586-alpine-linux-musl" ;;
-- x86_64) echo "x86_64-alpine-linux-musl" ;;
-+ aarch64) echo "aarch64-foxkit-linux-musl" ;;
-+ armel) echo "armv5-foxkit-linux-musleabi" ;;
-+ armhf) echo "armv6-foxkit-linux-muslgnueabihf" ;;
-+ armv7) echo "armv7-foxkit-linux-musleabihf" ;;
-+ i528) echo "pentium4-foxkit-linux-musl" ;;
-+ mips) echo "mips-foxkit-linux-musl" ;;
-+ mips32) echo "mips32el-foxkit-linux-musl" ;;
-+ pmmx) echo "i586-foxkit-linux-musl" ;;
-+ ppc) echo "powerpc-foxkit-linux-musl" ;;
-+ ppc64) echo "powerpc64-foxkit-linux-musl" ;;
-+ ppc64le) echo "powerpc64le-foxkit-linux-musl" ;;
-+ s390x) echo "s390x-foxkit-linux-musl" ;;
-+ x86) echo "i486-foxkit-linux-musl" ;;
-+ x86_64) echo "x86_64-foxkit-linux-musl" ;;
- *) echo "unknown" ;;
- esac
- }
-@@ -25,7 +29,11 @@ hostspec_to_arch() {
- arm*-*-*-*eabi) echo "armel" ;;
- armv6*-*-*-*eabihf) echo "armhf" ;;
- armv7*-*-*-*eabihf) echo "armv7" ;;
-- i[0-9]86-*-*-*) echo "x86" ;;
-+ i486-*-*-*) echo "x86" ;;
-+ i586-*-*-*) echo "pmmx" ;;
-+ mips32*-*-*-*) echo "mips32" ;;
-+ mips*-*-*-*) echo "mips" ;;
-+ pentium4-*-*-*) echo "i528" ;;
- powerpc-*-*-*) echo "ppc" ;;
- powerpc64-*-*-*) echo "ppc64" ;;
- powerpc64le-*-*-*) echo "ppc64le" ;;
diff --git a/system/abuild/newapkbuild-cmake.patch b/system/abuild/newapkbuild-cmake.patch
deleted file mode 100644
index e83ba753a..000000000
--- a/system/abuild/newapkbuild-cmake.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 4e0fb906bb3c77f307763a9565295e7d23a3b5e7 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Wed, 11 Oct 2017 17:47:23 -0500
-Subject: [PATCH] newapkbuild: add default check to CMake and RelWithDebugInfo
- type
-
----
- newapkbuild.in | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index c11aa39..d1cf2b9 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -66,11 +66,16 @@ build_cmake() {
- -DCMAKE_INSTALL_PREFIX=/usr \\
- -DCMAKE_INSTALL_LIBDIR=lib \\
- -DBUILD_SHARED_LIBS=True \\
-- -DCMAKE_BUILD_TYPE=Release \\
-+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \\
- -DCMAKE_CXX_FLAGS="\$CXXFLAGS" \\
- -DCMAKE_C_FLAGS="\$CFLAGS" \\
- \${CMAKE_CROSSOPTS}
- make
-+}
-+
-+check() {
-+ cd "\$builddir"
-+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
- __EOF__
- }
-
---
-2.14.1
-
diff --git a/system/abuild/posix-abuild.patch b/system/abuild/posix-abuild.patch
deleted file mode 100644
index ae95bec72..000000000
--- a/system/abuild/posix-abuild.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- src/abuild.in 2017-09-19 07:02:57.000000000 -0500
-+++ src/abuild.in 2017-09-23 22:34:32.534221312 -0500
-@@ -1,4 +1,4 @@
--#!/bin/ash -e
-+#!/bin/sh -e
-
- # abuild - build apk packages (light version of makepkg)
- # Copyright (c) 2008-2015 Natanael Copa <ncopa@alpinelinux.org>
-@@ -425,11 +425,11 @@
- tar -C "$srcdir" --lzip -xf "$s" || return 1;;
- *.tar.lzma)
- msg "Unpacking $s..."
-- unlzma -c "$s" | tar -C "$srcdir" -x \
-+ unlzma -c "$s" | tar -C "$srcdir" -f - -x \
- || return 1;;
- *.tar.xz)
- msg "Unpacking $s..."
-- unxz -c "$s" | tar -C "$srcdir" -x || return 1;;
-+ unxz -c "$s" | tar -C "$srcdir" -f - -x || return 1;;
- *.zip)
- msg "Unpacking $s..."
- unzip -n -q "$s" -d "$srcdir" || return 1;;
-@@ -476,7 +476,7 @@
- subpkgarch=${_splitarch#*:}
- if [ "$subpkgarch" = "$_splitarch" -o -z "$subpkgarch" ]; then
- case "$subpkgname" in
-- *-doc | *-lang | *-lang-*) subpkgarch="noarch" ;;
-+ *-doc | *-lang | *-lang-* | *-openrc) subpkgarch="noarch" ;;
- *) subpkgarch="$pkgarch" ;;
- esac
- fi
-@@ -1395,7 +1395,7 @@
- touch .dummy
- set -- .dummy
- fi
-- tar --xattrs -f - -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
-+ tar --format pax --xattrs -f - -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
-
- msg "Create checksum..."
- # append the hash for data.tar.gz
-@@ -1404,7 +1404,7 @@
-
- # control.tar.gz
- cd "$dir"
-- tar -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
-+ tar --format pax -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
- | gzip -9 > control.tar.gz
- abuild-sign -q control.tar.gz || exit 1
-
-@@ -1483,9 +1483,7 @@
-
- # predefined function check
- default_check() {
-- warning "APKBUILD does not run any tests!"
-- msg2 "Alpine policy will soon require that packages have any relevant testsuites run during the build process."
-- msg2 "To fix, either define a check() function, or declare !check in \$options to indicate the package does not have a testsuite."
-+ die "APKBUILD does not run any tests!"
- }
-
- check() {
-@@ -2337,6 +2335,7 @@
- }
-
- usage() {
-+ echo "$program $program_version"
- cat <<-EOF
- usage: $program [options] [-P REPODEST] [-s SRCDEST] [-D DESCRIPTION] [cmd] ...
- $program [-c] -n PKGNAME[-PKGVER]