summaryrefslogtreecommitdiff
path: root/system/abuild
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-07 01:44:42 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-07 01:44:42 +0000
commit6f60a5f69b99dd845c689119f7d0f519a043dff2 (patch)
treee475b7ed6a295073157b6a59ea37dfa12b51f2ea /system/abuild
parent5dba7907e14196aa368b0d84d3a2df7a0fd55123 (diff)
downloadpackages-6f60a5f69b99dd845c689119f7d0f519a043dff2.tar.gz
packages-6f60a5f69b99dd845c689119f7d0f519a043dff2.tar.bz2
packages-6f60a5f69b99dd845c689119f7d0f519a043dff2.tar.xz
packages-6f60a5f69b99dd845c689119f7d0f519a043dff2.zip
system/abuild: bump to 3.3.1
Diffstat (limited to 'system/abuild')
-rw-r--r--system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch31
-rw-r--r--system/abuild/0001-newapkbuild-fix-typo.patch25
-rw-r--r--system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch40
-rw-r--r--system/abuild/APKBUILD32
-rw-r--r--system/abuild/checkapk-libarchive-tar.patch11
-rw-r--r--system/abuild/use-pigz.patch19
6 files changed, 7 insertions, 151 deletions
diff --git a/system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch b/system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch
deleted file mode 100644
index d3bcb70ca..000000000
--- a/system/abuild/0001-abuild-continue-faking-POSIX-support-for-now.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 2a696e782445c020db606e92f49a7afb8b9bda1a Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sun, 20 May 2018 02:10:36 -0500
-Subject: [PATCH] abuild: continue faking POSIX support for now
-
----
- abuild.in | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index bd32f4e..e3a35ca 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -1,4 +1,4 @@
--#!/bin/ash -e
-+#!/bin/sh -e
-
- # abuild - build apk packages (light version of makepkg)
- # Copyright (c) 2008-2015 Natanael Copa <ncopa@alpinelinux.org>
-@@ -441,7 +441,7 @@ default_unpack() {
- tar -C "$srcdir" -xf "$s" || return 1;;
- *.tar.gz|*.tgz)
- msg "Unpacking $s..."
-- $gunzip -c "$s" | tar -C "$srcdir" -x || return 1;;
-+ $gunzip -c "$s" | tar -C "$srcdir" -f - -x || return 1;;
- *.tar.bz2)
- msg "Unpacking $s..."
- tar -C "$srcdir" -jxf "$s" || return 1;;
---
-2.15.0
-
diff --git a/system/abuild/0001-newapkbuild-fix-typo.patch b/system/abuild/0001-newapkbuild-fix-typo.patch
deleted file mode 100644
index 9df4f8526..000000000
--- a/system/abuild/0001-newapkbuild-fix-typo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 15299d6c47c3a0fdd0091691ad3461680f1cadff Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Tue, 22 May 2018 21:50:06 -0500
-Subject: [PATCH 1/2] newapkbuild: fix typo
-
----
- newapkbuild.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index 541f261..1a005c3 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -170,7 +170,7 @@ newaport() {
- pkgname=$pn
- fi
- if [ -e "$pkgname"/APKBUILD ] && [ -z "$force" ]; then
-- error "$pkgname/APKBUILD already exist"
-+ error "$pkgname/APKBUILD already exists"
- return 1
- fi
- mkdir -p "$pkgname"
---
-2.15.0
-
diff --git a/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch b/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch
deleted file mode 100644
index 338aff758..000000000
--- a/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From d3040cca076e187259e4aa4b1d613752d7254fcd Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Tue, 22 May 2018 21:50:55 -0500
-Subject: [PATCH 2/2] newapkbuild: move checksum call to after fetch
-
-unpack will no longer unpack without a checksum, even with -f. This
-means that newapkbuild will not be able to deduce what kind of build
-system is contained within, so the templates for CMake, Perl, etc are
-never used.
-
-This patch ensures checksumming is done right after fetch, so that
-unpack works properly.
----
- newapkbuild.in | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index 1a005c3..77d1a8b 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -228,7 +228,7 @@ subpackages="\$pkgname-dev \$pkgname-doc"
- source="$source"
- __EOF__
-
-- abuild -f fetch unpack
-+ abuild -f fetch checksum unpack
- # Figure out the builddir
- for i in src/*; do
- if [ -d "$i" ]; then
-@@ -339,7 +339,6 @@ __EOF__
- }
-
- __EOF__
-- abuild -f checksum
- }
-
- usage() {
---
-2.15.0
-
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 5e462a8c9..7e4693246 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abuild
-pkgver=3.2.0_rc1
-pkgrel=5
+pkgver=3.3.1
+pkgrel=0
pkgdesc="Script to build APK packages"
url="https://code.foxkit.us/adelie/aports"
arch="all"
@@ -15,17 +15,10 @@ makedepends_build="pkgconfig"
makedepends_host="openssl-dev zlib-dev"
makedepends="$makedepends_host $makedepends_build"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-subpackages="apkbuild-cpan:cpan:noarch abuild-rootbld:_rootbld:noarch
- $pkgname-doc"
+subpackages="abuild-rootbld:_rootbld:noarch $pkgname-doc"
options="suid !check"
pkggroups="abuild"
-source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz
- 0001-abuild-continue-faking-POSIX-support-for-now.patch
- 0001-newapkbuild-fix-typo.patch
- 0002-newapkbuild-move-checksum-call-to-after-fetch.patch
- use-pigz.patch
- checkapk-libarchive-tar.patch
- "
+source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz"
builddir="$srcdir/$pkgname-$pkgver+adelie"
prepare() {
@@ -50,14 +43,8 @@ package() {
# hardcoded to use Alpine repositories and URLs.
# maybe rewrite some day, pending user demand.
rm "$pkgdir"/usr/bin/apkbuild-gem-resolver
-}
-
-cpan() {
- pkgdesc="Script to generate perl APKBUILD from CPAN"
- depends="perl perl-libwww perl-json perl-module-build-tiny"
-
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/apkbuild-cpan "$subpkgdir"/usr/bin/
+ # very broken
+ rm "$pkgdir"/usr/bin/apkbuild-cpan
}
_rootbld() {
@@ -66,9 +53,4 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="8d9e66ec6a4e814f9be0a10b53c4b183afa97c9969d9bb86fdec0b9096756d6343cec4840fb61a5812eb4879e61c106adbdd286e63d9cfc4f8b66b6cad79557b abuild-3.2.0_rc1+adelie.tar.xz
-b7aa7ff9858eee2ff20eeed3b8da60d40e608b4da2676acb9c8b16ca6639283e5d70884888efd505fcd239bb462f726203e4773a4f706b16d07742b2a8631b6c 0001-abuild-continue-faking-POSIX-support-for-now.patch
-4ef673998b8f28469eeb4d1448a664f7052686466a67b1a3f3cab1e249ad44308df92737da4eae3c3ffea06806f460e23fc1c0ddccd7f9e82c4e308cb63be029 0001-newapkbuild-fix-typo.patch
-c6ebe8219c2e8ec9fc75da1c597b2d8d960e632286a6c7f1d1ffb6623b4d4acca54ae90a6c07637c589cbbe3ed2fb0da0c26a41df20cac0318b4894991e2dbf4 0002-newapkbuild-move-checksum-call-to-after-fetch.patch
-b428baddee9b719898a6e7f87d3a990aa1000cac0b6bcf3890e7cafd0ee164164551e7c4699d12f29ea9b6364cc18722a5560b0b65b9d8f586caf739a5432313 use-pigz.patch
-0acff1a66e327236aad85ab3b77724dd1ac398cc4db305fee82c6ead64ab9c9332c9ffa5d08c8607494e5925ced8d7b315670b2fe589c0df3b3fc61caea3acba checkapk-libarchive-tar.patch"
+sha512sums="c358f84d198527eeeac1a1aacc101174e18f9f34f692b12a4e4deb6b32d5f3ebdc703c90de6a6f81f195a81eebb90a11f9bfea13ef5db531d9b5d5ae6ecd6a66 abuild-3.3.1+adelie.tar.xz"
diff --git a/system/abuild/checkapk-libarchive-tar.patch b/system/abuild/checkapk-libarchive-tar.patch
deleted file mode 100644
index fb5243d02..000000000
--- a/system/abuild/checkapk-libarchive-tar.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- abuild-3.2.0_rc1+adelie/checkapk.in 2017-08-13 13:39:10.730229975 -0400
-+++ abuild-3.2.0_rc1+adelie/checkapk.in 2018-09-15 17:52:51.160104742 -0400
-@@ -72,7 +72,7 @@
- fi
-
- apk fetch --quiet --repositories-file $tmpdir/repositories --stdout $_pkgname \
-- | tar -zt | grep -v '^\.SIGN\.' | sort > filelist-$_pkgname-old \
-+ | tar -ztf - | grep -v '^\.SIGN\.' | sort > filelist-$_pkgname-old \
- || die "failed to download old pkg, maybe run 'apk update'?"
-
- tar -ztf "$filepath" | grep -v '^\.SIGN\.' | sort > "filelist-$_pkgname"
diff --git a/system/abuild/use-pigz.patch b/system/abuild/use-pigz.patch
deleted file mode 100644
index a917c8f81..000000000
--- a/system/abuild/use-pigz.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- abuild-3.2.0_rc1+adelie/abuild.in.old 2018-05-20 03:17:19.884154704 +0000
-+++ abuild-3.2.0_rc1+adelie/abuild.in 2018-08-31 17:42:34.900000000 +0000
-@@ -1466,6 +1466,7 @@
- local datadir="$pkgbasedir"/$name
- local subpkgname=$name
- local subpkgarch=$(pkginfo_val arch $file)
-+ local _mygzip=$(command -v pigz gzip | head -1)
-
- trace_apk_deps "$name" "$dir" "$subpkgarch" || return 1
- msg "Package size: ${size}"
-@@ -1478,7 +1479,7 @@
- touch .dummy
- set -- .dummy
- fi
-- tar --format pax --xattrs -f - -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
-+ tar --format pax --xattrs -f - -c "$@" | abuild-tar --hash | $_mygzip -9 >"$dir"/data.tar.gz
-
- msg "Create checksum..."
- # append the hash for data.tar.gz