summaryrefslogtreecommitdiff
path: root/system/adelie-base/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-06-13 12:31:44 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-06-13 12:31:44 +0000
commit59f4c22ed29293ebb908472be46e28991959f14a (patch)
treea953fe0d49a9cde23ac0ef9c833ea508f0820455 /system/adelie-base/APKBUILD
parenta7ffe23c8f4296a8f9398b404d1a047e668c5640 (diff)
downloadpackages-59f4c22ed29293ebb908472be46e28991959f14a.tar.gz
packages-59f4c22ed29293ebb908472be46e28991959f14a.tar.bz2
packages-59f4c22ed29293ebb908472be46e28991959f14a.tar.xz
packages-59f4c22ed29293ebb908472be46e28991959f14a.zip
system/adelie-base: it builds now
Diffstat (limited to 'system/adelie-base/APKBUILD')
-rw-r--r--system/adelie-base/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/system/adelie-base/APKBUILD b/system/adelie-base/APKBUILD
index 4ad282db4..ac1f2dbcb 100644
--- a/system/adelie-base/APKBUILD
+++ b/system/adelie-base/APKBUILD
@@ -8,12 +8,12 @@ pkgdesc="The Adélie Linux Base System"
url="http://adelielinux.org/"
arch="noarch"
license="NCSA"
-depends="apk-tools shadow v:mta v:syslog libarchive zsh binutils at coreutils diffutils v:cron file findutils shimmy grep noxcuse procps util-linux nail man patch sed sharutils bc vim psmisc net-tools kbd"
+depends="apk-tools shadow postfix rsyslog libarchive zsh binutils at coreutils diffutils dcron file findutils shimmy grep procps util-linux mailx man patch sed sharutils bc vim psmisc net-tools kbd"
makedepends=""
install=""
+options="!fhs"
subpackages="$pkgname-doc $pkgname-posix $pkgname-lsb"
source="https://distfiles.adelielinux.org/source/$pkgname/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir/"
build() {
return 0
@@ -21,6 +21,7 @@ build() {
package() {
cd "$builddir"
+ mkdir -p "$pkgdir"
make install DESTDIR="$pkgdir"
}
@@ -34,11 +35,13 @@ doc() {
posix() {
depends="cups ed m4 pax cflow ncompress"
+ mkdir -p "$subpkgdir"
return 0
}
lsb() {
depends="cpio gzip nspr nss gettext make ncurses mawk pam"
+ mkdir -p "$subpkgdir"
return 0
}