summaryrefslogtreecommitdiff
path: root/system/adelie-base
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-28 22:31:51 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-28 22:31:51 +0000
commit412d288bc4d13d5c6dfc61f7c879b1fad5c71c68 (patch)
tree116f7ecd0d4723e0d0aa58f7d7c03a6a4a9f03c2 /system/adelie-base
parent6990bd384a5a11f1dfa75bc32d094dd02d1851a2 (diff)
downloadpackages-412d288bc4d13d5c6dfc61f7c879b1fad5c71c68.tar.gz
packages-412d288bc4d13d5c6dfc61f7c879b1fad5c71c68.tar.bz2
packages-412d288bc4d13d5c6dfc61f7c879b1fad5c71c68.tar.xz
packages-412d288bc4d13d5c6dfc61f7c879b1fad5c71c68.zip
system/adelie-base: use heirloom-devtools instead of m4 for m4
GNU M4 does not pass compliance tests
Diffstat (limited to 'system/adelie-base')
-rw-r--r--system/adelie-base/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/system/adelie-base/APKBUILD b/system/adelie-base/APKBUILD
index 901a05ad1..5cebd3c92 100644
--- a/system/adelie-base/APKBUILD
+++ b/system/adelie-base/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=adelie-base
pkgver=0.8.1
-pkgrel=5
+pkgrel=6
pkgdesc="The Adélie Linux Base System"
url="http://adelielinux.org/"
arch="noarch"
@@ -66,20 +66,22 @@ doc() {
DOCS="CONTRIBUTING.rst LICENSE README.rst"
for _doc in $DOCS; do
install -Dm644 "$srcdir"/$pkgname-$pkgver/$_doc \
- "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc
done
}
posix() {
# We pull in vim for /usr/bin/ex, until apk has an alternatives system
- depends="adelie-base at bc cflow ed fcron heirloom-pax m4 mailx mawk vim"
+ depends="adelie-base at bc cflow ed fcron heirloom-devtools
+ heirloom-pax mailx mawk vim"
pkgdesc="$pkgdesc - Additional POSIX tools"
mkdir -p "$subpkgdir"
return 0
}
lsb() {
- depends="adelie-base gettext-tiny gzip libarchive-tools linux-pam make mawk ncurses nspr nss"
+ depends="adelie-base gettext-tiny gzip libarchive-tools linux-pam make
+ mawk ncurses nspr nss"
pkgdesc="$pkgdesc - Additional LSB tools"
mkdir -p "$subpkgdir"
return 0