summaryrefslogtreecommitdiff
path: root/system/apk-tools
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2019-08-05 01:16:41 +0000
committerSamuel Holland <samuel@sholland.org>2019-08-05 01:16:41 +0000
commit8466b5559e008686681ddd100cf8cdd9d01c3e2c (patch)
treecbce46a474b56517b5604ee02f696a4302257012 /system/apk-tools
parent3bf6c2f14c0cd6b736b5c74b3f48de16a81f74cc (diff)
downloadpackages-8466b5559e008686681ddd100cf8cdd9d01c3e2c.tar.gz
packages-8466b5559e008686681ddd100cf8cdd9d01c3e2c.tar.bz2
packages-8466b5559e008686681ddd100cf8cdd9d01c3e2c.tar.xz
packages-8466b5559e008686681ddd100cf8cdd9d01c3e2c.zip
system/apk-tools: Fix build with dash as /bin/sh
Signed-off-by: Samuel Holland <samuel@sholland.org>
Diffstat (limited to 'system/apk-tools')
-rw-r--r--system/apk-tools/APKBUILD2
-rw-r--r--system/apk-tools/dash.patch14
2 files changed, 16 insertions, 0 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index 5305ed1cb..c20759d7c 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -13,6 +13,7 @@ makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-static"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ dash.patch
pmmx.patch
search.patch
virtual.patch
@@ -70,6 +71,7 @@ static() {
}
sha512sums="d2d9fde0aae9059236f68a3fc2f2186104bb9a099b15d296a6202a20ab2912638f10bb3b9edb70f359d060c5839573c3d50ef37d13095fa01c66dc3219ab6e39 apk-tools-2.10.4.tar.xz
+7f2559e72cb3a6fc7752971e65c1888fb867da07d0aa7d53af56f41ee8716f6cfe0b8c3589840032233094a31d63ac4a0a2f7681c9a5ecf72eff90b2ff826e88 dash.patch
78f863c83af8b245aa38416c47016bcbe95ea8e33802123f6ea54b3752eb3c1ee79e5d6fc76ddedd2fba522b82a7367837f4596321085d54397b27fd5edf3b2f pmmx.patch
5ac09eadabe44fe05c952c25df8f6daca292c63e6e5e3481d57603b8b3f1980385ccd87ad4a87b617353d1f936591afb9ee8815e4d8ec3e33913be2b3e3a3f84 search.patch
4e2a8db82e6e40ae4863d12ee55151468d6e8c383e2e2001015f469e07f47057bc9055ab52a4a04f2bffa41ec225f77a9bd6042d5e1fcbd2908d7393e3aed2a1 virtual.patch"
diff --git a/system/apk-tools/dash.patch b/system/apk-tools/dash.patch
new file mode 100644
index 000000000..811427d3c
--- /dev/null
+++ b/system/apk-tools/dash.patch
@@ -0,0 +1,14 @@
+--- apk-tools-2.10.4/test/solver.sh
++++ apk-tools-2.10.4/test/solver.sh
+@@ -11,9 +11,9 @@ TEST_TO_RUN="$@"
+ fail=0
+ pass=0
+ for test in ${TEST_TO_RUN:-*.test}; do
+- get_block ARGS < $test | xargs $APK_TEST &> .$test.got
++ get_block ARGS < $test | xargs $APK_TEST > .$test.got 2>&1
+
+- if ! get_block EXPECT < $test | cmp .$test.got &> /dev/null; then
++ if ! get_block EXPECT < $test | cmp .$test.got > /dev/null 2>&1; then
+ fail=$((fail+1))
+ echo "FAIL: $test"
+ get_block EXPECT < $test | diff -ru - .$test.got