summaryrefslogtreecommitdiff
path: root/system/argon2
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 01:28:22 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 01:28:22 -0500
commitf989818e7ce43d52d578ff60b0f20026045b4cbc (patch)
tree7061a21f9597ec9258db0e4645b01270021cc2c0 /system/argon2
parentb95de892f5a2573e7586db5c7578994330ab49c7 (diff)
downloadpackages-f989818e7ce43d52d578ff60b0f20026045b4cbc.tar.gz
packages-f989818e7ce43d52d578ff60b0f20026045b4cbc.tar.bz2
packages-f989818e7ce43d52d578ff60b0f20026045b4cbc.tar.xz
packages-f989818e7ce43d52d578ff60b0f20026045b4cbc.zip
system/argon2: pull in for cryptsetup
Diffstat (limited to 'system/argon2')
-rw-r--r--system/argon2/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/system/argon2/APKBUILD b/system/argon2/APKBUILD
new file mode 100644
index 000000000..53145f7bc
--- /dev/null
+++ b/system/argon2/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Corey Oliver <coreyjonoliver@gmail.com>
+# Maintainer:
+pkgname=argon2
+_pkgname=phc-winner-argon2
+pkgver=20171227
+pkgrel=1
+pkgdesc="Password hashing function Argon2"
+url="https://github.com/P-H-C/phc-winner-argon2"
+arch="all"
+license="Apache-2.0 AND CC0-1.0"
+subpackages="$pkgname-dev $pkgname-dev $pkgname-libs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/P-H-C/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make OPTTARGET=none
+}
+
+check() {
+ cd "$builddir"
+ make OPTTARGET=none test
+}
+
+package() {
+ cd "$builddir"
+ make OPTTARGET=none DESTDIR="$pkgdir" install
+}
+
+sha512sums="9c9e1a3905e61ac6913d1e073c104477e419ddd0506adc4487e88e98d19165ed8901fe8bb11246ed0cc71b3523c190da9692d5926642f86be09c3e67510afe4d argon2-20171227.tar.gz"