summaryrefslogtreecommitdiff
path: root/system/asciidoctor
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 06:06:35 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 06:07:35 +0000
commit45c7d18ee3236dae130150d80a32e4a37710cd24 (patch)
tree6d09bbb9fa669a71c850ad80addd8eb1ddc06731 /system/asciidoctor
parent36a36b43679fc2ba8b14bc2b828345b8e770c769 (diff)
downloadpackages-45c7d18ee3236dae130150d80a32e4a37710cd24.tar.gz
packages-45c7d18ee3236dae130150d80a32e4a37710cd24.tar.bz2
packages-45c7d18ee3236dae130150d80a32e4a37710cd24.tar.xz
packages-45c7d18ee3236dae130150d80a32e4a37710cd24.zip
Update Ruby to 2.7.1
* Coroutines are using libucontext; added to ruby depends_dev. * Asciidoctor updated to 2.x branch since we have newer Ruby now. * uWSGI may not work properly with Rack; currently untested.
Diffstat (limited to 'system/asciidoctor')
-rw-r--r--system/asciidoctor/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/system/asciidoctor/APKBUILD b/system/asciidoctor/APKBUILD
index 760f82d81..188751c26 100644
--- a/system/asciidoctor/APKBUILD
+++ b/system/asciidoctor/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Seung Soo Mun <hamletmun@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=asciidoctor
-pkgver=1.5.8
+pkgver=2.0.10
pkgrel=0
pkgdesc="An implementation of AsciiDoc in Ruby"
url="https://rubygems.org/gems/$pkgname"
@@ -13,7 +13,7 @@ makedepends=""
source="https://rubygems.org/downloads/$pkgname-$pkgver.gem"
package() {
- local gemdir="$(ruby -e 'puts Gem.default_dir')"
+ gemdir="$(ruby -e 'puts Gem.default_dir')"
gem install \
--local \
@@ -26,7 +26,7 @@ package() {
rm -rf "$pkgdir"/$gemdir/cache
cd "$pkgdir"
- local i; for i in usr/lib/ruby/gems/*/bin/*; do
+ for i in usr/lib/ruby/gems/*/bin/*; do
if [ -e "$i" ]; then
mkdir -p "$pkgdir"/usr/bin
ln -s /$i "$pkgdir"/usr/bin/
@@ -34,4 +34,4 @@ package() {
done
}
-sha512sums="34ff0df98ff9ebb2d3640629870cd848cf2f4b617564a42e7b30b6cf60c01d1188b4cc695af49550e054c9e833accc1ed5d622b4952ece3da99c8ed98af769ac asciidoctor-1.5.8.gem"
+sha512sums="41db1947da60be27079eaef99c76ae7a20797f0291313ac82582466774a569130e995c674f7ef884a05d3d3783d70df3d5ef83b42ded1c722dd9ab7b1a3357ab asciidoctor-2.0.10.gem"