summaryrefslogtreecommitdiff
path: root/system/at
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 19:21:28 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 19:21:28 -0500
commitb71fe05dce49b3453b5b556be023b831344a62a8 (patch)
treee8c17ecca61918d1dd4a0c10f1d38043737b474c /system/at
parent33ab6f745fc7bcbc62a04445ec26bed721aabff4 (diff)
downloadpackages-b71fe05dce49b3453b5b556be023b831344a62a8.tar.gz
packages-b71fe05dce49b3453b5b556be023b831344a62a8.tar.bz2
packages-b71fe05dce49b3453b5b556be023b831344a62a8.tar.xz
packages-b71fe05dce49b3453b5b556be023b831344a62a8.zip
system/at: add for POSIX
Diffstat (limited to 'system/at')
-rw-r--r--system/at/10-Makefile.in-1.patch11
-rw-r--r--system/at/10-parsetime.l-1.patch11
-rw-r--r--system/at/10-parsetime.y-1.patch14
-rw-r--r--system/at/APKBUILD63
-rw-r--r--system/at/at.allow1
-rw-r--r--system/at/at.pre-install6
-rw-r--r--system/at/atd.initd27
7 files changed, 133 insertions, 0 deletions
diff --git a/system/at/10-Makefile.in-1.patch b/system/at/10-Makefile.in-1.patch
new file mode 100644
index 000000000..2a036aace
--- /dev/null
+++ b/system/at/10-Makefile.in-1.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig.in
++++ ./Makefile.in
+@@ -12,7 +12,7 @@
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
+ man8dir = $(mandir)/man8
+-docdir = $(prefix)/doc
++docdir = $(prefix)/share/doc
+ atdocdir = $(docdir)/at
+ etcdir = @ETCDIR@
+ systemdsystemunitdir = @systemdsystemunitdir@
diff --git a/system/at/10-parsetime.l-1.patch b/system/at/10-parsetime.l-1.patch
new file mode 100644
index 000000000..52fea53f4
--- /dev/null
+++ b/system/at/10-parsetime.l-1.patch
@@ -0,0 +1,11 @@
+--- ./parsetime.orig.l
++++ ./parsetime.l
+@@ -32,6 +32,8 @@
+ } while(0)
+ %}
+
++%option noyywrap
++
+ %%
+
+ now { COPY_TOK ; return NOW; }
diff --git a/system/at/10-parsetime.y-1.patch b/system/at/10-parsetime.y-1.patch
new file mode 100644
index 000000000..3eb0549e3
--- /dev/null
+++ b/system/at/10-parsetime.y-1.patch
@@ -0,0 +1,14 @@
+--- ./parsetime.orig.y
++++ ./parsetime.y
+@@ -17,6 +17,11 @@
+ extern int yylex();
+
+ int add_date(int number, int period);
++
++#ifndef __isleap
++#define __isleap(year) ((year) % 4 == 0 && ((year) % 100 != 0 || (year) % 400 == 0))
++#endif
++
+ %}
+
+ %union {
diff --git a/system/at/APKBUILD b/system/at/APKBUILD
new file mode 100644
index 000000000..280156524
--- /dev/null
+++ b/system/at/APKBUILD
@@ -0,0 +1,63 @@
+# Contributor: Alexander Belkov <msun00@yandex.ru>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=at
+pkgver=3.1.20
+pkgrel=3
+pkgdesc="Delayed job execution and batch processing daemon"
+url="https://packages.qa.debian.org/a/at.html"
+arch="all"
+options="!check suid" # No test suite.
+license="GPL-2.0+"
+makedepends="cmd:sendmail flex-dev byacc"
+depends_dev=""
+install="${pkgname}.pre-install"
+pkgusers="at"
+pkggroups="at"
+subpackages="$pkgname-doc $pkgname-openrc"
+source="http://http.debian.net/debian/pool/main/a/at/at_$pkgver.orig.tar.gz
+ 10-parsetime.l-1.patch
+ 10-parsetime.y-1.patch
+ 10-Makefile.in-1.patch
+ at.allow
+ atd.initd
+ "
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ LEXLIB=-lfl \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sbindir=/usr/sbin \
+ --runstatedir=/var/run \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ --with-jobdir=/var/spool/atd \
+ --with-atspool=/var/spool/atd
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -D -o root -g at -m 640 "$srcdir"/at.allow \
+ "$pkgdir"/etc/at.allow
+ make IROOT="$pkgdir" install
+ install -m 755 -D "$srcdir"/atd.initd \
+ "$pkgdir"/etc/init.d/atd
+}
+
+sha512sums="20a13512a86f988728f590712f5bf8a23f4dc44f4b42521a4dd4783dc1ba7ac2016ee87b4c2c14f2346a5839168a983d99c3195e947014aea3096a3db16d176f at_3.1.20.orig.tar.gz
+ec24581fd59de62a93a5914f57b811baaf00fcc8fe969a4c8d0eb0cb2fd939762871725fec406eb127763935ab95ea10e23f314144a5d08ede78ba3bcf231e4a 10-parsetime.l-1.patch
+9c06a4e92f3820a85ba75be8c14cb02762f6a5d4f0182bb2faafe51f5de2e35b0ce91e7e81f6e5b3127732c36c8e23e276a103aa0419661a602df93df274f855 10-parsetime.y-1.patch
+ba57e93c9c90dc989e8ac299c12de13de0005b28fd934620a9a5b47af89db3c0dc63e39043ab3a50d313ed2bb4f4832b1f68db971b3f515c500a2b74ed18acbd 10-Makefile.in-1.patch
+21e1bc024bd76c76b68e04614c6def5b03fd4b658e59bfde065b464b520f463711b795455e3a5c81a8a1946b2bca2f83d6c19300a4d3326ce17959a7cbc0846a at.allow
+fe5c075566ef1955e0eb4b4446fe1ea401940df6e0f29e4e2f1baf93e231214db58c707e99b16bb3a3c8c288a05fc390a44c6f09fde50d31f0ac631a98d86c2d atd.initd"
diff --git a/system/at/at.allow b/system/at/at.allow
new file mode 100644
index 000000000..d8649da39
--- /dev/null
+++ b/system/at/at.allow
@@ -0,0 +1 @@
+root
diff --git a/system/at/at.pre-install b/system/at/at.pre-install
new file mode 100644
index 000000000..78aa4bcf1
--- /dev/null
+++ b/system/at/at.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S at 2>/dev/null
+adduser -S -D -H -s /bin/false -G at -g at at 2>/dev/null
+
+exit 0
diff --git a/system/at/atd.initd b/system/at/atd.initd
new file mode 100644
index 000000000..733e5d04d
--- /dev/null
+++ b/system/at/atd.initd
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+
+# init.d file for atd (command scheduling daemon)
+
+command="/usr/sbin/$SVCNAME"
+pidfile="/var/run/$SVCNAME.pid"
+
+depend() {
+ after localmount
+}
+
+start() {
+ ebegin "Starting command scheduling daemon ${SVCNAME}"
+ start-stop-daemon --start --quiet \
+ --pidfile ${pidfile} \
+ --exec ${command}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping command scheduling daemon ${name}"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${pidfile} \
+ --exec ${command}
+ eend $?
+}
+