summaryrefslogtreecommitdiff
path: root/system/bash
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 00:29:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 00:29:26 +0000
commita403295128bf9dbfe33373380e61b30ab9e47fe2 (patch)
tree7277490c832539592a046f18fe8444d577c6ed4e /system/bash
parentac44a0fdcc4b5aaac38d6f23e8cd4584afc4a6da (diff)
downloadpackages-a403295128bf9dbfe33373380e61b30ab9e47fe2.tar.gz
packages-a403295128bf9dbfe33373380e61b30ab9e47fe2.tar.bz2
packages-a403295128bf9dbfe33373380e61b30ab9e47fe2.tar.xz
packages-a403295128bf9dbfe33373380e61b30ab9e47fe2.zip
system/*: remove checkroot, modernise
Diffstat (limited to 'system/bash')
-rw-r--r--system/bash/APKBUILD7
1 files changed, 0 insertions, 7 deletions
diff --git a/system/bash/APKBUILD b/system/bash/APKBUILD
index 9e01ae6fe..94ea6dbbd 100644
--- a/system/bash/APKBUILD
+++ b/system/bash/APKBUILD
@@ -14,7 +14,6 @@ license="GPL-3.0+"
makedepends_build="byacc flex"
makedepends_host="ncurses-dev"
depends=""
-options="!checkroot"
install="$pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang
$pkgname-binsh:binsh:noarch"
@@ -40,8 +39,6 @@ done
builddir="$srcdir"/$pkgname-$_myver
prepare() {
- cd "$builddir"
-
# NOTE: This section is for applying the vendor patches, which are required to fix
# security holes. `default_prepare` does *not* apply vendor patches in the format
# shipped with bash. We also need to make sure vendor patches are applied before
@@ -62,7 +59,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -77,14 +73,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd ${startdir}/src/${pkgname}-${_myver}
make DESTDIR=${pkgdir} install
-
install -D -m755 "$srcdir"/bashrc "$pkgdir"/etc/bash/bashrc
}