summaryrefslogtreecommitdiff
path: root/system/bash
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-06-03 23:28:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-06-03 23:28:26 +0000
commitc201ddecae188890079cac20a53232c7f361e393 (patch)
tree20fab95232adc91c19d743eecbd1c0fc00b11ce2 /system/bash
parent2f9cf649fd5ed77629c90f6a003eb2d303f61a71 (diff)
parent92563f5289c64332795cd296e2a9187a773f470c (diff)
downloadpackages-c201ddecae188890079cac20a53232c7f361e393.tar.gz
packages-c201ddecae188890079cac20a53232c7f361e393.tar.bz2
packages-c201ddecae188890079cac20a53232c7f361e393.tar.xz
packages-c201ddecae188890079cac20a53232c7f361e393.zip
Merge branch 'rootbld-providers' into 'master'
system/{bash-binsh,dash-binsh,build-tools}: add provider_priority This makes bash-binsh the default and should fix compatibility in /usr/bin/abuild for populating a chroot with only abuild, alpine-base (adelie-base), build-base (build-tools), and git See merge request !37
Diffstat (limited to 'system/bash')
-rw-r--r--system/bash/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/system/bash/APKBUILD b/system/bash/APKBUILD
index 5b6f7f6ed..79e77a736 100644
--- a/system/bash/APKBUILD
+++ b/system/bash/APKBUILD
@@ -94,6 +94,7 @@ package() {
binsh() {
pkgdesc="Use bash as /bin/sh"
provides="/bin/sh"
+ provider_priority=10
mkdir -p "$subpkgdir"/bin
ln -s /bin/bash "$subpkgdir"/bin/sh
}