summaryrefslogtreecommitdiff
path: root/system/binutils
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-09-11 18:15:55 -0500
committerMax Rees <maxcrees@me.com>2019-09-28 13:27:49 -0500
commit34908a6df0a38308174a2d27fec5169404de5075 (patch)
treea9c8ec907f9c35f0d7d4b779a0cc134d60ee7377 /system/binutils
parent1067b6142455d1f5f390d07ea722a69be4b803c4 (diff)
downloadpackages-34908a6df0a38308174a2d27fec5169404de5075.tar.gz
packages-34908a6df0a38308174a2d27fec5169404de5075.tar.bz2
packages-34908a6df0a38308174a2d27fec5169404de5075.tar.xz
packages-34908a6df0a38308174a2d27fec5169404de5075.zip
system/binutils: disable static 1d test for now (#170, #196)
Diffstat (limited to 'system/binutils')
-rw-r--r--system/binutils/APKBUILD2
-rw-r--r--system/binutils/disable-static-1d.patch42
2 files changed, 44 insertions, 0 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index c7924b43e..dadb06611 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -19,6 +19,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-gnu-mbind.patch
disable-ifunc-tests.patch
disable-preinit-array-tests.patch
+ disable-static-1d.patch
remove-pr2404-tests.patch
remove-pr19719-test.patch
remove-pr19553c-test.patch
@@ -139,6 +140,7 @@ ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735
d378fdf1964f8f2bd0b1e62827ac5884bdf943aa435ec89c29fc84bb045d406b733fffaff8fdd8bd1cba8ddea7701c4cf6ccf3ed76a8a3df9c72b447737575a6 disable-gnu-mbind.patch
474ab24097bbb5b24433620549e5234fe65c547824c1342f693c718ffbc81e2d968259cce2d650b55200dd1ec89da207ea2db10c551cd9941285c4600b4297b2 disable-ifunc-tests.patch
3537752e63cef0b5ef136d003ff7e814ba66b12624d817430112d0f291a792e8960fa69a78036f526af835441b3ee483d6a53d55c7b3dd8ee96f0399682dbcbe disable-preinit-array-tests.patch
+d4543d2f77808d317d17a5f0eb9af21540ef8543fceaed4e3524213e31e058333321f3ba3b495199e3b57bfd0c4164929cf679369470389e26871b8895cb0110 disable-static-1d.patch
32ab4215669c728648179c124632467573a3d4675e79f0f0d221c22eb2ec1ca5488b79910bd09142f90a1e0d0b81d99ca4846297f4f9561f158db63745facb66 remove-pr2404-tests.patch
a193d1fa7f42d91915960460a15e4d24e0df529d81e23014bcf45d283fae76bb7b300fdcb0d0a9d521cdb9137322efa1dc357112596d6ae7a7fd05988ac359b9 remove-pr19719-test.patch
39ef9c76dd5db6b15f11ffa8061f7ca844fb79c3fb9879c3b1466eef332a28b833597c87003ab9f260b1b85023fae264659088aee27cad7e5aa77b2d58b9a3f6 remove-pr19553c-test.patch
diff --git a/system/binutils/disable-static-1d.patch b/system/binutils/disable-static-1d.patch
new file mode 100644
index 000000000..daca64319
--- /dev/null
+++ b/system/binutils/disable-static-1d.patch
@@ -0,0 +1,42 @@
+The "No PLT (static 1d)" link test fails on pmmx and x86_64.
+lea is being emitted instead of mov.
+
+https://bts.adelielinux.org/show_bug.cgi?id=170
+https://bts.adelielinux.org/show_bug.cgi?id=196
+
+--- binutils-2.32/ld/testsuite/ld-x86-64/no-plt.exp 2019-01-19 10:01:34.000000000 -0600
++++ binutils-2.32/ld/testsuite/ld-x86-64/no-plt.exp 2019-09-11 17:21:27.232257151 -0500
+@@ -100,15 +100,6 @@ run_cc_link_tests [list \
+ "no-plt-1c" \
+ ] \
+ [list \
+- "No PLT (static 1d)" \
+- "-static tmpdir/no-plt-check1.o tmpdir/no-plt-main1.o \
+- tmpdir/no-plt-func1.o tmpdir/no-plt-extern1.o" \
+- "-Wa,-mx86-used-note=yes" \
+- {dummy.s} \
+- {{readelf -Wr no-plt-1d.rd} {objdump -dwrj.text no-plt-1d.dd}} \
+- "no-plt-1d" \
+- ] \
+- [list \
+ "No PLT (PIE 1e)" \
+ "-pie tmpdir/no-plt-check1.o tmpdir/no-plt-main1.o \
+ tmpdir/no-plt-func1.o tmpdir/no-plt-extern1.o" \
+--- binutils-2.32/ld/testsuite/ld-i386/no-plt.exp 2019-01-19 10:01:33.000000000 -0600
++++ binutils-2.32/ld/testsuite/ld-i386/no-plt.exp 2019-09-11 18:03:48.012302603 -0500
+@@ -102,15 +102,6 @@ run_cc_link_tests [list \
+ "no-plt-1c" \
+ ] \
+ [list \
+- "No PLT (static 1d)" \
+- "-static tmpdir/no-plt-check1a.o tmpdir/no-plt-main1.o \
+- tmpdir/no-plt-func1.o tmpdir/no-plt-extern1a.o" \
+- "-Wa,-mx86-used-note=yes" \
+- {dummy.s} \
+- {{readelf -Wr no-plt-1d.rd} {objdump -dwrj.text no-plt-1d.dd}} \
+- "no-plt-1d" \
+- ] \
+- [list \
+ "No PLT (PIE 1e)" \
+ "-pie tmpdir/no-plt-check1a.o tmpdir/no-plt-main1.o \
+ tmpdir/no-plt-func1.o tmpdir/no-plt-extern1a.o" \