summaryrefslogtreecommitdiff
path: root/system/binutils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-30 22:26:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-30 22:26:26 +0000
commit948e39e3934c7860b355e78cf6c93a51002ca9db (patch)
tree0e413a0acc4c2822124d1787ac460dad3127337b /system/binutils
parentac54368821fa09b8b1510de2b8da502bd3b52879 (diff)
downloadpackages-948e39e3934c7860b355e78cf6c93a51002ca9db.tar.gz
packages-948e39e3934c7860b355e78cf6c93a51002ca9db.tar.bz2
packages-948e39e3934c7860b355e78cf6c93a51002ca9db.tar.xz
packages-948e39e3934c7860b355e78cf6c93a51002ca9db.zip
system/binutils: patch to pass tests on aarch64
Diffstat (limited to 'system/binutils')
-rw-r--r--system/binutils/APKBUILD4
-rw-r--r--system/binutils/remove-pr19719-test.patch9
2 files changed, 12 insertions, 1 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 5fa5c7d6e..95d3ca91c 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.30
-pkgrel=0
+pkgrel=1
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -23,6 +23,7 @@ source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
mips-illegal-memcpy.patch
remove-no-static-plt-test.patch
remove-pr2404-tests.patch
+ remove-pr19719-test.patch
remove-pr19553c-test.patch
gold-mips.patch
"
@@ -136,5 +137,6 @@ ba2b5c8cdfa95db7a1f05da8a2c1ffc3bcb35300abf7061e52249d9b29037e3fdef1aed830686bca
06422157349abf02e79a5ef8bd9f51100e7e996aab65250d518e0cf0d7ac8ed922d3bf1603c4f5b4fd8fb179266b7b4c41db32dcb241d60a7f1c21d1df0c36dd mips-illegal-memcpy.patch
b40f9a3841a7af8fc12e8a4044cd672df5614bfda8461b0ca45efa57a42c3bc8490e491ea490c6c05d319a52d69993c4fca33a0aeb044090e7b7f4e4e30c6517 remove-no-static-plt-test.patch
32ab4215669c728648179c124632467573a3d4675e79f0f0d221c22eb2ec1ca5488b79910bd09142f90a1e0d0b81d99ca4846297f4f9561f158db63745facb66 remove-pr2404-tests.patch
+a193d1fa7f42d91915960460a15e4d24e0df529d81e23014bcf45d283fae76bb7b300fdcb0d0a9d521cdb9137322efa1dc357112596d6ae7a7fd05988ac359b9 remove-pr19719-test.patch
39ef9c76dd5db6b15f11ffa8061f7ca844fb79c3fb9879c3b1466eef332a28b833597c87003ab9f260b1b85023fae264659088aee27cad7e5aa77b2d58b9a3f6 remove-pr19553c-test.patch
f55cf2e0bf82f97583a1abe10710e4013ecf7d64f1da2ef8659a44a06d0dd8beaf58dab98a183488ea137f03e32d62efc878d95f018f836f8cec870bc448556f gold-mips.patch"
diff --git a/system/binutils/remove-pr19719-test.patch b/system/binutils/remove-pr19719-test.patch
new file mode 100644
index 000000000..8fbc08db6
--- /dev/null
+++ b/system/binutils/remove-pr19719-test.patch
@@ -0,0 +1,9 @@
+We always use -fPIE (it's in our spec file), so it isn't possible to test this.
+--- binutils-2.30/ld/testsuite/ld-elf/shared.exp.old 2018-05-25 06:28:07.252414401 +0000
++++ binutils-2.30/ld/testsuite/ld-elf/shared.exp 2018-05-25 06:51:50.637028357 +0000
+@@ -1102,5 +1102,4 @@
+ }
+ }
+
+-mix_pic_and_non_pic [list "arm*-*-*" "aarch64*-*-*"] "" "" "pr19719"
+ mix_pic_and_non_pic [] "-fPIE" "-pie" "pr19719pie"