summaryrefslogtreecommitdiff
path: root/system/bison
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:56 -0500
commitb1eb50599e4db7eb4501af75cbbfa22007081ea5 (patch)
treec94a34c882cc17adedd781e8c5f34349b2a62416 /system/bison
parentb9e85bbdcf38547ef2ca4e5c2a6e6293bbcd2752 (diff)
downloadpackages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.gz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.bz2
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.xz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.zip
The New Plan
all pkgs needed to bootstrap -> system others -> user
Diffstat (limited to 'system/bison')
-rw-r--r--system/bison/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/system/bison/APKBUILD b/system/bison/APKBUILD
new file mode 100644
index 000000000..382b04743
--- /dev/null
+++ b/system/bison/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Łukasz Jendrysik <scadu@yandex.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bison
+pkgver=3.0.4
+pkgrel=1
+pkgdesc="The GNU general-purpose parser generator"
+arch="all"
+license="GPL-3.0-or-later"
+url="https://www.gnu.org/software/bison/bison.html"
+makedepends="perl"
+depends="m4"
+checkdepends="bison flex"
+[ -n "$BOOTSTRAP" ] && options="!check"
+source="ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.xz"
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
+}
+
+sha512sums="bbdc23e7772e49da1c7c47e66d4e4efbfbfe9b21dbc59bf3ad9a6e573eecac6c9f52c7f11a64be9897e8deb99ef7ba015164aa8232aa391b901dd7db03632412 bison-3.0.4.tar.xz"