summaryrefslogtreecommitdiff
path: root/system/busybox
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 00:14:23 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 00:14:23 -0500
commit89103259e8947d3f9da5aa03fc49f37a31293675 (patch)
tree24730558e662802ba5e50780c8ce47b63ffa3419 /system/busybox
parent24eac36681eaeeda188b90d6d9a1cbd3a2aab5ed (diff)
downloadpackages-89103259e8947d3f9da5aa03fc49f37a31293675.tar.gz
packages-89103259e8947d3f9da5aa03fc49f37a31293675.tar.bz2
packages-89103259e8947d3f9da5aa03fc49f37a31293675.tar.xz
packages-89103259e8947d3f9da5aa03fc49f37a31293675.zip
system/busybox: no maintainer, fix pre-deinstall phase scripts
Diffstat (limited to 'system/busybox')
-rw-r--r--system/busybox/APKBUILD12
-rw-r--r--system/busybox/busybox-extras.pre-deinstall2
-rw-r--r--system/busybox/busybox.pre-deinstall9
3 files changed, 16 insertions, 7 deletions
diff --git a/system/busybox/APKBUILD b/system/busybox/APKBUILD
index ead7b4b55..c40864b4b 100644
--- a/system/busybox/APKBUILD
+++ b/system/busybox/APKBUILD
@@ -1,22 +1,22 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Oliver Smith <ollieparanoid@bitmessage.ch>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
pkgname=busybox
pkgver=1.27.2
-pkgrel=4
+pkgrel=5
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
+options="suid !check" # Test suite?
license="GPL-2.0-only"
makedepends_build=""
makedepends_host="linux-headers"
makedepends="$makedepends_build $makedepends_host"
checkdepends="zip"
-provides="/bin/sh /sbin/init"
-install="$pkgname.post-install $pkgname.post-upgrade
+provides="/sbin/init"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall
$pkgname-extras.post-install $pkgname-extras.pre-deinstall"
subpackages="$pkgname-static $pkgname-suid $pkgname-extras $pkgname-binsh"
-options="suid !check"
triggers="busybox.trigger=/bin:/usr/bin:/sbin:/usr/sbin:/lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0001-ash-add-support-for-command_not_found_handle-hook-fu.patch
@@ -43,7 +43,6 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
dad.if-up
nologin.c
"
-builddir="$srcdir"/$pkgname-$pkgver
_staticdir="$srcdir"/build-static
_dyndir="$srcdir"/build-dynamic
@@ -167,6 +166,7 @@ suid() {
binsh() {
pkgdesc="Provide /bin/sh with BusyBox ash"
depends="${pkgname}"
+ provides="/bin/sh"
mkdir -p "$subpkgdir"/bin
mv "$pkgdir"/bin/sh "$subpkgdir"/bin
diff --git a/system/busybox/busybox-extras.pre-deinstall b/system/busybox/busybox-extras.pre-deinstall
index 15461302c..5ae91ccbc 100644
--- a/system/busybox/busybox-extras.pre-deinstall
+++ b/system/busybox/busybox-extras.pre-deinstall
@@ -2,7 +2,7 @@
# Remove all symlinks to busybox-extras
cd /
-for link in $(busybox-extras --list --full); do
+for link in $(busybox-extras --list-full); do
if [ -L "$link" ] && [ "$(readlink $link)" = "/bin/busybox-extras" ]; then
rm "$link"
fi
diff --git a/system/busybox/busybox.pre-deinstall b/system/busybox/busybox.pre-deinstall
new file mode 100644
index 000000000..f1e10ba92
--- /dev/null
+++ b/system/busybox/busybox.pre-deinstall
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+# Remove all symlinks to busybox
+cd /
+for link in $(busybox --list-full); do
+ if [ -L "$link" ] && [ "$(readlink $link)" = "/bin/busybox" ]; then
+ rm "$link"
+ fi
+done