summaryrefslogtreecommitdiff
path: root/system/ca-certificates
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 04:22:12 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 04:22:12 +0000
commitfedeb0de594bf2405fde0272e3527583caea94be (patch)
tree2bb00148ad830269ba0fd323d1974d6773a94769 /system/ca-certificates
parente1d251a2095f2a7fcf8b9d9777cc8aaa9d82de49 (diff)
downloadpackages-fedeb0de594bf2405fde0272e3527583caea94be.tar.gz
packages-fedeb0de594bf2405fde0272e3527583caea94be.tar.bz2
packages-fedeb0de594bf2405fde0272e3527583caea94be.tar.xz
packages-fedeb0de594bf2405fde0272e3527583caea94be.zip
system/ca-certificates: bump to 20190131, modernise
Diffstat (limited to 'system/ca-certificates')
-rw-r--r--system/ca-certificates/APKBUILD23
-rw-r--r--system/ca-certificates/certhash2
2 files changed, 10 insertions, 15 deletions
diff --git a/system/ca-certificates/APKBUILD b/system/ca-certificates/APKBUILD
index 3dab0f01b..d5af2b91c 100644
--- a/system/ca-certificates/APKBUILD
+++ b/system/ca-certificates/APKBUILD
@@ -1,9 +1,7 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ca-certificates
-pkgver=20180411
-pkgrel=1
+pkgver=20190131
+pkgrel=0
pkgdesc="CA root certificates"
url="https://www.mozilla.org/en-US/about/governance/policies/security-group/certs/"
arch="all"
@@ -13,20 +11,18 @@ depends="debianutils"
makedepends_build="python3"
makedepends_host="openssl-dev"
subpackages="$pkgname-doc"
-# c_rehash is either in libcrypto1.0 or openssl depending on package, grr. replace both of them
-replaces="libcrypto1.0 openssl"
triggers="ca-certificates.trigger=/usr/share/ca-certificates:/usr/local/share/ca-certificates:/etc/ssl/certs:/etc/ca-certificates/update.d"
install="$pkgname.post-deinstall"
-source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
+ certhash
+ "
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -DSYMLINK_MAX=PATH_MAX"
make
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
(
@@ -44,11 +40,8 @@ package() {
-etc/ssl/certs/[0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f].[r0-9]*
EOF
- cat > "$pkgdir"/etc/ca-certificates/update.d/certhash <<-EOF
- #!/bin/sh
- exec /usr/bin/c_rehash /etc/ssl/certs
- EOF
- chmod +x "$pkgdir"/etc/ca-certificates/update.d/certhash
+ install -D -m755 "$srcdir"/certhash "$pkgdir"/etc/ca-certificates/update.d/certhash
}
-sha512sums="e7c0a8c4d876181f1826bcf1ed91554430af51751ad4d24911e5bf445c374b3592fd25242e5ae02b3eaa68e720f16e9af40a3d9a6098c8eeaa4479ecb880b153 ca-certificates-20180411.tar.xz"
+sha512sums="aec43296636887a8ebefc08abe60c123b67002eb8cf450662b5ff8fcbd2ea10d3d24d17080b5924b13aed9a52b91ba55e93d306e27ed3196ca67cbbe30146328 ca-certificates-20190131.tar.xz
+1efe48235f150052da6b872d2ebff174359825ab3bd66086c9d7f4c18dcd8aa8953c634dbf1aa8416d30d5623babf589660a25cf6e3a4cdcce707c14cc2f348a certhash"
diff --git a/system/ca-certificates/certhash b/system/ca-certificates/certhash
new file mode 100644
index 000000000..8943cd53f
--- /dev/null
+++ b/system/ca-certificates/certhash
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/c_rehash /etc/ssl/certs