summaryrefslogtreecommitdiff
path: root/system/coreutils
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-09-11 06:54:54 -0500
committerMax Rees <maxcrees@me.com>2019-09-28 13:27:49 -0500
commit1067b6142455d1f5f390d07ea722a69be4b803c4 (patch)
tree7c68fc6465bbafd0ae6bbfba5bd6fde15cf2c7ff /system/coreutils
parent96cac2093872a7b647d2bde53af20d90ebd3ffe3 (diff)
downloadpackages-1067b6142455d1f5f390d07ea722a69be4b803c4.tar.gz
packages-1067b6142455d1f5f390d07ea722a69be4b803c4.tar.bz2
packages-1067b6142455d1f5f390d07ea722a69be4b803c4.tar.xz
packages-1067b6142455d1f5f390d07ea722a69be4b803c4.zip
system/coreutils: skip bogus gnulib LOGNAME test
It is not necessarily true that LOGNAME will match the owner of the tty to which stdin is connected (sudo, su, ...)
Diffstat (limited to 'system/coreutils')
-rw-r--r--system/coreutils/APKBUILD2
-rw-r--r--system/coreutils/gnulib-test-fixes.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/system/coreutils/APKBUILD b/system/coreutils/APKBUILD
index 2860b3a43..23d96edbd 100644
--- a/system/coreutils/APKBUILD
+++ b/system/coreutils/APKBUILD
@@ -73,7 +73,7 @@ bd8b5cecba59eba30458c8afa895877d39a987b989bc06b70cd6836e0ef684677aaadcb4949b58a7
532ef8210261437855ba3e2fc72ec57b0e0252b2b0f7817990c9629613ece2cdd86cf30aa049f3cff6fbda12ed3bb9a0db3a3642475378ae44ce319bdf005d9b disable-mbrtowc-test.patch
86944e9ea5493c5b21ab62562a63aa134952738297b21cfb2e8f751db4a695ff25ee1592eb231ed1bb80999bc31f7504c7feffde2e93b4e068c05c44ac83cbdf localename-test-fix.patch
fd97fccd661befc558b3afb3e32c82dd2cef511a05e6129d49540599297c1b59ab1f109e63a12f585a2348c26c28fb98330c348829d1fe61cf8149d0dd1c989c gnulib-tests-dont-require-gpg-passphrase.patch
-a1d014a683fb3b2e08e7392f7589fd92a565e2a4d0cac1cf960968dd3d990e020fdd3bb6aea2bbeaca3ba8f2522b4da3d75b93f414ebf83d8b26b5ccbb38a64d gnulib-test-fixes.patch
+08f6de0e4c1615503a276fb7eb8abb3f1a996d3e9e4c789deb1507e9ac66364e3993591e37ee444d239c64bf3b7d61f909c0da5ead3047b75623cd846e9f868f gnulib-test-fixes.patch
aac3a89b27a7854fbf483e155df9133c3d33a0f36bd55d5606559a7781f9d27d5c17779ea427142311749252767097bf92ec22d4cf86b510568c186da84ff16c date-debug.patch
0b90b7721dd01bd22eba50f73bc756930dd4a8bc78ec408ce7f155a02b520375023897b9d12872030735d908208b912ea7adfac9e8b4d055e617873d982eef56 test-df-symlink-bindmount.patch"
[ "${CBUILD}" != "${CHOST}" ] && sha512sums="
diff --git a/system/coreutils/gnulib-test-fixes.patch b/system/coreutils/gnulib-test-fixes.patch
index abe010f7d..5455cf7cd 100644
--- a/system/coreutils/gnulib-test-fixes.patch
+++ b/system/coreutils/gnulib-test-fixes.patch
@@ -33,3 +33,15 @@
-
return 0;
}
+--- coreutils-8.31/gnulib-tests/test-getlogin.h 2019-01-04 10:14:43.000000000 -0600
++++ coreutils-8.31/gnulib-tests/test-getlogin.h 2019-09-11 06:50:47.791580246 -0500
+@@ -61,6 +61,9 @@ test_getlogin_result (const char *buf, i
+ struct stat stat_buf;
+ struct passwd *pwd;
+
++ fprintf (stderr, "Skipping test: this is a bogus assumption\n");
++ exit(77);
++
+ if (!isatty (STDIN_FILENO))
+ {
+ fprintf (stderr, "Skipping test: stdin is not a tty.\n");