summaryrefslogtreecommitdiff
path: root/system/cups-filters/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-04-02 21:36:27 -0400
committerMax Rees <maxcrees@me.com>2018-04-02 21:36:27 -0400
commitf3e82d8bf985424a0eb72ddd1dd89e090e6c4945 (patch)
tree3859fea44b74dda7ee459a2307227e931ebaeb8e /system/cups-filters/APKBUILD
parent61ce37455ec2f99ef314b876859ce24c9166ca1e (diff)
downloadpackages-f3e82d8bf985424a0eb72ddd1dd89e090e6c4945.tar.gz
packages-f3e82d8bf985424a0eb72ddd1dd89e090e6c4945.tar.bz2
packages-f3e82d8bf985424a0eb72ddd1dd89e090e6c4945.tar.xz
packages-f3e82d8bf985424a0eb72ddd1dd89e090e6c4945.zip
system/cups-filters: new package
APKBUILD based on Alpine's aport. Notable changes: * Add check() * Disable avahi (python2), mutool and ghostscript (licensing) * Remove textonly comment and makedepends=bash (removed several versions ago)
Diffstat (limited to 'system/cups-filters/APKBUILD')
-rw-r--r--system/cups-filters/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/system/cups-filters/APKBUILD b/system/cups-filters/APKBUILD
new file mode 100644
index 000000000..ad5d20cb7
--- /dev/null
+++ b/system/cups-filters/APKBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=cups-filters
+pkgver=1.19.0
+pkgrel=0
+pkgdesc="OpenPrinting CUPS filters and backends"
+url="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format"
+arch="all"
+license="GPL-2.0 and GPL-2.0-or-later and GPL-3.0 and MIT"
+depends="poppler-utils bc ttf-freefont"
+makedepends="cups-dev libjpeg-turbo-dev poppler-dev zlib-dev libpng-dev
+ tiff-dev lcms2-dev freetype-dev fontconfig-dev qpdf-dev dbus-dev linux-headers
+ coreutils gnutls-dev python3"
+checkdepends="ttf-dejavu"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://www.openprinting.org/download/cups-filters/cups-filters-$pkgver.tar.xz"
+builddir="$srcdir/cups-filters-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ --with-pdftops=pdftops \
+ --with-shell=/bin/sh \
+ --without-rcdir \
+ --without-rclevels \
+ --disable-avahi \
+ --disable-ghostscript \
+ --disable-mutool \
+ --with-test-font-path='/usr/share/fonts/ttf-dejavu/DejaVuSans.ttf'
+ # workaround parallel build issue by building libcupsfilters.la first
+ make libcupsfilters.la && make libfontembed.la && make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+ # the pdf.utf-8 symlink isn't quite good enough
+ cd "$pkgdir"/usr/share/cups/charsets && \
+ ln -s pdf.utf-8.simple pdf.UTF-8
+}
+
+dev() {
+ default_dev
+ # cupsfilters.drv needs pcl.h
+ install -Dm644 "$builddir"/filter/pcl.h \
+ "$pkgdir"/usr/share/cups/ppdc/pcl.h
+}
+
+libs() {
+ pkgdesc="OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="4b580734f7bac78c9d48aad7d8bb9e47227134e594fba76b1c82632fd8dd3e885f3897f7efd1a4b56647b74741f452f4e36d0157591c7fd5d626001028903d30 cups-filters-1.19.0.tar.xz"