summaryrefslogtreecommitdiff
path: root/system/curl
diff options
context:
space:
mode:
authorSheila Aman <sheila@vulpine.house>2021-11-07 09:05:06 -0800
committerSheila Aman <sheila@vulpine.house>2021-11-07 09:05:06 -0800
commitd045b5bca8cd983b9512fd45e19d2c5770323a32 (patch)
tree1a970980f607a132b3bd324721b727277edb8850 /system/curl
parent5cb8eeb287e3777076efee7392a107515f9fcc22 (diff)
downloadpackages-d045b5bca8cd983b9512fd45e19d2c5770323a32.tar.gz
packages-d045b5bca8cd983b9512fd45e19d2c5770323a32.tar.bz2
packages-d045b5bca8cd983b9512fd45e19d2c5770323a32.tar.xz
packages-d045b5bca8cd983b9512fd45e19d2c5770323a32.zip
system/curl: pull in nghttp2 for HTTP/2 support
Diffstat (limited to 'system/curl')
-rw-r--r--system/curl/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/system/curl/APKBUILD b/system/curl/APKBUILD
index 363b37de1..ecacc3a47 100644
--- a/system/curl/APKBUILD
+++ b/system/curl/APKBUILD
@@ -4,13 +4,13 @@
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=curl
pkgver=7.79.1
-pkgrel=0
+pkgrel=1
pkgdesc="A URL retrival utility and library"
url="https://curl.haxx.se"
arch="all"
license="MIT"
depends="ca-certificates"
-makedepends_build="perl"
+makedepends_build="perl nghttp2"
makedepends_host="zlib-dev openssl-dev libssh2-dev"
makedepends="$makedepends_build $makedepends_host"
source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz"
@@ -103,7 +103,8 @@ build() {
--without-libidn2 \
--disable-ldap \
--with-pic \
- --with-openssl
+ --with-openssl \
+ --with-nghttp2
make
}