summaryrefslogtreecommitdiff
path: root/system/dash/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-06-03 23:28:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-06-03 23:28:26 +0000
commitc201ddecae188890079cac20a53232c7f361e393 (patch)
tree20fab95232adc91c19d743eecbd1c0fc00b11ce2 /system/dash/APKBUILD
parent2f9cf649fd5ed77629c90f6a003eb2d303f61a71 (diff)
parent92563f5289c64332795cd296e2a9187a773f470c (diff)
downloadpackages-c201ddecae188890079cac20a53232c7f361e393.tar.gz
packages-c201ddecae188890079cac20a53232c7f361e393.tar.bz2
packages-c201ddecae188890079cac20a53232c7f361e393.tar.xz
packages-c201ddecae188890079cac20a53232c7f361e393.zip
Merge branch 'rootbld-providers' into 'master'
system/{bash-binsh,dash-binsh,build-tools}: add provider_priority This makes bash-binsh the default and should fix compatibility in /usr/bin/abuild for populating a chroot with only abuild, alpine-base (adelie-base), build-base (build-tools), and git See merge request !37
Diffstat (limited to 'system/dash/APKBUILD')
-rw-r--r--system/dash/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/system/dash/APKBUILD b/system/dash/APKBUILD
index f22c6c8eb..c1fbec305 100644
--- a/system/dash/APKBUILD
+++ b/system/dash/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dash
pkgver=0.5.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Small and fast POSIX-compliant shell"
url="http://gondor.apana.org.au/~herbert/dash/"
arch="all"
@@ -37,6 +37,7 @@ package() {
binsh() {
pkgdesc="Use dash as /bin/sh"
provides="/bin/sh"
+ provider_priority=1
mkdir -p "$subpkgdir"/bin
ln -s dash "$subpkgdir"/bin/sh
}