summaryrefslogtreecommitdiff
path: root/system/db
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-04 22:23:17 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-04 22:23:17 +0000
commit7bbcd1b84372873ca05e6d97a7849767ef7449db (patch)
tree11d99c6df970a7451fe813910c05548ba089d605 /system/db
parent99fdf2492680b0f36d96835f590a01a36b81b14d (diff)
downloadpackages-7bbcd1b84372873ca05e6d97a7849767ef7449db.tar.gz
packages-7bbcd1b84372873ca05e6d97a7849767ef7449db.tar.bz2
packages-7bbcd1b84372873ca05e6d97a7849767ef7449db.tar.xz
packages-7bbcd1b84372873ca05e6d97a7849767ef7449db.zip
system/db: fix FTBFS on pmmx
Diffstat (limited to 'system/db')
-rw-r--r--system/db/APKBUILD6
-rw-r--r--system/db/atomics.patch22
2 files changed, 26 insertions, 2 deletions
diff --git a/system/db/APKBUILD b/system/db/APKBUILD
index bf920315f..dabaa80cd 100644
--- a/system/db/APKBUILD
+++ b/system/db/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=db
pkgver=5.3.28
-pkgrel=0
+pkgrel=1
pkgdesc="The Berkeley DB embedded database system"
url="https://www.oracle.com/technology/software/products/berkeley-db/index.html"
arch="all"
@@ -11,6 +11,7 @@ depends=
makedepends=
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-c++:cxx"
source="http://download.oracle.com/berkeley-db/db-$pkgver.tar.gz
+ atomics.patch
"
prepare() {
@@ -57,4 +58,5 @@ cxx() {
mv "$pkgdir"/usr/lib/libdb_cxx*.so "$subpkgdir"/usr/lib/
}
-sha512sums="e91bbe550fc147a8be7e69ade86fdb7066453814971b2b0223f7d17712bd029a8eff5b2b6b238042ff6ec1ffa6879d44cb95c5645a922fee305c26c3eeaee090 db-5.3.28.tar.gz"
+sha512sums="e91bbe550fc147a8be7e69ade86fdb7066453814971b2b0223f7d17712bd029a8eff5b2b6b238042ff6ec1ffa6879d44cb95c5645a922fee305c26c3eeaee090 db-5.3.28.tar.gz
+8ba96cfc3e484a839b8651214f0769b35273c6235de7e53d5118eb0347f5a477f75e3336a12f1399b7748c6b6ab95aec39c8b813d7b227dd61f37ed4ab52f7d5 atomics.patch"
diff --git a/system/db/atomics.patch b/system/db/atomics.patch
new file mode 100644
index 000000000..ad3da2786
--- /dev/null
+++ b/system/db/atomics.patch
@@ -0,0 +1,22 @@
+diff --git a/src/dbinc/atomic.h b/src/dbinc/atomic.h
+index 0034dcc..fa7ba93 100644
+--- a/src/dbinc/atomic.h
++++ b/src/dbinc/atomic.h
+@@ -144,7 +144,7 @@ typedef LONG volatile *interlocked_val;
+ #define atomic_inc(env, p) __atomic_inc(p)
+ #define atomic_dec(env, p) __atomic_dec(p)
+ #define atomic_compare_exchange(env, p, o, n) \
+- __atomic_compare_exchange((p), (o), (n))
++ __db_atomic_compare_exchange((p), (o), (n))
+ static inline int __atomic_inc(db_atomic_t *p)
+ {
+ int temp;
+@@ -176,7 +176,7 @@ static inline int __atomic_dec(db_atomic_t *p)
+ * http://gcc.gnu.org/onlinedocs/gcc-4.1.0/gcc/Atomic-Builtins.html
+ * which configure could be changed to use.
+ */
+-static inline int __atomic_compare_exchange(
++static inline int __db_atomic_compare_exchange(
+ db_atomic_t *p, atomic_value_t oldval, atomic_value_t newval)
+ {
+ atomic_value_t was;