summaryrefslogtreecommitdiff
path: root/system/debianutils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-22 02:59:40 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-22 02:59:58 -0600
commitf730c188c7dc79f0a6bff9684a464c39a6158945 (patch)
tree12a64dac565311996501b41c85921e4f51f14131 /system/debianutils
parent645db1b26f930c1c262a8cc3ae566598563a4e34 (diff)
downloadpackages-f730c188c7dc79f0a6bff9684a464c39a6158945.tar.gz
packages-f730c188c7dc79f0a6bff9684a464c39a6158945.tar.bz2
packages-f730c188c7dc79f0a6bff9684a464c39a6158945.tar.xz
packages-f730c188c7dc79f0a6bff9684a464c39a6158945.zip
system/debianutils: split -which
Diffstat (limited to 'system/debianutils')
-rw-r--r--system/debianutils/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/system/debianutils/APKBUILD b/system/debianutils/APKBUILD
index be3f622b1..37267b3ec 100644
--- a/system/debianutils/APKBUILD
+++ b/system/debianutils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=debianutils
pkgver=4.8.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Useful utilities from Debian"
url="https://packages.qa.debian.org/d/debianutils.html"
arch="all"
@@ -11,7 +11,7 @@ license="BSD-3 GPL-2.0"
depends=""
makedepends="mawk grep" # early package, declare these
install=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-which"
source="http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_${pkgver}.tar.xz"
build() {
@@ -29,4 +29,9 @@ package() {
make DESTDIR="$pkgdir" install
}
+which() {
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/which "$subpkgdir"/usr/bin/
+}
+
sha512sums="22f27692a7d3847fad1be223d73e5575581db8621771e92e68fe91bd31e67084fd655fef857905be46ab3a45340503b0af9399b8fe28f221ea5cee4b49970821 debianutils_4.8.1.1.tar.xz"