summaryrefslogtreecommitdiff
path: root/system/e2fsprogs
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-22 22:38:00 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-22 22:38:17 +0000
commit985a48364f38b2e0bff2b8153711dd673f5dd759 (patch)
tree216a33dabb121a415c54370c47ee1d73ec20a9bb /system/e2fsprogs
parent5a11d291b9dacae7f1f23aa972c13bdc0fccc4ad (diff)
downloadpackages-985a48364f38b2e0bff2b8153711dd673f5dd759.tar.gz
packages-985a48364f38b2e0bff2b8153711dd673f5dd759.tar.bz2
packages-985a48364f38b2e0bff2b8153711dd673f5dd759.tar.xz
packages-985a48364f38b2e0bff2b8153711dd673f5dd759.zip
system/e2fsprogs: bugfix bump to 1.44.4
Diffstat (limited to 'system/e2fsprogs')
-rw-r--r--system/e2fsprogs/APKBUILD10
-rw-r--r--system/e2fsprogs/debugfs-spurious-message.patch28
-rw-r--r--system/e2fsprogs/header-fix.patch147
-rw-r--r--system/e2fsprogs/test-patch.patch41
4 files changed, 151 insertions, 75 deletions
diff --git a/system/e2fsprogs/APKBUILD b/system/e2fsprogs/APKBUILD
index 748fab308..211cf9aa9 100644
--- a/system/e2fsprogs/APKBUILD
+++ b/system/e2fsprogs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer:
pkgname=e2fsprogs
-pkgver=1.44.2
+pkgver=1.44.4
pkgrel=0
pkgdesc="Standard ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
@@ -13,8 +13,7 @@ depends_dev="util-linux-dev"
makedepends="$depends_dev linux-headers"
subpackages="$pkgname-lang $pkgname-dev $pkgname-doc libcom_err $pkgname-libs"
source="https://www.kernel.org/pub/linux/kernel/people/tytso/$pkgname/v$pkgver/$pkgname-$pkgver.tar.xz
- debugfs-spurious-message.patch
- test-patch.patch
+ header-fix.patch
"
build () {
@@ -59,6 +58,5 @@ libcom_err() {
mv "$pkgdir"/lib/libcom_err* "$subpkgdir"/lib/
}
-sha512sums="db34be8c2b606da565a46635d9ed859ccc28921c9a494dd90fbe461a400d0411b0ec6582d3a858adc916d68ec5e835814da798f1cb44710b75fc4efe0145eb90 e2fsprogs-1.44.2.tar.xz
-4e224a46beb73147485fe47de06bdf451c5a2fd4ea3835364f57d53d4ee80f2cb807a25bce40bacfa9abe1e0f81d1a4b1be5cb160b5c1103de6492288c5f8b7a debugfs-spurious-message.patch
-2718073be717f0f3b56147bb375fdffd3328cf920b12b474313f9c993184b73228b4478a91ba7913ef08a1119320ce1befe6eab20858c9ebc1c4b4890483f687 test-patch.patch"
+sha512sums="52e39565dee30997b9c245b5d8791844067a903a570082f3a5ff9d9ef96624535322617bb21029056c88259fef46416eb1181bd7aec419e64fc021830887ec8f e2fsprogs-1.44.4.tar.xz
+583c9133ea9df1fdffd2ec3d0234fbb3f36d180172a34ab5d8572434841690a08f1e045e189dc7e46b9396f49d4bd696335ef8625a033f969e26799f9b5c8a5b header-fix.patch"
diff --git a/system/e2fsprogs/debugfs-spurious-message.patch b/system/e2fsprogs/debugfs-spurious-message.patch
deleted file mode 100644
index 6ecb226da..000000000
--- a/system/e2fsprogs/debugfs-spurious-message.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 5f63e5c4f9c45abafe6ea2ee31b1e85c97bf6ef2 Mon Sep 17 00:00:00 2001
-From: Theodore Ts'o <tytso@mit.edu>
-Date: Sun, 24 Jun 2018 21:21:49 -0400
-Subject: debugfs: suppress spurious "checksum errors" message for unrelated
- failures
-
-Signed-off-by: Theodore Ts'o <tytso@mit.edu>
----
- debugfs/debugfs.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/debugfs/debugfs.c b/debugfs/debugfs.c
-index 2bf6a30..ecca810 100644
---- a/debugfs/debugfs.c
-+++ b/debugfs/debugfs.c
-@@ -172,7 +172,8 @@ static void open_filesystem(char *device, int open_flags, blk64_t superblock,
- try_open_again:
- retval = ext2fs_open(device, open_flags, superblock, blocksize,
- io_ptr, &current_fs);
-- if (retval && !(open_flags & EXT2_FLAG_IGNORE_CSUM_ERRORS)) {
-+ if (retval && (retval == EXT2_ET_SB_CSUM_INVALID) &&
-+ !(open_flags & EXT2_FLAG_IGNORE_CSUM_ERRORS)) {
- open_flags |= EXT2_FLAG_IGNORE_CSUM_ERRORS;
- printf("Checksum errors in superblock! Retrying...\n");
- goto try_open_again;
---
-cgit v1.1
-
diff --git a/system/e2fsprogs/header-fix.patch b/system/e2fsprogs/header-fix.patch
new file mode 100644
index 000000000..cc78a39d0
--- /dev/null
+++ b/system/e2fsprogs/header-fix.patch
@@ -0,0 +1,147 @@
+--- e2fsprogs-1.44.4/lib/ext2fs/hashmap.h.old 2018-10-22 22:12:54.700000000 +0000
++++ e2fsprogs-1.44.4/lib/ext2fs/hashmap.h 2018-10-22 22:13:49.010000000 +0000
+@@ -17,12 +17,12 @@
+ struct ext2fs_hashmap_entry *next;
+ struct ext2fs_hashmap_entry *list_next;
+ struct ext2fs_hashmap_entry *list_prev;
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wpedantic"
+ #endif
+ } *entries[0];
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+ };
+--- e2fsprogs-1.44.4/misc/e2undo.c.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/misc/e2undo.c 2018-10-22 22:25:35.130000000 +0000
+@@ -81,12 +81,12 @@
+ __le32 magic; /* KEYBLOCK_MAGIC number */
+ __le32 crc; /* block checksum */
+ __le64 reserved; /* zero */
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wpedantic"
+ #endif
+ struct undo_key keys[0]; /* keys, which come immediately after */
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+ };
+--- e2fsprogs-1.44.4/misc/filefrag.c.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/misc/filefrag.c 2018-10-22 22:26:04.730000000 +0000
+@@ -535,7 +535,7 @@
+ char *end;
+ blocksize = strtoul(optarg, &end, 0);
+ if (end) {
+-#if __GNUC_PREREQ (7, 0)
++#if defined(__GNUC__) && (__GNUC__ >= 7)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wimplicit-fallthrough"
+ #endif
+@@ -555,7 +555,7 @@
+ default:
+ break;
+ }
+-#if __GNUC_PREREQ (7, 0)
++#if defined(__GNUC__) && (__GNUC__ >= 7)
+ #pragma GCC diagnostic pop
+ #endif
+ }
+--- e2fsprogs-1.44.4/lib/ext2fs/fiemap.h.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/lib/ext2fs/fiemap.h 2018-10-22 22:21:59.110000000 +0000
+@@ -31,12 +31,12 @@
+ __u32 fm_mapped_extents;/* number of extents that were mapped (out) */
+ __u32 fm_extent_count; /* size of fm_extents array (in) */
+ __u32 fm_reserved;
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wpedantic"
+ #endif
+ struct fiemap_extent fm_extents[0]; /* array of mapped extents (out) */
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+ };
+--- e2fsprogs-1.44.4/lib/ext2fs/ext4_acl.h.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/lib/ext2fs/ext4_acl.h 2018-10-22 22:18:32.390000000 +0000
+@@ -50,12 +50,12 @@
+
+ typedef struct {
+ __le32 a_version;
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wpedantic"
+ #endif
+ posix_acl_xattr_entry a_entries[0];
+-#if __GNUC_PREREQ (4, 8)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+ } posix_acl_xattr_header;
+--- e2fsprogs-1.44.4/lib/ext2fs/unix_io.c.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/lib/ext2fs/unix_io.c 2018-10-22 22:20:38.770000000 +0000
+@@ -1127,7 +1127,7 @@
+ }
+
+ /* parameters might not be used if OS doesn't support zeroout */
+-#if __GNUC_PREREQ (4, 6)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wunused-parameter"
+ #endif
+@@ -1197,7 +1197,7 @@
+ unimplemented:
+ return EXT2_ET_UNIMPLEMENTED;
+ }
+-#if __GNUC_PREREQ (4, 6)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+
+--- e2fsprogs-1.44.4/lib/ext2fs/mmp.c.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/lib/ext2fs/mmp.c 2018-10-22 22:21:10.640000000 +0000
+@@ -34,7 +34,7 @@
+ #define O_DIRECT 0
+ #endif
+
+-#if __GNUC_PREREQ (4, 6)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #ifndef CONFIG_MMP
+ #pragma GCC diagnostic ignored "-Wunused-parameter"
+@@ -467,6 +467,6 @@
+ return EXT2_ET_OP_NOT_SUPPORTED;
+ #endif
+ }
+-#if __GNUC_PREREQ (4, 6)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+--- e2fsprogs-1.44.4/debugfs/set_fields.c.old 2018-08-19 02:26:58.000000000 +0000
++++ e2fsprogs-1.44.4/debugfs/set_fields.c 2018-10-22 22:22:34.510000000 +0000
+@@ -75,7 +75,7 @@
+ static errcode_t parse_mmp_clear(struct field_set_info *info, char *field,
+ char *arg);
+
+-#if __GNUC_PREREQ (4, 6)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4)
+ #pragma GCC diagnostic push
+ #pragma GCC diagnostic ignored "-Wmissing-field-initializers"
+ #endif
+@@ -291,7 +291,7 @@
+ { "checksum", &set_mmp.mmp_checksum, NULL, 4, parse_uint },
+ { 0, 0, 0, 0 }
+ };
+-#if __GNUC_PREREQ (4, 6)
++#if defined(__GNUC__) && ((__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4)
+ #pragma GCC diagnostic pop
+ #endif
+
diff --git a/system/e2fsprogs/test-patch.patch b/system/e2fsprogs/test-patch.patch
deleted file mode 100644
index 149124561..000000000
--- a/system/e2fsprogs/test-patch.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 579e9ae1ddd15d7f9c9d01b23133b6187ae1b2b9 Mon Sep 17 00:00:00 2001
-From: Theodore Ts'o <tytso@mit.edu>
-Date: Mon, 25 Jun 2018 09:43:18 -0400
-Subject: tests: fix up f_detect_junk and f_detect_xfs
-
-The golden output files for these two tests were out of date.
-
-Signed-off-by: Theodore Ts'o <tytso@mit.edu>
----
- tests/f_detect_junk/expect | 1 -
- tests/f_detect_xfs/expect | 1 -
- tests/f_detect_xfs/expect.nodebugfs | 2 --
- 3 files changed, 4 deletions(-)
-
-diff --git a/tests/f_detect_junk/expect b/tests/f_detect_junk/expect
-index 59f34b8..39f99af 100644
---- a/tests/f_detect_junk/expect
-+++ b/tests/f_detect_junk/expect
-@@ -13,7 +13,6 @@ is corrupt, and you might try running e2fsck with an alternate superblock:
-
- *** debugfs
- test.img: Bad magic number in super-block while opening filesystem
--Checksum errors in superblock! Retrying...
- *** tune2fs
- ../misc/tune2fs: Bad magic number in super-block while trying to open test.img
- *** mke2fs
-diff --git a/tests/f_detect_xfs/expect b/tests/f_detect_xfs/expect
-index fb510d9..a48e8af 100644
---- a/tests/f_detect_xfs/expect
-+++ b/tests/f_detect_xfs/expect
-@@ -14,7 +14,6 @@ is corrupt, and you might try running e2fsck with an alternate superblock:
- test.img contains a xfs file system labelled 'test_filsys'
- *** debugfs
- test.img: Bad magic number in super-block while opening filesystem
--Checksum errors in superblock! Retrying...
- test.img contains a xfs file system labelled 'test_filsys'
- *** tune2fs
- ../misc/tune2fs: Bad magic number in super-block while trying to open test.img
---
-cgit v1.1
-