summaryrefslogtreecommitdiff
path: root/system/easy-kernel/0202-fix-gcc13-build.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-10-02 00:03:08 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-10-03 21:56:52 -0500
commitee71f0098a7782c4a95c2f1d7ee614569214be1c (patch)
tree120b55e6bde7f7f7f726ba8b34355bccbbc79482 /system/easy-kernel/0202-fix-gcc13-build.patch
parent8b868f32f7e1b57c90da65157ea59eb6ce337cc9 (diff)
downloadpackages-ee71f0098a7782c4a95c2f1d7ee614569214be1c.tar.gz
packages-ee71f0098a7782c4a95c2f1d7ee614569214be1c.tar.bz2
packages-ee71f0098a7782c4a95c2f1d7ee614569214be1c.tar.xz
packages-ee71f0098a7782c4a95c2f1d7ee614569214be1c.zip
system/easy-kernel: Update to 5.15.132-mc6
* Adds exFAT module to all architectures. * Adds Hyper-V guest support to aarch64. * Fixes audio output issues on some PowerBook models.
Diffstat (limited to 'system/easy-kernel/0202-fix-gcc13-build.patch')
-rw-r--r--system/easy-kernel/0202-fix-gcc13-build.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/system/easy-kernel/0202-fix-gcc13-build.patch b/system/easy-kernel/0202-fix-gcc13-build.patch
new file mode 100644
index 000000000..9e0944512
--- /dev/null
+++ b/system/easy-kernel/0202-fix-gcc13-build.patch
@@ -0,0 +1,11 @@
+--- a/scripts/gcc-plugins/Makefile 2023-02-02 14:04:11.084280229 -0500
++++ b/scripts/gcc-plugins/Makefile 2023-02-02 14:04:54.084396776 -0500
+@@ -23,7 +23,7 @@ GCC_PLUGINS_DIR = $(shell $(CC) -print-f
+
+ plugin_cxxflags = -Wp,-MMD,$(depfile) $(KBUILD_HOSTCXXFLAGS) -fPIC \
+ -include $(srctree)/include/linux/compiler-version.h \
+- -I $(GCC_PLUGINS_DIR)/include -I $(obj) -std=gnu++11 \
++ -I $(GCC_PLUGINS_DIR)/include -I $(obj) \
+ -fno-rtti -fno-exceptions -fasynchronous-unwind-tables \
+ -ggdb -Wno-narrowing -Wno-unused-variable \
+ -Wno-format-diag